Results 1 to 4 of 4

Thread: N810 Users Fix for email client IMAP

  1. #1
    Join Date
    Sep 2007
    Posts
    80
    Rep Power
    8

    Thumbs up N810 Users Fix for email client IMAP

    After upgrading my Nokia N810 to the newest (diablo) firmware. My email hasn't worked. I knew they switched email clients to the new Modest client after setting up my account on my n810 about 5 times with different account details (always using IMAP) I would get the same result. A drafts folder would pop up and it would say connecting indefinitely.

    Come to find out that the Modest client uses IMAP-IDLE and after some googling I also find out that it is disabled by default in zimbra.

    To find out whether or not IMAP-IDLE is enabled on your server:
    Code:
    su - zimbra or sudo su zimbra (which ever you prefer)
    Code:
    zmlocalconfig | grep nio_imap_enable
    if your output looks like this:
    Code:
    nio_imap_enable = false
    nio_imap_enabled = false
    and you do want to enable IMAP-IDLE you can run this command:
    Code:
    zmlocalconfig -e nio_imap_enable=true
    zmlocalconfig -e nio_imap_enabled=true
    and finally you can restart your server with:
    Code:
    zmcontrol stop && zmcontrol start

    Congratulations! Your freshly upgraded N810 works with Zimbra!
    The only issue I have found so far is that for some reason I keep getting a tag created called $Label1 other than that IMAP is working on N810
    Last edited by cornbread; 07-09-2008 at 09:48 AM.

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    You have confused IMAP IDLE and our beta NIO IMAP implementation. You're welcome to beta-test NIO IMAP for us, but it is not GA-certified yet and as such you're running a risk.

    You should file a bug and include an IMAP protocol trace from the server.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jul 2008
    Posts
    1
    Rep Power
    7

    Default

    So how do you enable IMAP IDLE then?

    I am testing with a Blackberry Pearl. I have it setup with gmail and email is instant, but is delayed from the Zimbra server. I suspect it doesn't support IMAP IDLE somehow or is not enabled?

  4. #4
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    IMAP IDLE should be enabled by default on 5.0.1.

    Please open a bug report in bugzilla if you're not seeing it work. Include your mobile device type as well as the exact version of the Zimbra server that you're running!
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. users kicked out of web client, expires
    By nate.wheeler in forum Administrators
    Replies: 9
    Last Post: 03-11-2010, 12:43 AM
  2. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 05:53 PM
  3. [SOLVED] Enabling IMAP for users created with 'zmprov'?
    By deckard in forum Administrators
    Replies: 1
    Last Post: 10-26-2007, 11:42 AM
  4. Replies: 4
    Last Post: 08-23-2007, 08:31 AM
  5. Nee a head start with IMAP client to access Zimbra mails
    By abhishek_agl in forum Developers
    Replies: 14
    Last Post: 12-08-2006, 02:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •