Results 1 to 4 of 4

Thread: Zimbra php email question

  1. #1
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default Zimbra php email question

    I have a web server, then a separate zimbra email server.
    I have some web forms sending php emails from the web server.

    How do I setup php on the web server to talk with the zimbra server...?

    On the web server, in the php.ini file I have:
    Code:
    [mail function]
    ; For Win32 only.
    SMTP = localhost
    smtp_port = 25
    
    ; For Win32 only.
    sendmail_from = user@zimbradomain.com
    
    ; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
    sendmail_path = /usr/sbin/sendmail -t -i
    I tried changing the SMTP setting to mail.zimbradomain.com
    But it made no difference..

    Is zimbra blocking the php email?

    Please help, I'm confused and don't understand what would be the correct settings...

    Thanks!

  2. #2
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    Wow...no takers? Hmm.... Do you need more info? Or am I just confusing everyone?

    Maybe I could clarify...

    - Does Zimbra allow php email from another server over the LAN?
    - Does Zimbra allow other services to use it's SMTP server?
    - If yes, what settings are needed on the zimbra server to enable this?

    Thanks.

  3. #3
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    depends on whether the mail function uses smtp or sendmail, depending on platform and setup of php. instead of /usr/sbin/sendmail, try /opt/zimbra/postfix/sbin/sendmail.

  4. #4
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    linux NOT windows....

    I'll try that and see if it works...

Similar Threads

  1. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 10:13 AM
  2. Replies: 8
    Last Post: 02-27-2007, 03:10 AM
  3. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  4. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •