Results 1 to 2 of 2

Thread: Non-ASCII chars, iCal and ZCS

  1. #1
    Join Date
    Aug 2008
    Location
    Montreal
    Posts
    31
    Rep Power
    7

    Default Non-ASCII chars, iCal and ZCS

    I just found a major problem between iCal, ZCS, Mail and non-ASCII chars. First I created an event in a local calendar with the following subject :



    And I invited my ZCS account and sent out the invitation. The invitation subject is ok when I view it in ZCS Web client :



    But things go ugly after I accept the invitation. The answer look like this :



    And in the calendar, the event look like this :



    So it look like ZCS can't deal with non-ASCII chars in events. One thing I did notice, Mail and iCal seems to use Windows-Latin-1 as the encoding for the invitation :

    Subject: =?WINDOWS-1252?Q?_Tes?=
    =?WINDOWS-1252?Q?t_accents_=E9=E8=E0=E7=F9=E7?=
    X-Mail-Calendar-Part: Yes
    Date: Tue, 14 Oct 2008 10:41:26 -0400
    X-Mailer: Apple Mail (2.929.2)


    --Apple-Mail-9-874950417
    Content-Type: text/plain;
    charset=WINDOWS-1252;
    format=flowed;
    delsp=yes
    Content-Transfer-Encoding: quoted-printable


    But ZCS reply is done in UTF-8 :

    Subject: =?utf-8?Q?Accepter:_Test_a?= =?utf-8?Q?ccents_=EF=BF=BD?=
    =?utf-8?Q?=EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD?=
    =?utf-8?Q?=EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD? =
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_Part_928_503477018.1223994496885"
    X-Originating-IP: [xxx.xxx.xxx.xxx]
    X-Mailer: Zimbra 5.0.9_GA_2533.RHEL5_64 (ZimbraWebClient - SAF3 (Mac)/5.0.9_GA_2533.RHEL5_64)

    ------=_Part_928_503477018.1223994496885
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: quoted-printable

    Sujet=C2=A0: Test accents =EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=
    =BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD=EF=BF=BD=20
    Organisateur: probert@os.ca=20

    Heure: Mardi 14 Octobre 2008, 13:45:00 - 14:45:00 (GMT-0500) America/Montre=
    al
    =20
    Invit=C3=A9s: "Pascal Robert" <probert@macti.ca>; "probert" <probert@os.ca>=
    =20

    *~*~*~*~*~*~*~*~*~*


    Oui, je serai pr=C3=A9sent.


    ------=_Part_928_503477018.1223994496885
    Content-Type: text/html; charset=utf-8


    I guess that's part of the problem?
    ZCS 6.05 on CentOS 5.3 (VMWare ESX 4)

  2. #2
    Join Date
    Aug 2008
    Location
    Montreal
    Posts
    31
    Rep Power
    7

    Default

    I can confirm that this problem doesn't appear between Outlook (with the connector) and iCal.
    ZCS 6.05 on CentOS 5.3 (VMWare ESX 4)

Similar Threads

  1. CalDAV in iCal Not Syncing Shared Calendars
    By billglick in forum CalDAV / CardDAV / iSync
    Replies: 6
    Last Post: 06-25-2012, 09:18 AM
  2. Leopard iCal and ZCS iSync connector, duplicate events
    By nsmarler in forum CalDAV / CardDAV / iSync
    Replies: 7
    Last Post: 03-21-2011, 11:03 AM
  3. iCal not syncing properly with Zimbra
    By patrickachu in forum CalDAV / CardDAV / iSync
    Replies: 2
    Last Post: 08-27-2008, 09:01 AM
  4. iCal and ZCS, is this the correct behavior?
    By ArTT Vandelay in forum CalDAV / CardDAV / iSync
    Replies: 4
    Last Post: 07-28-2008, 02:08 PM
  5. Private calendar events between Zimbra and iCal
    By nsmarler in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 04-28-2008, 10:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •