Results 1 to 5 of 5

Thread: Logging in changes address to supposed FQDN

  1. #1
    Join Date
    Feb 2006
    Location
    Boston
    Posts
    38
    Rep Power
    9

    Unhappy Logging in changes address to supposed FQDN

    Hi Guys,

    I recently upgraded to the latest Debian Beta and there seems to be a change in the way Zimbra handles the address of the machine.
    Basically when I try to login to Zimbra it changes the address to the hostname and domain name I supply the server with. This is ok in my home network but I don't have a pretty (and static) fqdn outside. The behavior used to be it kept the name i signed in with, now something is rewriting the address which breaks things when I'm not inside my network.

    Any suggestions?

    -J

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Yes we made this change to get the user back on the right machine for a load balanced situation. Can you give more details about the hostnames your trying to use. We thought if we just didn't rewrite the address when it's localhost or an IP address that that'd cover the odd uses but seems there are more. Can you give us some more info on your use case? Thanks.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Feb 2006
    Location
    Boston
    Posts
    38
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Can you give more details about the hostnames your trying to use. Thanks.
    Well, I have DynDNS address ('Q'.homeip.net) I use to initially connect to my firewall (m0n0wall) which I setup to just NAT me over to my debian box on https. The fqdn I setup in my firewall uses domain .maxxnet.net and the hostname it tells the machine to use is mail. I mirrored these settings in the /etc/hosts .

    This of course breaks the connection when the address changes to mail.maxxnet.net from the Q.homeip.net I need to connect in.

  4. #4
    Join Date
    Feb 2006
    Location
    Boston
    Posts
    38
    Rep Power
    9

    Unhappy

    Sorry to pester, any resolution on this? Can this be a switch or something?

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    In 3.1 you can add ?redirect=0 to your URL to stop the redirect. The only other solution would be to have a DNS entry for both your internal/external hostname.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 12:41 PM
  2. Change Install Admin Email Address
    By soxfan in forum Administrators
    Replies: 4
    Last Post: 11-01-2007, 05:10 AM
  3. [SOLVED] Zimbra not syncing properly with Address Book and iCal
    By Colin Day in forum CalDAV / CardDAV / iSync
    Replies: 4
    Last Post: 07-13-2007, 09:52 AM
  4. Replies: 4
    Last Post: 10-18-2006, 08:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •