Results 1 to 3 of 3

Thread: [SOLVED] MacOS, .11 and the "@" character

  1. #1
    Join Date
    Mar 2007
    Posts
    10
    Rep Power
    8

    Default [SOLVED] MacOS, .11 and the "@" character

    strange, strange.

    today my wife wanted to compose a message and told me that the she cant enter "@" into the email-adress. first i didnt believe her as i had sent a mail today without troubles.

    she insists so i checked it and - voila - on her macboc (10.5.5) she cant enter "@" into "To:", "CC:", "Subject:" and not even into the message. the key simply wouldnt work (its ALT-L as we have german mac keyboards).
    other special chars with ALT are working fine, entering "@" into the browsers adress-line or searchfield, entering "@" into other apps and webapps ... and entering "@" in the zimbra adress-book, calendar etc will work too !!!
    just the mail-part will take no "@" ...

    further tests show that
    .) the problem is on both safari and firefox 3
    .) firefox in ubuntu works fine (thats why i had no problem)
    .) a second macbook (10.5.5 too) show the same symptoms

    on monday i did the update to 5.0.11 ...

    dunno what happens here.
    didnt find any other post on this problem but "@ mac" is a difficult search-term i guess.

    has anybody a clue ?

    wbr,tja...

    EDIT: added forgotten info about the update.
    Last edited by tja; 12-01-2008 at 03:21 PM.

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    That's Bug 28221 - [Mac] shortcut "Alt+L" coflicts with "@" char on german mac keyboard fixed for GNR 6.0.

    Workaround is to change the shortcuts for low priority:
    /opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/classes/keys ZmKeys_de.properties &
    ZhKeys_de.properties

    You could either create .mac values:
    compose.LowPriority.display = Alt+L
    compose.LowPriority.display.mac = Alt+value
    compose.LowPriority.keycode = Alt+76
    compose.LowPriority.keycode.mac = Alt+value

    Or change it to what it's going to be for 6.0 and not mess with specific .os attributes:
    compose.LowPriority.display = Ctrl+P,Ctrl+L
    compose.LowPriority.keycode = Ctrl+80,Ctrl+76
    compose.LowPriority.description = Low priority
    compose.LowPriority.sort = 30110

    su - zimbra
    zmmailboxdctl restart

  3. #3
    Join Date
    Mar 2007
    Posts
    10
    Rep Power
    8

    Default

    Quote Originally Posted by mmorse View Post
    ah, should have searched for Alt+L then.
    Quote Originally Posted by mmorse View Post
    Workaround is to change the shortcuts for low priority:
    /opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/classes/keys ZmKeys_de.properties &
    ZhKeys_de.properties
    ...
    Or change it to what it's going to be for 6.0 and not mess with specific .os attributes:
    compose.LowPriority.display = Ctrl+P,Ctrl+L
    compose.LowPriority.keycode = Ctrl+80,Ctrl+76
    compose.LowPriority.description = Low priority
    compose.LowPriority.sort = 30110
    ok, did that:
    Code:
    for f in *; do sed -i 's/Alt+L/Ctrl+P,Ctrl+L/g' $f; done
    for f in *; do sed -i 's/Alt+76/Ctrl+80,Ctrl+76/g' $f; done
    restarted zimbra and relog and the mac is able to send mails again, thank you very much.

    wbr,tja...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •