Results 1 to 10 of 10

Thread: Mailto: links in a multi-user environment

Hybrid View

  1. #1
    Join Date
    Jul 2009
    Posts
    3
    Rep Power
    6

    Default Mailto: links in a multi-user environment

    Hi folks,

    I'm a new sys admin in an FE college in Wales We use Zimbra for staff email and Gmail for students. Firefox is our standard browser. The only complaint we get from staff about the current set-up is that clicking on mailto: links in webpages doesn't bring up a 'compose' page in Zimbra.

    Googling hasn't come up with a solution. Zimbra Desktop, Toaster etc. don't appear to work in multi-user environments and there is no way (yet) to change the behaviour of Firefox to be Zimbra friendly. Has anyone got an answer to this issue? I'm sure we're not the only college with this problem.

    TIA

    Huw

  2. #2
    Join Date
    Jul 2009
    Posts
    3
    Rep Power
    6

    Default

    Any suggestions?

  3. #3
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    i think if you install the zimbra toaster it can handle mailto redirects

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    oh I see. Currently I don't think you can but you should be able to soon. Basically in firefox you can modify the way it handles mailto: links as explained here

    https://developer.mozilla.org/en/Web...tocol_handlers . The only problem is that currently if you set this up for zimbra it passes the whole mailto:address portion into the to: field. Zimbra does not currently parse this correctly to remove the mailto: portion, but apparently it will in 5.0.19

    Bug 39239 – Mailto: link arguments not parsed

  5. #5
    Join Date
    Feb 2010
    Posts
    14
    Rep Power
    5

    Default

    For firefox you can install this extension:

    Mailto Links and Zimbra [How to] - Zomgee

    The only flaw is that the new line, new paragraph mark for "body=blabla" does not work

    Should be something like taking this '%0%A' and replacing by something Zimbra's message pane knows how to interpret

    Anybody knows how to fix it?

  6. #6
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    firefox has built in support for this now and it's a lot easier

    http://www.zimbra.com/forums/develop...tml#post106937

  7. #7
    Join Date
    Jul 2009
    Posts
    3
    Rep Power
    6

    Default

    I'm sure it can. But can it do it in a multi-user environment? Another posting here said that that feature will be implemented 'after version 1.0' of Toaster.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •