Results 1 to 3 of 3

Thread: [SOLVED] Instant messaging window loses focus

  1. #1
    Join Date
    Sep 2009
    Posts
    4
    Rep Power
    6

    Default [SOLVED] Instant messaging window loses focus

    Hey everyone,

    We use Zimbra here in our school district. Great email platform[although I'd love to see backup available in the open source version that's the one thing that stopped me from using it myself].

    My question is about the chat box. I couldn't tell you exactly what version of Zimbra we're running since I'm only a user of the email system and the IT staff at the board office handle the mail server. But I'm wondering if any of you have experienced issues with the instant messaging boxes. I like the fact that they're integrated and that you can use them within the email program. The problem I'm having is that if I'm having a conversation with someone, and I'm typing, and they send a message while I'm still typing, for some reason the text cursor leaves the chat window, the main Zimbra interface gains focus, and since I was in the middle of typing, I realize that at the moment the text stopped being entered in the instant messaging window, I'm now typing keyboard shortcuts and doing random things like starting a new email, deleting an email, creating a new contact, completely by accident. I have to revert any changes, go back to my inbox, then click back to the instant messaging window and continue typing. This happens every single time an IM comes in while I'm typing. I tried searching the forums but I couldn't find anything on this. Is there any plans for this to be fixed? Also, it would be nice to only hear the new instant message chime if I receive a new IM and the IM window is not the active window, instead of every time even if I'm in the instant messaging window already.
    Last edited by link470; 05-04-2010 at 12:58 PM.

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    if i had to guess i'd say it was the sound playing htat is causing this. for some reason just playing a simple wav still requires like quicktime plugins for browsers. the loading of the plugin is notorious for causing focus issues

    try turning off the option to play a sound when an IM arrives and see if that fixes the problem. unfortunately if that is the problem i'm not sure what you or even zimbra could do about it.

  3. #3
    Join Date
    Sep 2009
    Posts
    4
    Rep Power
    6

    Default

    Ah, thanks! Worked perfectly, I disabled the sound in IM prefs and now the cursor doesn't jump around.

    A suggestion though. Not sure how hard this would be, but it would be awesome if the sound only played if the IM window wasn't highlighted [such as Google Talk within Gmail], and then stopped playing when the chat window was active.

Similar Threads

  1. Are you using IM Instant Messaging - Questions of scale
    By bowergo in forum Administrators
    Replies: 1
    Last Post: 09-17-2009, 12:25 PM
  2. Instant Messaging (IM) related questions
    By jasper in forum Developers
    Replies: 0
    Last Post: 04-15-2008, 05:37 AM
  3. XMPP Instant Messaging??
    By lisha in forum Installation
    Replies: 0
    Last Post: 01-22-2008, 07:50 AM
  4. Instant Messaging
    By folioguru in forum Installation
    Replies: 1
    Last Post: 01-08-2008, 06:15 AM
  5. Instant messaging
    By mansuper in forum Users
    Replies: 1
    Last Post: 08-09-2006, 08:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •