Hello, I've been looking through these forums, along with google trying to find answers to the problems I've been having with getting zimbra to work. Basically these are my problems:

Enable DNS lookups--SMTP works fine, mail is sent. Great. However, when looking at the logs, I see Oct 16 02:10:34 atcdirect postfix/smtp[1499]: 24EAD2D1900: to=<username@www.atcdirect.com>, relay=none, delay=30, status=deferred (connect to www.atcdirect.com[66.15.163.221]: Connection timed out)
*note, this was just atcdirect.com, but I added a hostname www to the front. shouldn't change anything.

When I remove DNS lookups, mail gets recieved just fine, but nothing will send. Either pingouts (to gmail.com because it doesn't resolve to google servers) or a 553 'this host is not allowed' error.

The last thing that doesn't seem to work is remote STMP authentication. It keeps prompting for a password in thunderbird and the logs return:
warning: SASL authentication failure: Password verification failed
Oct 16 02:09:10 atcdirect postfix/smtpd[30256]: warning: c-24-18-79-68.hsd1.wa.comcast.net[24.18.79.68]: SASL PLAIN authentication failed
Oct 16 02:09:10 atcdirect postfix/smtpd[30256]: warning: c-24-18-79-68.hsd1.wa.comcast.net[24.18.79.68]: SASL LOGIN authentication failed

In webmail, it seems like sending/recieving works just fine. Recieving mail in thunderbird works fine now that I've forwarded port 110 to 995 (the firewall on this network is really limiting towards ports.)

Hopefully someone can help. The 'disable_dns' page was helpful at first when I noticed I could recieve mail. but now that I can't send it, it hasn't really helped much.

Thank you!
Jakob