Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Default font type, color and size

  1. #1
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default Default font type, color and size

    I looked at the forums but couldn't find anything related.

    Wanted to understand if I can set a default font type, color and size while composing E-mails or creating a Wiki page or Writing an Event/Appointment.

    The editor is defaulting to Times New Roman, 3pts, Normal, Black. Same goes for the Signature, too.

    I would like to change it, for example, to Verdana, 2pts, Normal, Blue. (Both, the content and while composing E-mails, the Signature).

    Any ideas how I can do this?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  2. #2
    Join Date
    Oct 2005
    Location
    Belgium
    Posts
    68
    Rep Power
    10

    Default

    You could set this in zcs 3.x, but they removed it from this version (Don't know why).
    The configuration still exist in ldap. You can use zmprov to set this. look for entries

    zimbraPrefHtmlEditorDefaultFontColor: #000000
    zimbraPrefHtmlEditorDefaultFontFamily: Arial
    zimbraPrefHtmlEditorDefaultFontSize: 10pt

  3. #3
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Thank-you very much StefanD,

    This will be very useful for one domain in which I am the only user.

    However, not all will be happy with my preferences. And this will not help me have different styles for the signature.

    Do you have any idea how I can set this on a per user basis?

    Thanks,
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  4. #4
    Join Date
    Oct 2005
    Location
    Belgium
    Posts
    68
    Rep Power
    10

    Default

    Do you have any idea how I can set this on a per user basis?
    This is per user basis.
    I found the options using: zmprov ga your_account@your.domain

  5. #5
    Join Date
    Apr 2006
    Location
    Switzerland
    Posts
    46
    Rep Power
    9

    Default

    Hello,

    same font problem here. While using Zimbra 3.1.4 I set "Verdana" as prefered font type. After upgrade to 4.0.0 Times is used instead, but in LDAP there is the correct font (Verdana).

    Code:
    zimbraPrefHtmlEditorDefaultFontFamily: Verdana
    Same with other users on my systems...

    What's going wrong?

    Thanks
    McPringle

  6. #6
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    10

    Default

    Yes, this was purposefully taken out.

    Not to go into too much technical detail, the code setting the default font settings was flaky. We saw cases (re: complaints) where it would not obey these settings (for unknown reasons).

    Not to mention, it caused an annoying bug with trying to cancel compose - the user would get prompted to Save As Draft when nothing was yet entered (seems unrelated, but its not).

    Basically, the logic of the code made sense but due to browser quirkiness (particularly w/ design mode), it didnt always work.

    Nevertheless, I have created a new enhancement request to get this feature back into the web client (and hopefully get it done right this time!)

    Please vote for it here:
    http://bugzilla.zimbra.com/show_bug.cgi?id=10526
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Thanks pshah,

    My vote has been added.

    Regards,
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  8. #8
    Join Date
    Apr 2006
    Location
    Switzerland
    Posts
    46
    Rep Power
    9

    Default

    Quote Originally Posted by pshah
    Thanks, done!

  9. #9
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default

    In the meantime, can I request that if a feature is removed like this, it is removed from the online help also?

    I have users complaining about this because they can see the option in the help but it's not there in the actual interface?

  10. #10
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default

    Quote Originally Posted by pshah
    Yes, this was purposefully taken out.

    Not to go into too much technical detail, the code setting the default font settings was flaky. We saw cases (re: complaints) where it would not obey these settings (for unknown reasons).
    just another quick question on this...

    You implied that just the web gui setting of this default was removed, but I've just set
    zimbraPrefHtmlEditorDefaultFontColor: #000000
    zimbraPrefHtmlEditorDefaultFontFamily: Arial
    zimbraPrefHtmlEditorDefaultFontSize: 10pt

    and given everything a restart and it's still not honoured in the compose new html email....

    So that I don't spend any more time messing with it, has the "compose new html message" been changed not to look at these attributes any more? So there's absolutely no way I could set this on a per user basis even from the command line?

    Thanks,
    Keith
    Last edited by keithop; 09-12-2006 at 07:08 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •