Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Admin message to all accounts?

  1. #1
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    10

    Default Admin message to all accounts?

    Is there a way to easily send an administrative message to all accounts in all domains on the system?

  2. #2
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default

    Quote Originally Posted by Billy
    Is there a way to easily send an administrative message to all accounts in all domains on the system?
    I haven't seen a built in way to do that, and indeed, that would be a useful feature.

    In the meantime, you can do this from the command line. The quick and dirty way is just like this:

    mail -s "Hello World" `zmprov GetAllAccounts` < email_body.txt

    The "zmprov GetAllAccounts" command returns a list of all the accounts, which is the email address of each user. So, the above would send an email to all accounts, with the subject "Hello World", using the message body contained in "email_body.txt".

    You could also use "zmprov GetAllAccounts" to get your email address list, then just load that into Thunderbird or Outlook or whatever, then send it from there.

    Have a good one,
    -Eric

  3. #3
    Join Date
    Apr 2010
    Posts
    29
    Rep Power
    5

    Question

    I know the thread is very old, but I just looked for the same feature.

    Can anybody tell if there is a way to send an admin-mail to all accounts in the current zimbra version?

    In the moment I do this with a distribution list for every domain each with every account from this domain in it. To avoid that anyone uses them and to avoid spam I activate the "can receive mail"-checkbox only when I need it - but this is not a very usefull way as anyone can guess...

    Any suggestions? (The CLI-version is less usefull in my opinion... ;-) )

    Greets,
    Steffen

  4. #4
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    Any way to run this command using bcc instead of listing all user in the to field? As this behavior is very rude

    mail -s "NEW ZIMLETS ANYONE?" `zmprov GetAllAccounts` < admin_message_zimlets
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  5. #5
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    Great as rude as this command is adding all addresses to the "TO:" field. It has now stopped working?? can someone confirm if it works in 7.0.0????

    $ mail -s "ZIMBRA UPGRADE" `zmprov GetAllAccounts` < /usr/src/admin_message_upgrade_7.0.0

    ERROR: service.INVALID_REQUEST (invalid request: can only be used with "zmprov -l/--ldap")
    mail: You must specify direct recipients with -s, -c, or -b

    PS I know their is a bug files somewhere to get Zimbra to send to all account, I am super frustrated today so forgive me, but I have requested this feature many time here on the forums usually without reply.
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  6. #6
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    Sometime Zimbra really annoys me still help or feature in regards to this post this is a feature that is asked for again and again. Not just by me but probably everyone in the community.

    A simple message to my users that i am rolling out Zimbra upgrades today is this feature really to much to ask for
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  7. #7
    Join Date
    Apr 2010
    Posts
    29
    Rep Power
    5

    Exclamation

    hey rmvg,
    i'm totally with you. i'm also right before the next update and everytime i activate the distribution lists i made for all our customer companies to write all of them. it's an annoying work...
    i also have no idea why it should be such a problem to build such a feature that surely every zimbra admin will need from time to time...
    ZCS NETWORK edition 7.1.2 (GA 3268) - Ubuntu 8 LTS 64bit

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by rmvg View Post
    A simple message to my users that i am rolling out Zimbra upgrades today is this feature really to much to ask for
    You ought to know the answer to this by now. Asking in the forums for a particular feature to be included in Zimbra has zero effect on whether it will even be considered as a feature. The correct place for this is an RFE filed in bugzilla, if there's already one filed (search first) then vote on it and if not then file an RFE - that's what gets the attention of developers not posting a request in these forums.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Apr 2010
    Posts
    29
    Rep Power
    5

    Default

    Hi Bill,
    you're right. I thought I already saw and voted for such an request but I couldn't find one.
    So I opened one by myself!
    TATA:
    https://bugzilla.zimbra.com/show_bug.cgi?id=63971
    So, everyone out there: PLEASE VOTE!!!
    ZCS NETWORK edition 7.1.2 (GA 3268) - Ubuntu 8 LTS 64bit

  10. #10
    Join Date
    Apr 2010
    Posts
    29
    Rep Power
    5

    Unhappy Bug marked as dublicate

    Hi again,

    so, my bug was marked as a dublicate of the following:
    https://bugzilla.zimbra.com/show_bug.cgi?id=3884

    So, it's very good that someone pointed out this very helpful feature a few years ago with ZCS 4.0! I read nearly the whole comments of this bug. And my next question is: Can anybody tell me, what happend to this bug? What does this say:
    "Status: VERIFIED, Resolution: FIXED"???

    Maybe I'm too stupid but I can't read anything that says: It will be in ZCS 7.0 or something similar! I also can't find a solution for the problem in the comments.
    Can anyone help me to understand it?

    Greets,
    Steffen
    ZCS NETWORK edition 7.1.2 (GA 3268) - Ubuntu 8 LTS 64bit

Similar Threads

  1. Replies: 59
    Last Post: 12-05-2008, 10:33 AM
  2. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. message stats in admin area
    By primz in forum Users
    Replies: 3
    Last Post: 12-20-2006, 02:21 PM
  5. Replies: 4
    Last Post: 07-13-2006, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •