Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: POP3 Outlook 2002 and Zimbra Open Source

  1. #11
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Exclamation POP3 and Outlook 2007 and Zimbra Open Source

    Thanks Czaveri,
    From what I can see, my zimbra setting looks fine. Here's what I have.

    1. Admin Console -> Global Settings -> MTA
    --- Enable authentication : Checked
    --- TLS Authentication only : Checked
    --- Web mail MTA Hostname: Localhost
    --- Web mail MTA Port : 25
    --- Relay MTA for ext. deliv: <nothing>
    --- Maximum message size : 10000
    --- Maximum size upload file : 10240
    --- Enable DNS lookups : Checked
    --- Protocol checks :
    ------- Hostname in greeting violates RFC (reject_invalid_hostname)
    ------- Sender address must be fully qualified (reject_non_fqdn_sender)
    <the rest is unchecked>
    --- DNS checks :
    <Nothing is checked>

    2. Admin Console -> Global Settings -> POP
    --- Enable POP3 service : Checked
    --- Enable SSL for POP3 service : Not checked
    --- Enable clear text login : Not checked
    --- POP3 port number : 7110
    --- POP3 SSL port number : 7995
    --- POP3 proxy port number : 110
    --- POP3 SSL proxy port number : 995
    --- Number of threads : <nothing>

    3. Admin Console -> Servers -> host.yourdomain.com -> MTA
    --- Enable authentication : Checked
    --- TLS authentication only : Checked
    --- Web mail MTA Hostname : <MY host.yourdomain.com>
    --- Web mail MTA Port : 25
    --- Web mail MTA timeout : 60
    --- Relay MTA for external delivery : <nothing>
    --- Enable DNS lookups : Checked

    4. Admin Console -> Servers -> host.yourdomain.com -> POP
    --- Enable POP3 service : Checked
    --- POP3 port number : 110
    --- Address : <nothing>
    --- Advertized name : <nothing>
    --- Number of threads : 20
    --- Enable SSL for POP3 service : Not checked
    --- POP3 SSL port number : <nothing>
    --- Enable clear text login : Not checked

    These are all the setting I have right now. Do you see anything in there that could be a problem?
    Also, if I change a setting in there, it's not clear to me if I have to restart the zimbra services and/or reboot my server.

    I would appreciate any help you can provide.
    Thank You.

  2. #12
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Note: Server settings override Global settings.

    Method 1:
    In Outlook. You need to setup Incoming mail server without SSL and Outgoing Mail Server with SSL (not sure if TLS is available in Outlook). Once you check this, you should see the port number change from 110 to 995

    OR

    Method 2:
    Uncheck "TLS authentication only" for MTA and setup outgoing mail server also without SSL.

    Only, if the above won't work, change the Incoming mail server port to the non-proxy port number. (7110)

    Regarding restarting of Zimbra after change:

    You generally won't need it except when you change a few particular options. Best is to restart only Tomcat using the commands:

    Code:
    tomcat stop
    tomcat start
    Last edited by czaveri; 10-24-2006 at 05:56 AM. Reason: Regarding restarting of Zimbra after change
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  3. #13
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Post POP3 and Outlook 2007 and Zimbra Open Source

    Hi Czaveri.

    Just to give more details on the errors I'm getting from Outlook, here they are:

    I'm getting 2 errors:
    1. "Log onto incoming mail server (POP3): Your e-mail server rejected your login. Verify your user name and password in your account properties. Unter Tools, click E-mail accounts. The server responded: -ERR only valid after entering TLS mode"
    2. "Send test e-mail message: Your e-mail server rejected your login. Verify your user name and password in your account properties. Under Tools, click E-mail accounts."

    And by the way, yes, I'm sure the user name and password I used are valid. I tried the user name by itself and also the user name followed by "@<dns name>" and the password I set in my zimbra user account.

    I'm a little confused with your answer.

    Method 1:
    In Outlook. You need to setup Incoming mail server without SSL and Outgoing Mail Server with SSL (not sure if TLS is available in Outlook). Once you check this, you should see the port number change from 110 to 995

    You mentioned to use Outgoing Server with SSL, but I don't want to use SSL. So I want to use port 110 not 995.

    OR

    Method 2:
    Uncheck "TLS authentication only" for MTA and setup outgoing mail server also without SSL.

    I would like to keep TLS authentication but for the purpose of testing, I can do that.

    Only, if the above won't work, change the Incoming mail server port to the non-proxy port number. (7110)

    I'm confused. I though non-poxy was 110 and proxy was 7110.

    Thanks for your continued help. I hope to get to the bottom of this soon.

    Mario.

  4. #14
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Hi mariotre,

    I am sorry, I didn't intend to confuse you. It's my English!

    Since, you received an error such as the following, you need to have SSL checked for POP/Incoming Mail Server in your Email Client (Outlook).

    Code:
    Log onto incoming mail server (POP3): Your e-mail server rejected your login. Verify your user name and password in your account properties. Unter Tools, click E-mail accounts. The server responded: -ERR only valid after entering TLS mode
    Once you check SSL, it shouldn't complain with this error. Outlook will probably ask you if you want to accept the server certificate. Say, Yes, here.

    Your email should flow in now.

    Regarding the second error:

    Code:
    Send test e-mail message: Your e-mail server rejected your login. Verify your user name and password in your account properties. Under Tools, click E-mail accounts.
    You are receiving the second error while trying to send email.

    This, too, looks like SSL is not checked for Outgoing Mail Server. Can you confirm?
    Last edited by czaveri; 10-24-2006 at 08:28 AM.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  5. #15
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Post POP3 and Outlook 2007 and Zimbra Open Source

    I just did some more testing.

    I removed all authentication methods from the MTA on the server setup, not at the Global setup.

    After I tried again with Outlook (modifying it's setup accordingly), I still get the error after I get prompt for user name and password:

    "Log onto incoming mail server (POP3): Your e-mail server rejected your login. Verify your user name and password in your account properties. Unter Tools, click E-mail accounts. The server responded: -ERR only valid after entering TLS mode".

    But I don't get the second error.
    I need to make a correction. In my previous email, the second error message is wrong, it should read:
    "Send test e-mail message: None of the authentication methods supported by this client are supported by your server".

    The second error comes back when I check the "Enable authentication" box on the MTA tab in server setup.

    Mario.

  6. #16
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Post POP3 and Outlook 2007 and Zimbra Open Source

    Sorry I saw your message right after I sent mine.

    I did as you said, I checked SSL in both Outlook Incoming and Outgoing Server for SSL but I still get an error. The message is different this time:

    1. "Log onto incoming mail server (POP3): Outlook cannot connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server admnistrator or Internet Service Provider (ISP)"
    2. "Send test e-mail message: Your server does not support the connection encryption type you have specified Try changing the encryption method. Contact your mail server administrator or Internet Service Provider (ISP) for additional assistance".

    On my last test,
    I did as you mentioned in your previous message, and you're right. If I check SSL for Incoming (POP3) the the error -ERR goes away but I still get an error:

    "Log onto incoming mail server (POP3): Outlook cannot connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server admnistrator or Internet Service Provider (ISP)".

    And now, I'm not getting any error with the Outgoing (SMTP) and I receive a test mail from Outlook on my zimbra server. So it looks like the only issue I have left is why POP3 isn't able to logon to my zimbra MTA server. I currently use SSL on port 995. I tried port 7110 but I get the same error.

    Mario.

  7. #17
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Default POP3 and Outlook 2007 and Zimbra Open Source

    Hi Chintan,

    Just FYI. I tried configure an IMAP/SMTP connection and it works fine. So it's only with POP3 that I have a problem (Outlook Incoming POP3).

    Mario.

  8. #18
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by mariotre
    Sorry I saw your message right after I sent mine.

    I did as you said, I checked SSL in both Outlook Incoming and Outgoing Server for SSL but I still get an error. The message is different this time:

    1. "Log onto incoming mail server (POP3): Outlook cannot connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server admnistrator or Internet Service Provider (ISP)"
    2. "Send test e-mail message: Your server does not support the connection encryption type you have specified Try changing the encryption method. Contact your mail server administrator or Internet Service Provider (ISP) for additional assistance".

    On my last test,
    I did as you mentioned in your previous message, and you're right. If I check SSL for Incoming (POP3) the the error -ERR goes away but I still get an error:

    "Log onto incoming mail server (POP3): Outlook cannot connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server admnistrator or Internet Service Provider (ISP)".

    And now, I'm not getting any error with the Outgoing (SMTP) and I receive a test mail from Outlook on my zimbra server. So it looks like the only issue I have left is why POP3 isn't able to logon to my zimbra MTA server. I currently use SSL on port 995. I tried port 7110 but I get the same error.

    Mario.
    Hi Mario,

    Snapshots of my settings attached. This server uses no TLS, no SSL for sending or receiving - just standard authentication ("my server requires authentication") for sending and receiving.

    If you want SSL - enable in server settings and check it at your end.

    HTH,
    Attached Images Attached Images
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  9. #19
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default this forum allows max. of five files

    this forum allows max. of five files, so here's the 6th one.
    Attached Images Attached Images
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  10. #20
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Thumbs up POP3 and Outlook 2007 and Zimbra Open Source

    Hi Chintan,

    Big THANKS for all your help. It was really appreciated.

    I finally got it working yesterday (before I was your attachments) which I appreciate you sharing nonetheless.

    The final setting that made it all work was a setting in Outlook itself.

    In the Account Settings > More settings, in the "Advanced" tab. I had to select/check the box
    "This server requires an encrypted connection (SSL)"

    Under the "Incoming server (POP3) setting, which I had previously set to port 995 as you suggested.

    For the Outgoing server (SMTP) on port 25 I didn't have to set any encryption.
    "Use the following type of encrypted connection" = "None"

    That did it for me. Again, many thanks, it way great to chat with you on this problem. I appreciated the prompt responses and it helped me a lot to resolve this issue.

    Take care, and hope to chat with you again.

    Mario.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Outlook 2003 on Terminal Services not joyful...
    By techrat in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 06-18-2007, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •