Results 1 to 10 of 10

Thread: Zimbra + E62 Observations

  1. #1
    Join Date
    Oct 2005
    Location
    Coeur d'Alene, ID
    Posts
    59
    Rep Power
    10

    Default Zimbra + E62 Observations

    I am using Zimbra Network 4.0.3 on Redhat ES 4. Since I needed to replace my dying cell phone, I purchased the Nokia E62. Here are my observations. The bottom line is .... this is way kool.

    1) I have been unable to sync using a secure connection. I noted in another thread the method of adding the self-signed certificate for Zimbra. Despite this, all attempts to secure sync cause a hang requiring a reboot of the E62 to regain normal sync functioning.

    2) Placing tags on contacts in Zimbra makes the contact unusable on the E62. The contact is synced but it is titled (unnamed). Editing the contact on the E62 shows "no data". If I remove the tags on Zimbra, the contacts are once again fully usable.

    3) "Always On" syncing is not enabled by Mail for Exchange. It is an option for syncing but you will receive an error message if you use it. The next fastest time is 15 minutes.

    4) On calendar events, you can replace (but NOT edit) the note field. So if you add "This note written using Zimbra" under Zimbra in the note field of a calendar event, you can read this note. But, you can not ADD the line "And this note added using E62". You would instead have to replace the Zimbra note with the E62 note.

    5) I have been unable to figure out how to sync anything but the Inbox of Zimbra. I have emails that are important but I do not want them "clogging" up my Inbox. So, I always create a "Save" folder (in Zimbra). Important message go to Save. I made the Save folder as a separate folder at first to see if I could include it in the sync process... without luck. I then moved the Save folder (in Zimbra) to be a subfolder of the Inbox. This subfolder does not show up on the E62.

    So, how well does it really work? Pretty darn well. Every 15 minutes the E62 syncs with Zimbra. If I have an email, I hear a lite musical tone plus there is a blinky light that goes off. I press a button and I can read the emails. The calendar events are all synced, as well as the contacts (personal contacts only). I can add,delete and edit email, calendar and contacts on Zimbra <--> E62.
    You can send email from the E62 using the "keyboard". You will not be a speed typist with this keyboard but it does work for short emails... which is all I would want to send with a "phone" device.

    This phone plus Network Zimbra is great!

    Mike

    Mike

  2. #2
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default

    Hi Mike,

    Glad to hear you like the sync features. Thanks for the valuable feedback! Please see my answers to your issues below:

    1) I have been unable to sync using a secure connection. I noted in another thread the method of adding the self-signed certificate for Zimbra. Despite this, all attempts to secure sync cause a hang requiring a reboot of the E62 to regain normal sync functioning.

    So far we have not tested with E62. Our test devices include E61 which is almost exactly the same as E62. E61 has no problem to sync over SSL. Do you know if the client can reach server at all when using secure connection? If not, it's most likely a certificate setup issue.

    2) Placing tags on contacts in Zimbra makes the contact unusable on the E62. The contact is synced but it is titled (unnamed). Editing the contact on the E62 shows "no data". If I remove the tags on Zimbra, the contacts are once again fully usable.

    This is a known issue due to a Nokia client bug. See http://bugzilla.zimbra.com/show_bug.cgi?id=11132
    We will provide a workaround in the next release.

    3) "Always On" syncing is not enabled by Mail for Exchange. It is an option for syncing but you will receive an error message if you use it. The next fastest time is 15 minutes.

    "Always On" is not supported in the current release. We will provide a beta version of "Always On" support in the next release.

    4) On calendar events, you can replace (but NOT edit) the note field. So if you add "This note written using Zimbra" under Zimbra in the note field of a calendar event, you can read this note. But, you can not ADD the line "And this note added using E62". You would instead have to replace the Zimbra note with the E62 note.

    On E61 I can't reproduce this issue. Does the E62 client simply doesn't allow you to append text?

    5) I have been unable to figure out how to sync anything but the Inbox of Zimbra. I have emails that are important but I do not want them "clogging" up my Inbox. So, I always create a "Save" folder (in Zimbra). Important message go to Save. I made the Save folder as a separate folder at first to see if I could include it in the sync process... without luck. I then moved the Save folder (in Zimbra) to be a subfolder of the Inbox. This subfolder does not show up on the E62.

    Unfortunately sync of email folders other than Inbox depends on client support. Currently only PocketPC version of sync client supports other email folders. All other clients, Nokia included, don't support additional folders. We hope later versions of Nokia client can add multifolder support in the future. Zimbra sever already has multifolder support and PocketPC phones can sync additional folders with Zimbra server.

    JimBob

  3. #3
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by mjfleck2000
    I am using Zimbra Network 4.0.3 on Redhat ES 4. Since I needed to replace my dying cell phone, I purchased the Nokia E62. Here are my observations. The bottom line is .... this is way kool.

    1) I have been unable to sync using a secure connection. I noted in another thread the method of adding the self-signed certificate for Zimbra. Despite this, all attempts to secure sync cause a hang requiring a reboot of the E62 to regain normal sync functioning.
    Hi Mike,

    I got my new E62 working with a secure connection. Likely, the problem you had was with the CA as I have been working on this for 2 days and just now got it working:

    http://wiki.zimbra.com/index.php?title=Nokia_E62

    Regards,
    John

  4. #4
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Unhappy

    Quote Originally Posted by mjfleck2000
    2) Placing tags on contacts in Zimbra makes the contact unusable on the E62. The contact is synced but it is titled (unnamed). Editing the contact on the E62 shows "no data". If I remove the tags on Zimbra, the contacts are once again fully usable.
    Unfortunately, I just discovered that this bug affects emails as well. Any email in my inbox that is tagged does not show up in my E62 Inbox.

    Is this a known bug?

  5. #5
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default

    No we were not aware of that. It looks like Nokia client has a general issue with tags, not just with Contacts. I will look into it and provide a workaround in the next release.

    Thanks for catching this for us!

    JimBob

  6. #6
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default

    I'm opened a bug for this http://bugzilla.zimbra.com/show_bug.cgi?id=12470

    However I can't reproduce this issue. Because email tagging is server side only. Sync clients don't support categories anyway, so I don't see how they can be affected. I will leave the ticket open for a few days. Please confirm you are still experiencing the issue and provide exact steps to reproduce.

    Thanks!

    JimBob

  7. #7
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by jimbob View Post
    I'm opened a bug for this http://bugzilla.zimbra.com/show_bug.cgi?id=12470

    However I can't reproduce this issue. Because email tagging is server side only. Sync clients don't support categories anyway, so I don't see how they can be affected. I will leave the ticket open for a few days. Please confirm you are still experiencing the issue and provide exact steps to reproduce.

    Thanks!

    JimBob
    Hi Jim,

    Sorry, I didn't post the link to the bug I had already opened.

    Yes, I'm still seeing this bug. Basically, once I tag something and the E62 sync's, it will not show up on the E62. What is really strange though, is that if I remove the tag in Zimbra, I still cannot get the email to show up on the E62.

    Basically, it seems like once an email is tagged, it will never show up. Weird.

  8. #8
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default

    Hi John,

    Many of us here use E61 and run the same ExchangeMail client from Nokia. I can't reproduce this issue so far. Also I'm pretty sure your problem should not be related to tagging emails because our code does not encode tag or category when doing email sync. We only encode categories for contacts and calendar events (although so far Zimbra web UI doesn't yet support tagging calendar items).

    I don't know how to explain the issue you are experiencing. Maybe it's not directly tag related but somehow appears that way. As more people start to use E62 with Zimbra server I hope we can find more data related your issue.

    Regards,

    JimBob

  9. #9
    Join Date
    Jun 2006
    Location
    Viseu
    Posts
    105
    Rep Power
    9

    Default

    2) Placing tags on contacts in Zimbra makes the contact unusable on the E62. The contact is synced but it is titled (unnamed). Editing the contact on the E62 shows "no data". If I remove the tags on Zimbra, the contacts are once again fully usable.

    This is a known issue due to a Nokia client bug. See http://bugzilla.zimbra.com/show_bug.cgi?id=11132
    We will provide a workaround in the next release.

    Seems that it will be fixed in 4.5.. but when it will be out?

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by miguel View Post
    2) Seems that it will be fixed in 4.5.. but when it will be out?
    Late January.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •