I have been using Zimbra for 9 months as it is connected to my website through Intuit. Lately I have been having some serious problems and I'm getting very frustrated. First, when I try to reply, I can type my message and then it will not allow me to hit send. The send button is grayedout and not clickable. Then I have to exit and start and email instead of being able to reply to the one I'm replying to; and it asks me if I want to save the draft of the one I abandoned so I try to and it won't let me. I have to cancel and start a new one. This has probably happened to me 50 times in the past month.

Second, my customers are telling me they are getting notices that their emails to me did not go through and are having to retype messages. I can't tell you how awful this is as they don't get the message for a few days and it is really affecting my sales and ability to meet their needs quickly- not to mention I'm sure there are some customers who don't bother to try again and some who don't notice the notice that it didn't go through and thus think I am ignoring them. I am also missing automated emails which are supposed to notify me of orders (luckily these come through to another email as well)- but also concerns me. What the heck! This has all started in the past month. Here is an error message one of my customers sent me:

Sorry, we were unable to deliver your message to the following address.

<Message expired for domain *****. Remote host said: 452 Too many recipients received this hour [RCPT_TO]