Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Need settings for Zimbra OpenLDAP

  1. #1
    Join Date
    Feb 2007
    Posts
    18
    Rep Power
    8

    Default Need settings for Zimbra OpenLDAP

    Need settings for Zimbra OpenLDAP for use with Openfiler

    Openfiler (a NAS/SAN solution) requires a LDAP or AD to connect to.

    I then proceeded to find Zimbra. All of this was coming together beautifully...until I couldn't get Openfiler to connect to Zimbra's LDAP server.

    Here's the information that Openfiler wants, Could someone give me some hints as to what would allow it to connect?

    Use TLS: Y/N
    Server: mail.domain.com
    Base DN: dc=domain, dc=com
    Authenticated bind DN:
    Authenticated bind password:
    Root bind DN:
    Root bind password:
    Login SMB server to root DN: Y/N

    I would have provided a screenshot but my storage server won't work without LDAP authentification of some kind

    thanks!

  2. #2
    Join Date
    Apr 2006
    Location
    Ridgefield, CT
    Posts
    152
    Rep Power
    9

    Default

    I recently upgraded to Openfiler 2.2, which now allows for local LDAP authentication.... have you tried that?

  3. #3
    Join Date
    Feb 2007
    Posts
    18
    Rep Power
    8

    Default

    Thanks! I actually upgraded last night in hopes of the LDAP magically starting to connect and never checked out the new features.

    However, while that will bandaid me long enough to show my supervisor it doesn't achieve a single user/password without modification.

    I would really prefer to have the single LDAP be stored on the mail server. That way there won't be any downtime with mail if all of a sudden the LDAP settings change on either product during an update.

    Is it possible?

  4. #4
    Join Date
    Jul 2007
    Posts
    98
    Rep Power
    8

    Default

    I'm also very interested in collaborating zimbra and openfiler.
    Is it possible??

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You'll probably need the Samba and posix extensions installed in Zimbra and the correct setting for 'LDAP User Suffix' (it's on the Services/SMB Settings tab) on your openfiler server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Jul 2007
    Posts
    98
    Rep Power
    8

    Default

    Thanks Bill,
    I'm trying the setup now. I'll report when it's done.

  7. #7
    Join Date
    Jul 2007
    Posts
    98
    Rep Power
    8

    Default

    Hmm I still can't make it. The error:
    Code:
    Please configure the LDAP section of the Authentication page before attempting to use this page.
    
    Error message:
        ldap_bind: Invalid credentials (49)
    I set it up this way:
    Code:
      Use LDAP: YES
    Local LDAP server: NO	
    Use Local LDAP Server: NO
    LDAP Security: 	Use TLS: NO
    Server: 192.168.0.115 (zimbra)
    Base DN: dc=example,dc=com
    Authenticated bind DN: 	cn=config
    Authenticated bind password: 123456
    Root bind DN: cn=config
    Root bind password: 123456
    SMB LDAP Configuration: 	Login SMB server to root DN: YES
    User password policy: 	Allow user to change password

  8. #8
    Join Date
    Jul 2007
    Posts
    98
    Rep Power
    8

    Default

    Ok some progresses here?
    I edit directly the smb.conf in the openfiler:


    And do smbpasswd -w 123456
    Code:
    Mar 14 16:55:51 localhost smbd[2524]:   fetch_ldap_pw: neither ldap secret retrieved! 
    Mar 14 16:55:51 localhost smbd[2524]: [2008/03/14 16:55:51, 0] lib/smbldap.c:smbldap_connect_system(941) 
    Mar 14 16:55:51 localhost smbd[2524]:   ldap_connect_system: Failed to retrieve password from secrets.tdb 
    Mar 14 16:55:52 localhost smbd[2524]: [2008/03/14 16:55:52, 0] lib/smbldap.c:smbldap_connect_system(981) 
    Mar 14 16:55:52 localhost smbd[2524]:   failed to bind to server ldap://cnt5.example.com/ with dn="cn=config" Error: Invalid credentials 
    Mar 14 16:55:52 localhost smbd[2524]:   ^I

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Try it without the 'Authenticated Bind' information.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Jul 2007
    Posts
    98
    Rep Power
    8

    Default

    I'm using zimbra 5.0.2.
    Is the rootdn is cn=config? or the previous zimbra?

Similar Threads

  1. Custom LDAP Server
    By KermitTheFragger in forum Developers
    Replies: 22
    Last Post: 12-30-2007, 01:48 PM
  2. Please, help me with Outlook Express settings.
    By maykonsantini in forum Zimbra Connector for Outlook
    Replies: 7
    Last Post: 02-16-2007, 01:40 PM
  3. Per user spamassassin settings possible?
    By redhat in forum Administrators
    Replies: 1
    Last Post: 08-11-2006, 03:51 PM
  4. OpenLDAP and Outlook
    By PNE in forum Administrators
    Replies: 3
    Last Post: 03-08-2006, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •