Results 1 to 8 of 8

Thread: Emails show correct date until print - then 1969

  1. #1
    Join Date
    Apr 2014
    Posts
    5
    Rep Power
    1

    Default Emails show correct date until print - then 1969

    Running Zimbra 8.06.
    Received emails show the proper date:
    correctdate.png - March 31, 2014, 10:31

    Then when I try to print the email the date changes to Wed, Dec 31, 1969 05:00 PM.
    wrongdate.png

    This happens randomly - sometimes from in house mail from the same server. This suggest to me the header has the correct time format.

    Printing these emails is an integral business process for documenting the date it was received.

  2. #2
    Join Date
    Apr 2014
    Posts
    5
    Rep Power
    1

    Default Just me?

    Is it really just me that has this problem? I've searched extensively through these forums and across the internet and have not found a situation where it happens intermittently and with messages sent from mailbox to mailbox on the same server.

    Any insight would be greatly appreciated.

  3. #3
    Join Date
    Feb 2011
    Location
    San Mateo, CA
    Posts
    88
    Rep Power
    4

    Default

    Quote Originally Posted by Brian DeLaet View Post
    Is it really just me that has this problem? I've searched extensively through these forums and across the internet and have not found a situation where it happens intermittently and with messages sent from mailbox to mailbox on the same server.

    Any insight would be greatly appreciated.
    Hi Brian,

    I'm sorry to hear you're having problems with the date printing correctly. I've tried to reproduce the issue in my development build, but all messages I've run into seem to print the date without issue. I'm wondering if there could be something unique about your messages. If you have a message that's exhibiting the behaviour and you feel comfortable sharing, I'd suggest right-clicking the message, choosing Show Original and copying that information to a message here. I can then see if the message is the cause of the issue.

    Regards,
    Josh

  4. #4
    Join Date
    Apr 2014
    Posts
    5
    Rep Power
    1

    Default Internal email

    Please note, this is an internal email. Most emails between these two print the date fine. This one however doesn't.

    The domain name was changed but all else is verbatim:

    Return-Path: email@mycustomer.com
    Received: from 192.168.0.2 (LHLO mail.mycustomer.com) (192.168.0.2)
    by mail.mycustomer.com with LMTP; Fri, 28 Mar 2014 10:22:15 -0600
    (MDT)
    Received: from localhost (localhost [127.0.0.1])
    by mail.mycustomer.com (Postfix) with ESMTP id 0D79510003D;
    Fri, 28 Mar 2014 10:22:15 -0600 (MDT)
    X-Spam-Flag: NO
    X-Spam-Score: -2.889
    X-Spam-Level:
    X-Spam-Status: No, score=-2.889 tagged_above=-10 required=2
    tests=[ALL_TRUSTED=-1, BAYES_00=-1.9, HTML_MESSAGE=0.001,
    T_KAM_HTML_FONT_INVALID=0.01] autolearn=ham
    Received: from mail.mycustomer.com ([127.0.0.1])
    by localhost (mail.mycustomer.com [127.0.0.1]) (amavisd-new, port 10032)
    with ESMTP id wnpKbWyiyzXT; Fri, 28 Mar 2014 10:22:13 -0600 (MDT)
    Received: from localhost (localhost [127.0.0.1])
    by mail.mycustomer.com (Postfix) with ESMTP id 191FA10003B;
    Fri, 28 Mar 2014 10:22:13 -0600 (MDT)
    X-Virus-Scanned: amavisd-new at mycustomer.com
    Received: from mail.mycustomer.com ([127.0.0.1])
    by localhost (mail.mycustomer.com [127.0.0.1]) (amavisd-new, port 10026)
    with ESMTP id xYY5z_p6Kz2c; Fri, 28 Mar 2014 10:22:12 -0600 (MDT)
    Received: from mail.mycustomer.com (localhost [127.0.0.1])
    by mail.mycustomer.com (Postfix) with ESMTP id D2A5A100025;
    Fri, 28 Mar 2014 10:22:12 -0600 (MDT)
    Date: Fri, 28 Mar 2014 10:22:12 -0600 (MDT)
    From: My Customer <email@mycustomer.com>
    To: Marcelo <marcelo@apollologistics.net>
    Cc: Their Customer <email@theircustomer.com>,
    Message-ID: <809314713.101369.1396023732763.JavaMail.zimbra@my customer.com>
    In-Reply-To: <D1D7749F3E97456BBAD4BB439E2DB106@HPLaptop>
    References: <D1D7749F3E97456BBAD4BB439E2DB106@HPLaptop>
    Subject: Re: : Delivery Order
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_Part_101365_1529726274.1396023732760"
    X-Mailer: Zimbra 8.0.6_GA_5922 (ZimbraWebClient - GC33 (Win)/8.0.6_GA_5922)
    Thread-Topic: : Delivery Order
    Thread-Index: CeMYb78cRQVQQoyxcCAwf9uT0y27Ug==

    ------=_Part_101365_1529726274.1396023732760
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit

  5. #5
    Join Date
    Apr 2014
    Posts
    5
    Rep Power
    1

    Default another inhouse email

    This was from a different in house user

    Return-Path: email@mycustomer.com
    Received: from 192.168.0.2 (LHLO mail.mycustomer.com) (192.168.0.2)
    by mail.mycustomer.com with LMTP; Wed, 11 Dec 2013 13:16:46 -0700
    (MST)
    Received: from localhost (localhost [127.0.0.1])
    by mail.mycustomer.com (Postfix) with ESMTP id 5767010003D;
    Wed, 11 Dec 2013 13:16:46 -0700 (MST)
    X-Spam-Flag: NO
    X-Spam-Score: -2.899
    X-Spam-Level:
    X-Spam-Status: No, score=-2.899 tagged_above=-10 required=2
    tests=[ALL_TRUSTED=-1, BAYES_00=-1.9, HTML_MESSAGE=0.001]
    autolearn=ham
    Received: from mail.mycustomer.com ([127.0.0.1])
    by localhost (mail.mycustomer.com [127.0.0.1]) (amavisd-new, port 10032)
    with ESMTP id jKSCYBuohQWR; Wed, 11 Dec 2013 13:16:45 -0700 (MST)
    Received: from localhost (localhost [127.0.0.1])
    by mail.mycustomer.com (Postfix) with ESMTP id 516B610003B;
    Wed, 11 Dec 2013 13:16:45 -0700 (MST)
    X-Virus-Scanned: amavisd-new at mycustomer.com
    Received: from mail.mycustomer.com ([127.0.0.1])
    by localhost (mail.mycustomer.com [127.0.0.1]) (amavisd-new, port 10026)
    with ESMTP id diOIHUGxjdxr; Wed, 11 Dec 2013 13:16:45 -0700 (MST)
    Received: from mail.mycustomer.com (localhost [127.0.0.1])
    by mail.mycustomer.com (Postfix) with ESMTP id 24C8E10003D;
    Wed, 11 Dec 2013 13:16:45 -0700 (MST)
    Date: Wed, 11 Dec 2013 13:16:45 -0700 (MST)
    From: My Customer <email@mycustomer.com>
    To: In House Customer <anotheremail@mycustomer.com>,
    Cc: Another In House <another@mycustomer.com>,
    Message-ID: <46778869.73124.1386793005000.JavaMail.zimbra@mycu stomer.com>
    In-Reply-To: <4B797A70B7C29041874A365D845730DA17775CF3@dcaexmbx 04>
    References: <4B797A70B7C29041874A365D845730DA17775CF3@dcaexmbx 04>
    Subject: Fwd: KN IAS
    MIME-Version: 1.0
    Content-Type: multipart/mixed;
    boundary="----=_Part_73120_972024041.1386793004991"
    X-Mailer: Zimbra 8.0.4_GA_5737 (ZimbraWebClient - IE7 (Win)/8.0.4_GA_5737)
    Thread-Topic: KN IAS
    Thread-Index: Ac72q1FuY+rsgux5QkO9ap3kDcYtFtFPf7C9

    ------=_Part_73120_972024041.1386793004991
    Content-Type: multipart/alternative;
    boundary="----=_Part_73121_899954358.1386793004991"

    ------=_Part_73121_899954358.1386793004991
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: quoted-printable

  6. #6
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    There's a bug on this; it's fixed in 8.0.7.

    The workaround is to print emails only from the list view; do not open the email into a separate window or tab.

    Hope that helps,
    Mark

  7. #7
    Join Date
    Apr 2014
    Posts
    5
    Rep Power
    1

    Default That did it!

    Thanks Mark!

    That did it. What an odd bug and an easy solution!

  8. #8
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Quote Originally Posted by Brian DeLaet View Post
    Thanks Mark!

    That did it. What an odd bug and an easy solution!
    Glad the workaround worked for you.

    8.0.7 has a lot of other bug fixes; it's worth the upgrade.

    Mark

Similar Threads

  1. Replies: 6
    Last Post: 10-16-2013, 04:42 PM
  2. Replies: 2
    Last Post: 07-08-2013, 12:47 PM
  3. Replies: 0
    Last Post: 03-17-2013, 09:36 PM
  4. Regular backup by date. Please correct me the command
    By Bullz3y3 in forum Administrators
    Replies: 2
    Last Post: 03-10-2012, 12:38 AM
  5. Meeting Request emails through CalDav don'ts show time or date
    By kbaliey in forum CalDAV / CardDAV / iSync
    Replies: 1
    Last Post: 08-16-2010, 12:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •