Results 1 to 9 of 9

Thread: Toaster Problem

  1. #1
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default Toaster Problem

    I have installed ZimbraToast-4.5.2_GA_696-4.5.61.msi and after getting my self-signed SSL certificate installed, I can get IE7 and Toaster to both connect with secure connection and not complain about the cert, so I'm assuming that is ok.

    But now that is connects ok, the problem is that whenever I get a new email and then click the new message popup window, I get an exception box that pops up for a few seconds and then disappears.

    After playing with it for awhile, I managed to hit details and print screen within the 2 seconds before the error dialog disappeared

    So, I managed to get this screenshot. Is the toaster working for anyone with 4.5.2 ZCS NE and ZimbraToast-4.5.2_GA_696-4.5.61.msi installed?

    I tried in both IE7 and FF2 with same error, I have FF2 registered as default browser.

    Any idea where the *whole* error message might be contained before the window disappears? I found nothing in the 'Event Viewer' and nothing in c:\program files\zimbra\..., and nothing in '...application data\zimbra'
    Attached Images Attached Images
    Last edited by jdell; 02-26-2007 at 10:10 PM.

  2. #2
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    Do you have a default browser configured on the system? The toaster is attempting to open the item in your default browser and the system is compaining there is a default browser.
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  3. #3
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by sam View Post
    Do you have a default browser configured on the system? The toaster is attempting to open the item in your default browser and the system is compaining there is a default browser.
    Yes, I indicated in my first post that FF2 is registered as the default browser. Does it need to be IE7? I didn't try it with IE7 as default browser.

  4. #4
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    sorry, missed that. shouldn't matter what browser it is. Perhaps the url that its trying to open is corrupt. What is your 'click item url'? Check the value in the stored in the configuration file ( ztoastcfg.xml ).
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  5. #5
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by sam View Post
    sorry, missed that. shouldn't matter what browser it is. Perhaps the url that its trying to open is corrupt. What is your 'click item url'? Check the value in the stored in the configuration file ( ztoastcfg.xml ).
    Here is my ztoastcfg.xml:

    <ZimbraToast>
    <Server>[removed for security]</Server>
    <UseSecure>True</UseSecure>
    <Account>jdell</Account>
    <EncryptedPassword>[removed for security]</EncryptedPassword>
    <PollInterval>2</PollInterval>
    <ClickURLPathFmt>/zimbra/?view=msg&amp;id={0}</ClickURLPathFmt>
    <WindowLocation>100,100</WindowLocation>
    <MaxOpacity>0.8</MaxOpacity>
    <OpacityDelta>0.01</OpacityDelta>
    <UpdateInterval>10</UpdateInterval>
    <PauseInterval>5000</PauseInterval>
    </ZimbraToast>

  6. #6
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    You may want to copy and paste the actual exception info so we can see the entire contents. I haven't used that Zimbra utility but is it possible it's trying to open the default mail client? I've found that many systems don't have a default application assigned to mail MIME types if a fat mail client has never been used on that computer.

    Not to complain but I'm still a bit mystified that Zimbra doesn't have "built-in" notification at least on par with other common web mail UIs. Just changing the web page title to include "new mail" in the task bar would be enough for most of us (and removing it once we've looked at the mail). Maybe after posting this message I'll go search bugzilla to see if it's on the list

  7. #7
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by rajahd View Post
    You may want to copy and paste the actual exception info so we can see the entire contents. I haven't used that Zimbra utility but is it possible it's trying to open the default mail client? I've found that many systems don't have a default application assigned to mail MIME types if a fat mail client has never been used on that computer.

    Not to complain but I'm still a bit mystified that Zimbra doesn't have "built-in" notification at least on par with other common web mail UIs. Just changing the web page title to include "new mail" in the task bar would be enough for most of us (and removing it once we've looked at the mail). Maybe after posting this message I'll go search bugzilla to see if it's on the list
    I've had Thunderbird functioning as a 'fat client' on this machine. I would love to paste the full contents of the error message, but it disappears after 1-2 seconds, so the screen shot is the best I could do. I looked all over for the error message, but it appears that toaster doesn't log errors. Would be nice if these errors went to the event viewer log.

    Is there a setting I can add to the ztoastcfg.xml to make it log errors?

  8. #8
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    I installed the app just see if I could recreate the issue (and evaluate it for my use as well). Unfortunately I can't get it to work at all. If I put an invalid e-mail address/password in the settings area I can get an error message (non-fatal) to pop up. Once a valid account is in there it simply does nothing - no notification of new messages, no error message, nothing. I even gave it unrestricted internet access (full trust in Zone Alarm).

    Did the source ever get added to CVS for it? I'm not versed in CVS so any pointers on how to get at it would help too.

  9. #9
    Join Date
    Aug 2006
    Location
    Essex, UK
    Posts
    250
    Rep Power
    9

    Default

    Has anyone else had this one?

    If I choose to 'Show new messages' from the toaster icon then click on the red 'x' instead of clicking on the message itself I always get this error when looking in the 'Details' section in the Net window that pops up;

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.ArgumentOutOfRangeException: InvalidArgument=Value of '0' is not valid for 'index'.
    Parameter name: index
    at System.Windows.Forms.ImageList.ImageCollection.get _Item(Int32 index)
    at Zimbra.Toast.ToastForm.ClosePictureBox_MouseLeave( Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnMouseLeave(EventArg s e)
    at System.Windows.Forms.Control.WmDestroy(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.O nMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    ZToast
    Assembly Version: 4.5.74.0
    Win32 Version: 4.5.74.0
    CodeBase: file:///C:/Program%20Files/Zimbra/Zimbra%20Toaster/Zimbra%20Toaster.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    Zimbra.Client
    Assembly Version: 4.5.74.0
    Win32 Version: 4.5.74.0
    CodeBase: file:///C:/Program%20Files/Zimbra/Zimbra%20Toaster/Zimbra.Client.DLL
    ----------------------------------------
    System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    System.Deployment
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
    ----------------------------------------
    System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Web
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.210 (QFE.050727-2100)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_32/System.Web/2.0.0.0__b03f5f7f11d50a3a/System.Web.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.




    It doesn't seem to like it when you don't pick to read the message!

    I have this on the version with the latest 4.5.3 Network edition of Zimbra, I'm running Windows XP SP2 with Net 1.1. I have also tried this on two different PC with the same setup.

    Also, I have put the toaster.exe in my startup file to get it to pop up in the morning automatically, is this what I should be doing? It's just that this then asks you for the setup info every time you startup each morning.

    Thanks

    Russ

Similar Threads

  1. Zimbra, WM5.0, AS + problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 7
    Last Post: 06-25-2007, 02:04 AM
  2. toaster app problem
    By sperkins in forum Administrators
    Replies: 7
    Last Post: 12-21-2006, 02:56 PM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •