Results 1 to 9 of 9

Thread: Toaster Problem

Hybrid View

  1. #1
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default Toaster Problem

    I have installed ZimbraToast-4.5.2_GA_696-4.5.61.msi and after getting my self-signed SSL certificate installed, I can get IE7 and Toaster to both connect with secure connection and not complain about the cert, so I'm assuming that is ok.

    But now that is connects ok, the problem is that whenever I get a new email and then click the new message popup window, I get an exception box that pops up for a few seconds and then disappears.

    After playing with it for awhile, I managed to hit details and print screen within the 2 seconds before the error dialog disappeared

    So, I managed to get this screenshot. Is the toaster working for anyone with 4.5.2 ZCS NE and ZimbraToast-4.5.2_GA_696-4.5.61.msi installed?

    I tried in both IE7 and FF2 with same error, I have FF2 registered as default browser.

    Any idea where the *whole* error message might be contained before the window disappears? I found nothing in the 'Event Viewer' and nothing in c:\program files\zimbra\..., and nothing in '...application data\zimbra'
    Attached Images Attached Images
    Last edited by jdell; 02-26-2007 at 10:10 PM.

  2. #2
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    Do you have a default browser configured on the system? The toaster is attempting to open the item in your default browser and the system is compaining there is a default browser.
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  3. #3
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by sam View Post
    Do you have a default browser configured on the system? The toaster is attempting to open the item in your default browser and the system is compaining there is a default browser.
    Yes, I indicated in my first post that FF2 is registered as the default browser. Does it need to be IE7? I didn't try it with IE7 as default browser.

  4. #4
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    sorry, missed that. shouldn't matter what browser it is. Perhaps the url that its trying to open is corrupt. What is your 'click item url'? Check the value in the stored in the configuration file ( ztoastcfg.xml ).
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  5. #5
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by sam View Post
    sorry, missed that. shouldn't matter what browser it is. Perhaps the url that its trying to open is corrupt. What is your 'click item url'? Check the value in the stored in the configuration file ( ztoastcfg.xml ).
    Here is my ztoastcfg.xml:

    <ZimbraToast>
    <Server>[removed for security]</Server>
    <UseSecure>True</UseSecure>
    <Account>jdell</Account>
    <EncryptedPassword>[removed for security]</EncryptedPassword>
    <PollInterval>2</PollInterval>
    <ClickURLPathFmt>/zimbra/?view=msg&amp;id={0}</ClickURLPathFmt>
    <WindowLocation>100,100</WindowLocation>
    <MaxOpacity>0.8</MaxOpacity>
    <OpacityDelta>0.01</OpacityDelta>
    <UpdateInterval>10</UpdateInterval>
    <PauseInterval>5000</PauseInterval>
    </ZimbraToast>

  6. #6
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    You may want to copy and paste the actual exception info so we can see the entire contents. I haven't used that Zimbra utility but is it possible it's trying to open the default mail client? I've found that many systems don't have a default application assigned to mail MIME types if a fat mail client has never been used on that computer.

    Not to complain but I'm still a bit mystified that Zimbra doesn't have "built-in" notification at least on par with other common web mail UIs. Just changing the web page title to include "new mail" in the task bar would be enough for most of us (and removing it once we've looked at the mail). Maybe after posting this message I'll go search bugzilla to see if it's on the list

Similar Threads

  1. Zimbra, WM5.0, AS + problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 7
    Last Post: 06-25-2007, 02:04 AM
  2. toaster app problem
    By sperkins in forum Administrators
    Replies: 7
    Last Post: 12-21-2006, 02:56 PM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •