Hello,

i have a strange problem. I installed Zimbra-M2 on FC4 regarding the very (!) useful howto http://www.zimbra.com/forums/showthr...ht=install+FC4

Everything is working fine, BUT:
============================

1. I can't send mails locally and externaly...

2. Status:
-------------

Code:
[zimbra@zimbra bin]$ zmcontrol status
Host zimbra.lan
        antispam                Stopped
        antivirus               Running
        ldap                    Running
        logger                  Running
        mailbox                 Running
        mta                     Stopped
        snmp                    Running
        spell                   Running
the mta is down, in /var/log/zimbra.log i get :

Code:
Nov 21 14:58:23 zimbra postfix/qmgr[2960]: 4293F1BFA0C: from=<>, size=10570, nrcpt=1 (queue active)
Nov 21 14:58:23 zimbra postfix/smtp[16264]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Nov 21 14:58:23 zimbra postfix/smtp[16265]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Nov 21 14:58:23 zimbra postfix/smtp[16265]: 1A1E31BF9FC: to=<admin@zimbra.lan>, relay=none, delay=135286, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Okay...Port 10024 belongs to amavisd but it is NOT running, trying to start:
Code:
[zimbra@zimbra bin]$ zmamavisdctl start
[zimbra@zimbra bin]$ Problem in Amavis::DB or Amavis::DB::SNMP code: Can't load '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/BerkeleyDB/BerkeleyDB.so' for module BerkeleyDB: libdb-4.2.so: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.6/i386-linux-thread-multi/XSLoader.pm line 68.
 at (eval 36) line 12
Compilation failed in require at (eval 36) line 12.
BEGIN failed--compilation aborted at (eval 36) line 12.
Undefined subroutine &BerkeleyDB::Term::close_everything called at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/BerkeleyDB.pm line 1649.
END failed--call queue aborted.
Hmmm...what does that mean ? If i search for libdb-4.2.so, i get nothing....

Code:
[zimbra@zimbra bin]$ locate libdb-4.2.so
[zimbra@zimbra bin]$ locate libdb-4
/lib/tls/i686/libdb-4.3.so
/lib/tls/i586/libdb-4.3.so
/lib/tls/i486/libdb-4.3.so
/lib/libdb-4.3.so
/usr/lib/tls/i686/libdb-4.3.so
/usr/lib/tls/i586/libdb-4.3.so
/usr/lib/tls/i486/libdb-4.3.so
/usr/lib/libdb-4.3.so
3. So i have libdb-4.3.so installed --> How do i get libdb-4.2.so ??

Anyone out there, who can give me an advice ?!

Thanks !

/harry