Results 1 to 2 of 2

Thread: Zimbra 5 fails to start.

  1. #1
    Join Date
    Feb 2006
    Location
    Boston
    Posts
    38
    Rep Power
    9

    Default Zimbra 5 fails to start.

    Hi Guys,

    I broke my server again, *sign*. After a seemingly successful upgrade from 4.5.5 to 5B1 I try to login to the webportal without success.

    zmcontrol status returns zmmailboxdctl as not starting.
    zmmailboxdctl status returns nothing

    Catalina seems to say that the java being used is 1.5.0 but the java in /opt/zimbra points to 1.6

    Also /var/log/zimbra.log says

    zmmailboxdmgr[15965]: status requested
    zmmailboxdmgr[15965]: stale pid 14808 found in /opt/zimbra/log/zmmailboxd.pid: No such process
    zmmailboxdmgr[15965]: assuming no other instance is running
    zmmailboxdmgr[15965]: no manager process is running

    ----

    Tomcat has usually been the culprit in the past so when I run 'tomcat start' it returns.

    Warning: /opt/zimbra/mailboxd/webapps/service.war does not exist
    Warning: /opt/zimbra/mailboxd/webapps/zimbra.war does not exist
    /opt/zimbra/bin/tomcat: line 95: /opt/zimbra/mailboxd/bin/catalina.sh: No such file or directory

    ----

    I tried deleting some stale pid's in /opt/zimbra/log but that didn't help either. :s

    ------

    Also, my log files are not over 2GB and my disk space is still great.

    ----

    mysql mysql logs me in correctly, doesn't seem like that's a problem.

    ------

    sh -x bin/zmmtactl status returns all 0 (ok)

    -------

    As downgrading isn't an option how can I get this up? :s
    Last edited by Verbunk; 06-28-2007 at 08:00 PM.

  2. #2
    Join Date
    Feb 2006
    Location
    Boston
    Posts
    38
    Rep Power
    9

    Default Fix

    Turns out for some reason perdition was activated after the install. I had to start zimbra

    > sudo su - zimbra
    % makes you the zimbra user. Important!
    > zmcontrol start
    % starts the zimbra services
    > zmcontrol status
    % shows that zmmailboxdctl is not running due to port conflict. Why, I dunno.
    > zmperditionctl stop
    % stops perdition with predjudice!! Nah, just stops it.
    > zmmailboxdctl start
    % starts mailboxdctl

    Now you should be able to log back into the admin portal and uncheck imap and pop proxy in the servers ~> services tab.

    perdition is only needed in multi-machine environments and it seems (from reading too) that it breaks single machine installs.

Similar Threads

  1. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  2. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM
  3. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 07:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •