Installation of 8.8.8 - Unable to download packages from repository

Ask questions about your setup or get help installing ZCS server (ZD section below).
Rocketrrt
Posts: 10
Joined: Wed Feb 21, 2018 5:44 pm

Installation of 8.8.8 - Unable to download packages from repository

Postby Rocketrrt » Mon Apr 16, 2018 6:22 pm

Hi,

I had the 8.8.7 Collaboration (Trail License) installed. We can't talk to the exchange server (outside access not allowed) so I want to install the open source version. I will be using ZSP with that version.
I have removed the Collaboration version(8.8.7). I am trying to install 8.8.8 open source version on CentOS 7 (RHEL 7) and I am getting the following error: Unable to download packages from repository. System is not modified.

According to website: LDAP and MS Active Directory Support is not supported with the open source version. When Installing it looks it wants LDAP. I did say yes to it because it asked in the install.sh.

Checking for installable packages

Found zimbra-core (local)
Found zimbra-ldap (local)
Found zimbra-logger (local)
Found zimbra-mta (local)
Found zimbra-dnscache (local)
Found zimbra-snmp (local)
Found zimbra-store (local)
Found zimbra-apache (local)
Found zimbra-spell (local)
Found zimbra-memcached (repo)
Found zimbra-proxy (local)
Found zimbra-chat (repo)
Found zimbra-drive (repo)
Found zimbra-imapd (local)
Found zimbra-network-modules-ng (repo)


Installing:
zimbra-core
zimbra-ldap
zimbra-logger
zimbra-mta
zimbra-snmp
zimbra-store
zimbra-apache
zimbra-spell
zimbra-memcached
zimbra-proxy
zimbra-chat
zimbra-drive
zimbra-imapd
zimbra-network-modules-ng

and it wants to install LDAP : zimbra-ldap will be installed.

Then:

Downloading packages (11):
zimbra-core-components
zimbra-ldap-components
zimbra-mta-components
zimbra-snmp-components
zimbra-store-components
zimbra-jetty-distribution
zimbra-apache-components
zimbra-spell-components
zimbra-memcached
zimbra-proxy-components
zimbra-network-modules-ng
...Unable to download packages from repository. System is not modified.

Is it looking at the wrong repository? Maybe the paid version 8.8.7 not the Open Source Version 8.8.8.

Not sure what to do, any help would appreciated.

Thank you,
Ron


Rocketrrt
Posts: 10
Joined: Wed Feb 21, 2018 5:44 pm

Re: Installation of 8.8.8 - Unable to download packages from repository

Postby Rocketrrt » Mon Apr 16, 2018 8:04 pm

After looking some more at the install.log it looks it using the wrong repository.

---> Package zimbra-freetype-libs.x86_64 0:2.6.3-1zimbra8.7b1.el7 will be installed
---> Package zimbra-libart-libs.x86_64 0:2.3.21-1zimbra8.7b1.el7 will be installed
---> Package zimbra-libpng-libs.x86_64 0:1.6.23-1zimbra8.7b1.el7 will be installed
---> Package zimbra-network-modules-ng.x86_64 0:1.0.14.1522918190-1.r7 will be installed
--> Processing Dependency: zimbra-network-store >= 8.8.8 for package: zimbra-network-modules-ng-1.0.14.1522918190-1.r7.x86_64
---> Package zimbra-zeromq-libs.x86_64 0:4.1.4-1zimbra8.7b1.el7 will be installed
--> Processing Dependency: zimbra-libsodium-libs for package: zimbra-zeromq-libs-4.1.4-1zimbra8.7b1.el7.x86_64
--> Running transaction check
---> Package zimbra-libsodium-libs.x86_64 0:1.0.6-1zimbra8.7b1.el7 will be installed
---> Package zimbra-network-modules-ng.x86_64 0:1.0.14.1522918190-1.r7 will be installed
--> Processing Dependency: zimbra-network-store >= 8.8.8 for package: zimbra-network-modules-ng-1.0.14.1522918190-1.r7.x86_64
--> Finished Dependency Resolution
Error: Package: zimbra-network-modules-ng-1.0.14.1522918190-1.r7.x86_64 (zimbra-888-patch)
Requires: zimbra-network-store >= 8.8.8

Any idea how to fix it. yum repolist all

zimbra Zimbra RPM Repository enabled: 486
zimbra-888-patch Zimbra New RPM Repository enabled: 11
zimbra-v1 Zimbra New RPM Repository enabled: 2

I have disabled the 3 repositories:

yum-config-manager --disable repository zimbra
yum-config-manager --disable repository zimbra-888-patch
yum-config-manager --disable repository zimbra-v1

zimbra Zimbra RPM Repository disabled
zimbra-888-patch Zimbra New RPM Repository disabled
zimbra-v1 Zimbra New RPM Repository disabled

when I run the install the repositories become active again then I get the error again.

Do I need this zimbra-network-store?

Ron
axslingr
Posts: 45
Joined: Sat Sep 13, 2014 2:20 am
ZCS/ZD Version: Release 8.8.5.GA.1894.UBUNTU14.64

Re: Installation of 8.8.8 - Unable to download packages from repository

Postby axslingr » Mon Apr 16, 2018 8:11 pm

Answer N when prompted to install zimbra-network-modules-ng

Lance

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: Google [Bot] and 4 guests