New Install Problem in ZCS-8.5 on Centos 6.5

Ask questions about your setup or get help installing ZCS server (ZD section below).
chauhananshul
Posts: 6
Joined: Mon Sep 15, 2014 5:29 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby chauhananshul » Mon Sep 15, 2014 6:40 am

Hi,



i'm a new user of ZCS 8.5, trying to make a mail server, but mails to my domain are not delivered locally.


Please find below steps of installation on a new Centos 6.5 Server


yum -y update


[root@mail1 ~]# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
132.147.0.2     mail1.example.org  mail1
[root@mail1 ~]# cat /etc/resolv.conf
nameserver 8.8.8.8
nameserver 4.2.2.2
[root@mail1 ~]#


[root@mail1 ~]#cd /tmp/
[root@mail1 tmp]#wget http://files2.zimbra.com/downloads/8.5.0_GA/zcs-8.5.0_GA_3042.RHEL6_64.20140828192005.tgz
[root@mail1 tmp]#tar zvxf zcs-8.5.0_GA_3042.RHEL6_64.20140828192005.tgz
[root@mail1 tmp]#cd zcs-8.5.0_GA_3042.RHEL6_64.20140828192005
[root@mail1 zcs-8.5.0_GA_3042.RHEL6_64.20140828192005]#./install.sh --platform-override



After installation, i;ve created few users and mails to gmail and yahoo are delivering but mails to my self domains are relayed to the MX.


My local zimbra is sending the local mail to the MX pointer and not delivering them locally. Kindly suggest what i'm missing in the above configuration.




iozatay
Posts: 7
Joined: Sat Sep 13, 2014 3:18 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby iozatay » Mon Sep 15, 2014 10:08 am

You must resolve the mx record of the server. Basically you could do it by installing the bind and setup the zone file for example.org domain and edit the resolve.conf file and add 127.0.0.1 for name server. After that it is going to work.
chauhananshul
Posts: 6
Joined: Mon Sep 15, 2014 5:29 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby chauhananshul » Tue Sep 16, 2014 12:14 am

My mx is resolving from my local zimbra server and the problem is my zimbra server is relaying local mails to my MX instead of delivering locally. I've tried with adding 127.0.0.1 in the resolv.conf but then also the local mails are relayed to the MX but mails to other domains like gmail, yahoo delvering normally. Kindly suggest.
iozatay
Posts: 7
Joined: Sat Sep 13, 2014 3:18 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby iozatay » Tue Sep 16, 2014 12:47 am

That's not possible, for me it seems something wrong with the mx record. Can you post the dig output?

dig mx yourdomain.com
damith
Posts: 44
Joined: Sat Sep 13, 2014 3:57 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby damith » Mon Sep 22, 2014 6:33 am

change your dns setting on "/etc/sysconfig/network-scripts/ifcfg-eth0" test this

dns1=127.0.0.1
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2782
Joined: Thu May 22, 2014 4:47 pm

New Install Problem in ZCS-8.5 on Centos 6.5

Postby jorgedlcruz » Mon Sep 22, 2014 1:54 pm

Also in the /etc/resolv.conf

nameserver 127.0.0.1

nameserver 8.8.8.8
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
damith
Posts: 44
Joined: Sat Sep 13, 2014 3:57 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby damith » Wed Sep 24, 2014 12:21 am

remove this nameserver 8.8.8.8 and check again
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2782
Joined: Thu May 22, 2014 4:47 pm

New Install Problem in ZCS-8.5 on Centos 6.5

Postby jorgedlcruz » Wed Sep 24, 2014 5:21 am

It is working chauhananshul? We are waiting for your response :)



Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
chauhananshul
Posts: 6
Joined: Mon Sep 15, 2014 5:29 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby chauhananshul » Wed Sep 24, 2014 6:57 am

[root@zimbra ~]# dig mx ntl-group.com



; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.23.rc1.el6_5.1 <<>> mx ntl-group.com

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13505

;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0



;; QUESTION SECTION:

;ntl-group.com. IN MX



;; ANSWER SECTION:

ntl-group.com. 63611 IN MX 10 mail.ntl-group.com.



;; Query time: 0 msec

;; SERVER: 127.0.0.1#53(127.0.0.1)

;; WHEN: Wed Sep 24 17:22:41 2014

;; MSG SIZE rcvd: 52





[root@zimbra ~]# cat /etc/resolv.conf

nameserver 127.0.0.1

nameserver 8.8.8.8

nameserver 4.2.2.2

[root@zimbra ~]# cat /etc/hosts

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

192.168.0.2 zimbra.ntl-group.com

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

[root@zimbra ~]#
chauhananshul
Posts: 6
Joined: Mon Sep 15, 2014 5:29 am

New Install Problem in ZCS-8.5 on Centos 6.5

Postby chauhananshul » Wed Sep 24, 2014 7:00 am

[root@zimbra ~]# cat /etc/resolv.conf

nameserver 127.0.0.1

nameserver 8.8.8.8

nameserver 4.2.2.2

[root@zimbra ~]# cat /etc/hosts

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

132.147.0.2 zimbra.ntl-group.com

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

[root@zimbra ~]#

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 10 guests