Polling PoP email accounts

Ask questions about your setup or get help installing ZCS server (ZD section below).
derr1ck
Advanced member
Advanced member
Posts: 53
Joined: Fri Sep 12, 2014 10:34 pm

Polling PoP email accounts

Postby derr1ck » Fri Mar 28, 2008 2:08 pm

Hi,
Could some one tell me the correct arguments for zmpov mds (user) (ext pop account) zimbraDataSourcePollingInterval 60 ??
I keep getting "error: account.NO_SUCH_DATA_SOURCE
trying to switch on pop email polling on FOSS 5.0.x
Thanks.


phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Polling PoP email accounts

Postby phoenix » Fri Mar 28, 2008 3:20 pm

Check the setting with:
zmprov gc default | grep zimbraDataSourcePollingInterval
Set the interval:
zmprov mc default zimbraDataSourcePollingInterval 60
Confirm setting:
zmprov gc default | grep zimbraDataSourcePollingInterval

zimbraDataSourcePollingInterval: 60
Check if the feature is enabled with:
zmprov gc default | grep zimbraFeatureMailPollingIntervalPreferenceEnabled
Enable the feature with:
zmprov mc default zimbraFeatureMailPollingIntervalPreferenceEnabled TRUE
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
derr1ck
Advanced member
Advanced member
Posts: 53
Joined: Fri Sep 12, 2014 10:34 pm

Polling PoP email accounts

Postby derr1ck » Fri Mar 28, 2008 4:17 pm

Thanks Bill,
"zmprov mc default zimbraFeatureMailingPollingIntervalPreferenceEnabled= TRUE"
everything but the last step works I get the following error:-
ERROR: account.INVALID_ATTR_NAME (invalid attr name: [LDAP: error code 17 - zimbraFeatureMailingPollingIntervalPreferenceEnabled=: AttributeDescription contains inappropriate characters])
phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Polling PoP email accounts

Postby phoenix » Fri Mar 28, 2008 4:34 pm

My fault, there shouldn't be an equals sign in that last command - remove it and it'll work fine.:o
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
derr1ck
Advanced member
Advanced member
Posts: 53
Joined: Fri Sep 12, 2014 10:34 pm

Polling PoP email accounts

Postby derr1ck » Fri Mar 28, 2008 4:54 pm

nope took away equals sign still same error.
phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Polling PoP email accounts

Postby phoenix » Sat Mar 29, 2008 2:27 am

What does the following return:
zmprov gc default | grep Polling
post the results.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
derr1ck
Advanced member
Advanced member
Posts: 53
Joined: Fri Sep 12, 2014 10:34 pm

Polling PoP email accounts

Postby derr1ck » Sat Mar 29, 2008 5:18 am

It seems ok it has returned:-
zimbraDataSourceMinPollingInterval: 1m

zimbraDataSourcePollingInterval: 60

zimbraFeatureMailPollingIntervalPreferenceEnabled: TRUE

zimbraMailMinPollingInterval: 2m

zimbraPrefMailPollingInterval: 5m
But mail still is not coming through. is the above correct?
phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Polling PoP email accounts

Postby phoenix » Sat Mar 29, 2008 6:08 am

Yes, those setting all look OK. What I suggest you now do is go through each of the external accounts save each of their settings again (including the passwords) and save the settings from the accounts tab. Wait until a couple of periods have passed and check your /opt/zimbra/log/mailbox.log and see what messages you are getting about the retrieval.
Where are you putting the mail when it's retrieved, is it in your Inbox or in separate folders? If you don't retrieve mail on a timed interval, what happens if you hit the Get Mail button?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Maja
Posts: 30
Joined: Fri Sep 12, 2014 10:07 pm

Polling PoP email accounts

Postby Maja » Mon May 05, 2008 1:22 pm

We are having a similar issue. From what I've found, searching the forums, we have things set up correctly (polling interval and polling set to true), yet it doesn't appear that the pollling ever occurs. I can manually check mail and it works without issue, but it does not actually pull it automatically.
Something I'm missing?
phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Polling PoP email accounts

Postby phoenix » Mon May 05, 2008 2:24 pm

Post the details of the Polling intervals as per my post above.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests