Page 1 of 1

[SOLVED] Problems with upgrade from 8.0.1 version - asks to install zimbra-mta

Posted: Sat Jan 11, 2014 4:06 pm
by arnisraido
Hi!
Yesterday I did upgrade from 8.0.1 to 8.0.6 Zimbra Ubuntu 12.04 64-bit version, but I had few problems. After upgrade, messages were nor delivered, nor received. With reject message from Postfix.
After problems, I have restored to snapshot, and LIVE server is up and running 8.0.1. But I havecreated a clone for test upgrades.
So, the first thing: when I start ./install.sh, it asks for upgrade, and then - asks again to install zimbra-mta.

MTA _IS_ installed already, and this would be required to upgrade it, not install as fresh service, am I right?
Checking for prerequisites...

FOUND: NPTL

FOUND: netcat-openbsd-1.89-4ubuntu1

FOUND: sudo-1.8.3p1-1ubuntu3.4

FOUND: libidn11-1.23-2

FOUND: libpcre3-8.12-4

FOUND: libgmp3c2-2:4.3.2+dfsg-2ubuntu1

FOUND: libexpat1-2.0.1-7.2ubuntu1.1

FOUND: libstdc++6-4.6.3-1ubuntu5

FOUND: libperl5.14-5.14.2-6ubuntu2.3
Checking for suggested prerequisites...

FOUND: pax

FOUND: perl-5.14.2

FOUND: sysstat

FOUND: sqlite3

Prerequisite check complete.

Checking current number of databases...
Do you want to verify message store database integrity? [Y] n
Checking for installable packages
Found zimbra-core

Found zimbra-ldap

Found zimbra-logger

Found zimbra-mta

Found zimbra-snmp

Found zimbra-store

Found zimbra-apache

Found zimbra-spell

Found zimbra-memcached

Found zimbra-proxy


The Zimbra Collaboration Server appears already to be installed.

It can be upgraded with no effect on existing accounts,

or the current installation can be completely removed prior

to installation for a clean install.
Do you wish to upgrade? [Y] y
Select the packages to install

Upgrading zimbra-core

Upgrading zimbra-ldap

Upgrading zimbra-logger
Install zimbra-mta [N]


In fact - I had few problems with 8.0.1 before, where I was forced to restore few folders from backup, but do not remembre, probably postfix also.

It would be the best - to install fresh 8.0.1 on new server, and move message and user store to new server, but I did not found good tutorial for 8th version. Does anyone has materials for that?

[SOLVED] Problems with upgrade from 8.0.1 version - asks to install zimbra-mta

Posted: Sun Jan 12, 2014 11:30 am
by arnisraido
Even
dpkg -s zimbra-mta
did not found installed package (this is the same command install.sh ir running to determine installed packages).
I decided to fix installation, based on forum [SOLVED] Upgrade Problem: zimbra-core...NOT FOUND : Release package zimbra-core is no
0. MAKE FULL BACKUP. MAKE SNAPSHOT OR anything to be sure, if something goes wrong!!!
1. stop all services



su - zimbra

zmcontrol stop


2. rename old zimbra

mv /opt/zimbra /opt/zimbra_bak


3. install the same Zimbra version (in my case - 8.0.1) with "-s" switch (will install only software packages)

and choose NOT TO UPGRADE, but install fresh version. It will show, that all mails/users will be deleted!

./install.sh -s


4. check, if all services are stopped



su - zimbra

zmcontrol stop

5. rename new version (or delete if You wish)

mv /opt/zimbra /opt/zimbra_new


6. Now, run latest installation script, 8.0.6 in my case, with normal "./install.sh"

Installation script now correctly recognizes, that zimbra-mta is installed.

Now choose to upgrade!
Everything went well. It took time to recognize, that all services are running in WEB ADMIN GUI, but in command line everything worked as expected.