Page 1 of 2

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Wed Jun 04, 2014 10:39 pm
by Brad_C
What?!?
libreoffice and its 250M of dependencies on a Server ?
I notice inspecting util/utilfunc.sh that libreoffice is only a dep on Ubuntu. Is this some artifact of the beta build or is this likely to be a hard requirement going forward?

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Thu Jun 05, 2014 11:03 am
by 15337Raunaq
ZCS 8.5 will be requiring libreoffice for high fidelity doc preview.

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Thu Jun 05, 2014 2:06 pm
by quanah
It will actually be optional for 8.5, not required. But if you want the newer preview engine, it is required.

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Thu Jun 05, 2014 7:28 pm
by Brad_C
[quote user="quanah"]It will actually be optional for 8.5, not required. But if you want the newer preview engine, it is required.[/QUOTE]
Thanks for the clarification guys. We are running 7.2.6 on Ubuntu 10.04, so I cloned our system to a test VM and ran up to 8.5 yesterday. This went like :

- Upgrade 7.2.6 to 8.0.7 - Ubuntu 10.04

- Upgrade OS to 12.04

- Upgrade 8.0.7-10.04 to 8.0.7-12.04

- Upgrade 8.0.7-12.04 to 8.5-12.04

- Upgrade OS to 14.04

- Upgrade 8.5-12.04 to 8.5-14.04
All went flawlessly and the web interface ran well. The only hitch I've found so far is in the Admin console.
Configure->Global Settings->MTA results in this :

"JavaScript error encountered in method ZaOverviewPanelController.prototype._overviewTreeListener"

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Thu Jun 05, 2014 7:44 pm
by quanah
Thanks! Can you file a bug on that last issue and let me know the bug#? :)

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Thu Jun 05, 2014 7:59 pm
by Brad_C
Done. Bug No. 91488
https://bugzilla.zimbra.com/show_bug.cgi?id=91488
I'm
going to backup this VM so if required I can do further tests on it.

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Thu Jun 05, 2014 8:29 pm
by quanah
Thanks very much!

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Fri Jun 13, 2014 4:21 pm
by 10119metux
By the way: where can I get the source for 8.5 ?

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Fri Jun 13, 2014 4:28 pm
by quanah
The main-foss repo has 8.5 source.

ZCS-NE 8.5 BETA2 requires libreoffice on UBUNTU 14.04

Posted: Tue Jun 17, 2014 12:08 pm
by 10119metux
Okay, got it :)
Build process (at least 3rdparty stuff) seems to have improved quite a lot.
But still a lots of problems. Will push my fixes to github:

https://github.com/metux/open-zimbra