zimbra localhost installation troubles

Ask questions about your setup or get help installing ZCS server (ZD section below).
seravitae
Posts: 21
Joined: Fri Sep 12, 2014 10:28 pm

zimbra localhost installation troubles

Postby seravitae » Wed Jan 21, 2009 3:35 am

Hi there, i currently don't have DNS server, I wish to install zimbra on a server only for LAN usage (remote users will be able to access it with port forwarding via NAT on my external IP).. does zimbra need the external IP for that?
i ask because ive been trying to install zimbra and i get these problems:
root@lina:/home/seravitae/tmp/zcs-5.0.11_GA_2695.UBUNTU8.20081117052520# ./install.sh

hostname: Unknown host

hostname: Unknown host

---------------

skipping a bit...

---------------

Operations logged to /tmp/zmsetup.01212009-190052.log

Setting defaults...hostname: Unknown host

No results returned for A lookup of

Checked nameservers:

10.1.1.1

DNS ERROR resolving

It is suggested that the hostname be resolveable via DNS

Change hostname [Yes] No
DNS ERROR resolving MX for

It is suggested that the domain name have an MX record configured in DNS

Change domain name? [Yes] No
my /etc/hosts:

seravitae@lina:~$ cat /etc/hosts

127.0.0.1 localhost.localdomain localhost


my /etc/hostname:

seravitae@lina:~$ cat /etc/hostname

lina


My /etc/resolv.conf

seravitae@lina:~$ cat /etc/resolv.conf

nameserver 10.1.1.1

how can i trick zimbra into runnign without a dns server? or do i need to install one? I don't understand anything about DNS as yet..
thanks :)


uxbod
Ambassador
Ambassador
Posts: 7811
Joined: Fri Sep 12, 2014 10:21 pm

zimbra localhost installation troubles

Postby uxbod » Wed Jan 21, 2009 3:47 am

As you are on a private IP you will need to setup a Wiki :: Split DNS architecture. Also, your /etc/hosts file is incorrect so I would recommend reading through the Quick Start Installation Guide.
seravitae
Posts: 21
Joined: Fri Sep 12, 2014 10:28 pm

zimbra localhost installation troubles

Postby seravitae » Wed Jan 21, 2009 4:37 am

hi there, thanks for the pointer.


root@lina:/var/named# cat /etc/hosts

127.0.0.1 localhost.localdomain localhost

10.1.1.2 server.example.com server


Is that correct now?
I installed the package, but neither /var/named or /etc/named exists.. ??
i created /var/named/ and made a new file for the config anyways..
When i went to start the server (/etc/init.d/named start) i discovered that named doesnt exist in init.d... i used the ubuntu package from the repository... not sure what gives?? i ran named by itself, checked with ps aux | grep named and it's there. however nslookup server.example.com yeilds:
root@lina:/etc/init.d# nslookup server.example.com

;; connection timed out; no servers could be reached


any help much appreciated. i followed the split-dns guide to the letter..
seravitae
Posts: 21
Joined: Fri Sep 12, 2014 10:28 pm

zimbra localhost installation troubles

Postby seravitae » Thu Jan 22, 2009 6:46 am

ok, i investigated a bit more, and i believe I have my config correct.. however when i run named nothing happens. since /etc/init.d/named doesnt exist i have to manually run it. i get no errors, nothing in syslog, nothing in named log, and ps aux | grep named shows its not running, like it just exits instantly.
I dont think this is supposed to happen...?
partner
Posts: 20
Joined: Fri Sep 12, 2014 11:22 pm

zimbra localhost installation troubles

Postby partner » Thu Jan 22, 2009 7:19 am

I am not familiar with the Ubuntu platform but yu have to install a DNS server on your local machine to get it working. If you do not find the named.conf, you are definitely looking at either the wrong location or you simply have not installed the DNS server.
As a reference I use the openSUSE platform and used yast to select and install the needed packages to run the DNS server. After that I used the zimbra WIKIS to tweak the configuration to match the requirements for zimbra. I am most conident that Ubuntu has a similar service for you and I suggest you check the forums for how to do this in Ubuntu.
partner
Posts: 20
Joined: Fri Sep 12, 2014 11:22 pm

zimbra localhost installation troubles

Postby partner » Thu Jan 22, 2009 7:21 am

On a second note. You indicated to install it for local use only and I do not see you have a domain name available for your mailserver. If you do not have a fully qualified domain name search this forum how to install zimbra without FQDN there are already several entries to guide you through this process.
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

zimbra localhost installation troubles

Postby jholder » Fri Jan 23, 2009 11:46 am

You probably have chroot installed.
Making Zimbra & BIND Work Together » Zimbra :: Blog

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests