Page 1 of 1

Program not able to start after reboot

Posted: Wed Jan 21, 2009 9:16 pm
by SpAcKs
Linode VPS

Debian 4.0

Zimbra CE 5.0.11
For starters, please bear with me, I'm noob at the whole Linux/Zimbra experience. However, I thought I managed to successfully installed Zimbra CE onto my virtual server. I was even able to add a few domains, accounts, and send/receive emails/IM's. All was right with the world. Then I decided to reboot the server to give it a clean boot before I totally unleashed it on the www. After the server rebooted, to my surprise I couldn't access the web based login anymore. When I checked on the Zimbra services this is what I found.
[QUOTE]zimbra@mail:~$ zmcontrol status

Unable to determine enabled services from ldap.

Enabled services read from cache. Service list may be inaccurate.

Host mail.webimax.com

antispam Stopped

zmmtaconfigctl is not running

zmamavisdctl is not running

antivirus Stopped

zmmtaconfigctl is not running

zmamavisdctl is not running

zmclamdctl is not running

ldap Stopped

logger Stopped

logmysql.server is not running

zmlogswatchctl is not running

mailbox Stopped

zmmtaconfigctl is not running.

mysql.server is not running.

zmmailboxdctl is not running.

mta Stopped

zmmtaconfigctl is not running

postfix is not running

zmsaslauthdctl is not running

snmp Stopped

zmswatch is not running.

spell Stopped

zmapachectl is not running

stats Stopped

[/QUOTE]
Then when I tried to restart the services I received the following error message;
[QUOTE]zimbra@mail:~$ zmcontrol start

Host mail.webimax.com

Starting ldap...Done.

FAILED

Failed to start slapd. Attempting debug start to determine error.

bdb_db_close: txn_checkpoint failed: Invalid argument (22)

backend_startup_one: bi_db_open failed! (38)

bdb_db_close: alock_close failed

[/QUOTE]
I'm not having much luck finding any information on this message, so any help would greatly appreciated.

Program not able to start after reboot

Posted: Thu Jan 22, 2009 10:43 am
by SpAcKs
Update:
I can get just about all of the Zimbra services started manually except for 'ldap'.
Can someone provide me a starting point to troubleshoot as to why this is happening?
[QUOTE]zimbra@mail:~$ ldap start

Failed to start slapd. Attempting debug start to determine error.

bdb_db_close: txn_checkpoint failed: Invalid argument (22)

backend_startup_one: bi_db_open failed! (38)

bdb_db_close: alock_close failed

[/QUOTE]

Program not able to start after reboot

Posted: Fri Jan 23, 2009 11:42 am
by jholder
Welcome to the Zimbra forums!
How did you stop the server before reboot? Was it a clean shutdown?
Can you post your /var/log/zimbra.log?

Program not able to start after reboot

Posted: Fri Jan 23, 2009 12:04 pm
by SpAcKs
Thanks for the reply...Sorry I forgot to update this post.
I was rebooting the server using the 'reboot' command as the root.
I reloaded the OS & Zimbra on my virtual server multiple times and each time I rebooted the same thing happened. So I finally abandoned Debian 4.0 and installed Ubuntu 8.04 LTS. I've been testing the system for the last few hours and everything is working properly. Even after a reboot.