[SOLVED] Server Status connection refused in admin console

Ask questions about your setup or get help installing ZCS server (ZD section below).
tkosig
Posts: 10
Joined: Sat Sep 13, 2014 12:39 am

[SOLVED] Server Status connection refused in admin console

Postby tkosig » Tue Aug 18, 2009 2:15 am

I know there has been a similar thread before that has been marked solved (here). The author of the thread solved his problem by complete re-installation of the ZCS which at this time is NOT an option to me.
We're in the process of evaluating ZCS Network Edition and so far we like it. The problem I need help with is that accidentially I installed the zimbra-logger package on both mailstore and MTA server.
I quote from the other thread (as I am having exactly the same problem!):
[QUOTE]

When I click on the server status item in the left panel of the administration web page, I received the following error:
Message: error while proxying request to target server Connection refused Error code: service.PROXY_ERROR Method: GetServiceStatusRequest Details:soap:Receiver

[/QUOTE]
In the mailbox.log file I see:
2009-08-18 09:09:39,192 INFO [btpool0-34] [name=timo.kosig@mycompany.com;mid=4;ip=192.168.100.29;ua=ZimbraWebClient - FF3.0 (Win);] SoapEngine - handler exception

com.zimbra.common.service.ServiceException: error while proxying request to target server Connection timed out

ExceptionId:btpool0-34:1250579379192:d84fee73f357f6d5

Code:service.PROXY_ERROR Arg:(url, STR, https://mta.mycompany.com:7071/service/admin/soap/GetServiceStatusRequest")




Our sever setup is quite simple. We have a dedicated mailstore server in the trusted network, and the MTA is located in our DMZ.
I disabled the logger on the MTA after realising my mistake. Still it seems that a request is sent to the MTA on port 7071 which times out eventually causing an exception (I left the stack trace out but can supply one anytime needed).
Please help me to fix this problem. As I said before, re-installation is not feasible.
Thanks in advance,

Timo Kosig


tkosig
Posts: 10
Joined: Sat Sep 13, 2014 12:39 am

[SOLVED] Server Status connection refused in admin console

Postby tkosig » Tue Aug 18, 2009 3:45 am

I solved the problem by setting zimbraLogHostname to the right hostname. After installing the logger on the mta zimbraLogHostname was set to mta.company.com.
zmprov modifyConfig zimbraLogHostname mailstore.company.com

Did solve the problem - without re-installing everything.
ECB
Posts: 43
Joined: Sat Sep 13, 2014 12:00 am

[SOLVED] Server Status connection refused in admin console

Postby ECB » Thu Oct 01, 2009 2:46 am

That solved my problem too. Thanks for the tip!
sufehmi
Posts: 2
Joined: Sat Sep 13, 2014 2:05 am

[SOLVED] Server Status connection refused in admin console

Postby sufehmi » Fri Apr 13, 2012 9:38 pm

Thanks tkosig ! Your posts helped me solved my problem.
Basically I have accidentally setup a Zimbra server with localhost.localdomain set as its hostname. Very bad.
Some other post suggested to delete it from the Global Server config. However, it failed with error message :
> zmprov ds localhost.localdomain

ERROR: service.TOO_MANY_HOPS (mountpoint or proxy loop detected)


So I checked to see what services that it had registered :
### set variables

su - zimbra

source ~/bin/zmshutil

zmsetvars

### start checking current setting

ldapsearch -LLL -x -D $zimbra_ldap_userdn -w $zimbra_ldap_password -H $ldap_url -b "" | grep -i localdomain

zmprov -l gaa -s localhost.localdomain

zmlocalconfig | grep -i localdomain

zmprov gacf | grep -i localdomain


Looks like zimbraLogHostname is the most important one.
So I found your post, and how to change it :
> zmprov modifyConfig zimbraLogHostname my.zimbra.server

Voila ! No more "PROXY_ERROR Method: GetServiceStatusRequest" error message whenever I tried to access the Global Config :D
Thanks again !

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests