[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Ask questions about your setup or get help installing ZCS server (ZD section below).
mtanzer
Posts: 36
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby mtanzer » Sun Sep 13, 2009 1:23 pm

I tried an upgrade from 5.0.16_GA to 6.0_GA, after the upgrade mailboxd did nont start. I ran in this Error:

Zimbra server reserving server socket port=110 bindaddr=null ssl=false

Zimbra server reserving server socket port=995 bindaddr=null ssl=true

Fatal error. exception while binding to ports.

Java.net.BindException: cannot assign requested address
which ist described http://www.zimbra.com/forums/installation/32678-zimbra-6-mailboxd-zmmailboxdctl-do-not-start-after-upgrade-solution.html
The
Solution did not work, I ran into this Error:



root@zimbra:/usr/src/zcs-6.0.0_GA_1802.UBUNTU6.20090830162655# /opt/zimbra/bin/zmcertmgr deploycrt self

** Saving server config key zimbraSSLCertificate...failed.

** Saving server config key zimbraSSLPrivateKey...failed.

** Installing mta certificate and key...done.

** Installing slapd certificate and key...done.

** Installing proxy certificate and key...done.

** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...failed.
XXXXX ERROR: failed to create jetty.pkcs12

unable to load private key



which seems to be described here: [url=Failed to create jetty.pkcs12 - Zimbra :: Wiki[/url]
I tried to solve this problem, no sucess. LDAP does not start at all. Trying to reinstall I finaly recieve this:


Starting ldap...failed with exit code: 256.

main: TLS init def ctx failed: -1


Now the server seems to be broken, pleas help! PANIC!


iway
Outstanding Member
Outstanding Member
Posts: 425
Joined: Fri Sep 12, 2014 11:31 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby iway » Sun Sep 13, 2009 4:32 pm

Looks like a cert issue. Try reinstalling the server certs.
mtanzer
Posts: 36
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby mtanzer » Sun Sep 13, 2009 4:39 pm

I solved it. After the upgrade the file /opt/zimbra/jetty/etc/keystore was missing. Moving from one error to the other the problem got worse and worse. Finally I followed this instructions.
Recreating a Self-Signed SSL Certificate - Zimbra :: Wiki
This solved my problem.
meikka
Posts: 27
Joined: Fri Sep 12, 2014 10:01 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby meikka » Sun Oct 25, 2009 2:53 pm

I upgraded from 5.0.16 to 6.0.2 and I had the same problem.
Only the manual certificate operation solved the problem.
Thanks guys!!
-- Timo
PS. 6.0.2 is great
mtanzer
Posts: 36
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby mtanzer » Sun Nov 08, 2009 8:12 am

I upgraded the Commercial Distribution from 5.0.18 to 6.0.2 - still the same Problem! Since 3 releases not solved... I have a lot of Servers to upgrade, so I wait for 6.0.3. Hope you guys will have fixed it then.
3648Des
Posts: 12
Joined: Sat Sep 13, 2014 12:45 am

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby 3648Des » Sun Nov 08, 2009 12:50 pm

[quote user="mtanzer"]I solved it. After the upgrade the file /opt/zimbra/jetty/etc/keystore was missing. Moving from one error to the other the problem got worse and worse. Finally I followed this instructions.
Recreating a Self-Signed SSL Certificate - Zimbra :: Wiki
This solved my problem.[/QUOTE]
So the instructions for 5.0+ are valid for 6.0+?
mtanzer
Posts: 36
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby mtanzer » Tue Nov 10, 2009 1:35 am

Yes, it worked for me.
8134Himanshu
Outstanding Member
Outstanding Member
Posts: 217
Joined: Fri Sep 12, 2014 11:16 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby 8134Himanshu » Tue Nov 10, 2009 10:20 pm

[quote user="mtanzer"]I solved it. After the upgrade the file /opt/zimbra/jetty/etc/keystore was missing. Moving from one error to the other the problem got worse and worse. Finally I followed this instructions.
Recreating a Self-Signed SSL Certificate - Zimbra :: Wiki
This solved my problem.[/QUOTE]
This Solved my Problem too for 5.02 t 6.02
rnuno
Posts: 18
Joined: Fri Sep 12, 2014 10:35 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby rnuno » Mon Jan 04, 2010 1:19 pm

Upgraded from 5.0.18 to 5.0.21 and now i cant stard my server my server:
        Starting ldap...Done.

FAILED

Failed to start slapd. Attempting debug start to determine error.

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:02001002:system library:fopen:No such file or directory bss_file.c:356

TLS: error:20074002:BIO routines:FILE_CTRL:system lib bss_file.c:358

main: TLS init def ctx failed: -1

What we tryed:
AS Root:

[root@email /]# rm -rf /opt/zimbra/ssl

[root@email /]# mkdir /opt/zimbra/ssl

[root@email /]# chown zimbra:zimbra /opt/zimbra/ssl

[root@email /]# chown zimbra:zimbra /opt/zimbra/java/jre/lib/security/cacerts

[root@email /]# chmod 644 /opt/zimbra/java/jre/lib/security/cacerts

[root@email /]# /opt/zimbra/bin/zmcertmgr createca -new

** Creating directory /opt/zimbra/ssl/zimbra

** Creating directory /opt/zimbra/ssl/zimbra/ca

** Creating directory /opt/zimbra/ssl/zimbra/server

** Creating directory /opt/zimbra/ssl/zimbra/commercial

** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf...done

** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.

** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.

[root@email /]# /opt/zimbra/bin/zmcertmgr deployca -localonly

** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.

** Copying CA to /opt/zimbra/conf/ca...done.

[root@email /]# /opt/zimbra/bin/zmcertmgr createcrt self -new

** Creating /opt/zimbra/conf/zmssl.cnf...done

** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20100104191121

** Retrieving server config key zimbraSSLCertificate...failed.

** Retrieving server config key zimbraSSLPrivateKey...failed.

** Generating a server csr for download self

** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20100104191123

** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.

** Saving server config key zimbraSSLPrivateKey...failed.

** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.

[root@email /]# /opt/zimbra/bin/zmcertmgr deploycrt self

** Saving server config key zimbraSSLCertificate...failed.

** Saving server config key zimbraSSLPrivateKey...failed.

** Installing mta certificate and key...done.

** Installing slapd certificate and key...done.

** Installing proxy certificate and key...done.

** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.

** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.

** Installing CA to /opt/zimbra/conf/ca...done.


As Zimbra:
[zimbra@email ~]$ keytool -delete -alias my_ca -keystore /opt/zimbra/java/jre/lib/security/cacerts -storepass changeit

[zimbra@email ~]$ keytool -delete -alias jetty -keystore /opt/zimbra/mailboxd/etc/keystore -storepass zimbra

[zimbra@email ~]$ zmlocalconfig -s -m nokey mailboxd_keystore_password

zimbra

[zimbra@email ~]$ zmcontrol start

Host email.system.com

Starting ldap...Done.

FAILED

Failed to start slapd. Attempting debug start to determine error.

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:650

TLS: error:02001002:system library:fopen:No such file or directory bss_file.c:356

TLS: error:20074002:BIO routines:FILE_CTRL:system lib bss_file.c:358

main: TLS init def ctx failed: -1


Please any help would be great we cant bring the server back up
iway
Outstanding Member
Outstanding Member
Posts: 425
Joined: Fri Sep 12, 2014 11:31 pm

[SOLVED] Unable to upgrade from 5.0.16 to 6.0 - Server broken, a nightmare!

Postby iway » Mon Jan 04, 2010 1:28 pm

HAve you checked the hosts file?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests