Page 1 of 1

[SOLVED] Error while testing after installation

Posted: Sun Sep 27, 2009 7:41 pm
by Infolookup
Hello All,
I am getting the following error while sending a test email after my installation. Setup is domain registered--> hosting server at home using dyndns-->ISP verizon.
I did the following:
[QUOTE]Enable SMTP authentication on outbound messages:
Code:
$ postconf -e smtp_sasl_auth_enable=yes
Create a file text file mapping which name/password should be used for

which given outbound destination. This file can contain multiple

lines.
Code:
$ echo mailrelay.example.com user:password > /opt/zimbra/conf/relay_password
Create a postfix lookup table from this text file:
Code:
$ postmap /opt/zimbra/conf/relay_password
Test that the map is okay and that the user: password pair is returned.
Code:
$ postmap -q mailrelay.example.com /opt/zimbra/conf/relay_password

user:password
Make postfix use this:
Code:
$ postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password

$ postfix reload[/QUOTE]
Error I am getting

[QUOTE]: host outgoing.verizon.net[206.46.232.12]

said: 550 5.7.1 Authentication Required (in reply to MAIL FROM command)[/QUOTE]
Thanks in advance.

[SOLVED] Error while testing after installation

Posted: Sun Sep 27, 2009 9:37 pm
by Infolookup
I am getting a new error after I ran the following command:
[QUOTE]postconf -e smtp_cname_overrides_servername=no[/QUOTE]
new error
[QUOTE] After sending a test message, check the Log Files for the error:
(Authentication failed: cannot SASL authenticate to server ...: no mechanism available)
You can fix this problem by tweaking the auth mechanisms that postfix is willing to use. First check what auth mechanism postfix is configured to use - by default, you will see:
postconf smtp_sasl_security_options

smtp_sasl_security_options = noplaintext, noanonymous
Since noplaintext is present, postfix will refuse to use a mechanism that sends passwords in the clear. If your upstream relay host only supports PLAIN or LOGIN mechanisms (both of which send password in the clear), you have to remove noplaintext from smtp_sasl_security_options:
postconf -e smtp_sasl_security_options=noanonymous

postfix reload

[/QUOTE]
Applying this to see if it fixed it if so you can close this post.