can't access ZWC Advanced outside of network

Ask questions about your setup or get help installing ZCS server (ZD section below).
Neoculture
Posts: 2
Joined: Sat Sep 13, 2014 12:51 am

can't access ZWC Advanced outside of network

Postby Neoculture » Wed Nov 18, 2009 6:39 pm

Hi,
I am a Zimbra newbie trying it out as a replacement for my aging personal mail server (see this thread for my saga of woes). One of the problems I have been having is not being able to use the Ajax/Advanced version of the Web Client outside of my network. :confused:
My setup is a 512/128Kb ADSL line, the ADSL modem redirects the traffic based on port/protocol, and I'm running Zimbra 6.0 on Ubuntu 8.04 on salvaged hardware.
And everything seems to be working from inside my home network, but not from outside - while I can use the html/standard web client, trying to use the ajax/advanced client outside the network causes the process to stop at the http://mydomain.com/zimbra/?client=advanced[/url] screen (the one which reads "loading...").
I first thought this might have something to do with my rather slow ADSL speed, until I noticed that Firebug wanted my attention. So I tried IE, just in case, and (after a long pause) it gave me an error too. :(
And the error is:
Line: 6437

Char: 37

Error: Expected ')'

Code: 0

URL: http://mydomain.com/zimbra/?client=advanced[/url]
Running it with dev=1 gets me the following errors (after an interminable wait):
Line: 685

Char: 107

Error: Expected identifier

Code: 0

URL:
Line
: 799

Char: 29

Error: Unterminated comment

Code: 0

URL:
Meanwhile
, Firebug reports:

ZmMsg is not defined

zimbra?client=advanced&dev=1()

zimbra?c...ced&dev=1 (line 374)

*


zimbra?c...ced&dev=1 (line 352)

ZmMsg is not defined




zimbra?c...ced&dev=1 (line 365)

ZmMsg is not defined



User avatar
Zied FAKHFAKH
Posts: 28
Joined: Tue Jan 07, 2014 1:43 am
Location: Tunisia
ZCS/ZD Version: ZCS 8.6
Contact:

Re: can't access ZWC Advanced outside of network

Postby Zied FAKHFAKH » Tue May 24, 2016 8:23 pm

Same error here, any luck ?
User avatar
Zied FAKHFAKH
Posts: 28
Joined: Tue Jan 07, 2014 1:43 am
Location: Tunisia
ZCS/ZD Version: ZCS 8.6
Contact:

Re: can't access ZWC Advanced outside of network

Postby Zied FAKHFAKH » Tue May 24, 2016 9:15 pm

I think I solved my problem it's about timeouts, you can see that on zmmailboxd.out

so as zimbra check this out:

Code: Select all

zmprov gs $(zmhostname)  zimbraHttpThreadPoolMaxIdleTimeMillis zimbraHttpConnectorMaxIdleTimeMillis

for every server
here are my results:

Code: Select all

[zimbra@zmail etc]$ zmprov gs $(zmhostname)  zimbraHttpThreadPoolMaxIdleTimeMillis zimbraHttpConnectorMaxIdleTimeMillis
# name mail.acme.net
zimbraHttpConnectorMaxIdleTimeMillis: 60000
zimbraHttpThreadPoolMaxIdleTimeMillis: 10000


the zimbraHttpConnectorMaxIdleTimeMillis, is the most important, it was at 1000 for me, I made it 60000 (copy it from another fresh install, this one was upgraded a long way from 7.1), restarted mailboxd and it seems ok.

Code: Select all

zmprov ms  $(zmhostname)  zimbraHttpConnectorMaxIdleTimeMillis 60000
zmmailboxdctl restart


Good luck,
Zied.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests