No luck installing on FC4

Ask questions about your setup or get help installing ZCS server (ZD section below).
lledynot
Posts: 5
Joined: Fri Sep 12, 2014 9:55 pm

No luck installing on FC4

Postby lledynot » Wed Sep 21, 2005 11:51 am

I've tried several times and still have no luck getting things working. For a little upfront background information, I have installed a basic FC4 load in vmware (I did read the information about changing the innodb thing to 50). I am not sure I have all the necessary packages installed since I haven't been able to find that anywhere in the documentation.
Anyway, when I run the install.sh script, for one when I select https, it never prompts me to create the certificate. The install completes...after waiting a while for the servers to start, but then when I run zmcontrol status, all I get back is:
Calling GetServiceInfoRequest (rocky.me.com)
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip 127.0.0.1

name rocky.me.com
I'm not sure what other information I can provide, but any help would be greatly appreciated.
Tony


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

No luck installing on FC4

Postby marcmac » Wed Sep 21, 2005 1:07 pm

[quote user="lledynot"]I've tried several times and still have no luck getting things working. For a little upfront background information, I have installed a basic FC4 load in vmware (I did read the information about changing the innodb thing to 50). I am not sure I have all the necessary packages installed since I haven't been able to find that anywhere in the documentation.
Anyway, when I run the install.sh script, for one when I select https, it never prompts me to create the certificate. The install completes...after waiting a while for the servers to start, but then when I run zmcontrol status, all I get back is:
Calling GetServiceInfoRequest (rocky.ellifino.com)
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip 127.0.0.1

name rocky.me.com
I'm not sure what other information I can provide, but any help would be greatly appreciated.
Tony[/QUOTE]
either ldap or sql is probably failing to start - it appears as if your server object is not being provisioned in ldap.
Can you check (or post) the install.log.$$ file (in /tmp) for errors? Also, verify that slapd and mysql are running.
Also, check your /etc/hosts file (as shown in other threads) to make sure it's correct.
lledynot
Posts: 5
Joined: Fri Sep 12, 2014 9:55 pm

No luck installing on FC4

Postby lledynot » Wed Sep 21, 2005 1:56 pm

ok, the install log said that it could not find libssl.so.4 so I followed the instructions from the other posts about symlinking. Ran the install again, but there are still problems. Below are the contents from the install log. (well, most of the contents...was too long to post)
COMMAND: zmlocalconfig -f -e zimbra_store_directory='${zimbra_home}/store'

COMMAND: zmlocalconfig -e zimbra_server_hostname=rocky.me.com

COMMAND: zmlocalconfig -e ldap_host=rocky.me.com

COMMAND: zmlocalconfig -e ldap_port=389

COMMAND: ldap start

db_recover: Finding last valid log LSN: file: 1 offset 28

Started slapd: pid

COMMAND: zmldapapplyldif

db_recover: Finding last valid log LSN: file: 1 offset 28

Started slapd: pid

ldap_bind: Can't contact LDAP server (-1)

ldap_bind: Can't contact LDAP server (-1)

ldap_bind: Can't contact LDAP server (-1)

ldap_bind: Can't contact LDAP server (-1)

COMMAND: id=`zmprov gs rocky.me.com | grep zimbraId | awk '{print $2}'`; for i in `zmprov gc default | grep zimbraMailHostPool | sed 's/zimbraMailHostPool: //'`; do host="$host zimbraMailHostPool $i"; done; zmprov mc default $host zimbraMailHostPool $id

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException rocky.me.com:389)

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException rocky.me.com:389)

zmprov [cmd] [args ...]
CreateAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2...]]

DeleteAccount(da) {name@domain|id}

GetAccount(ga) {name@domain|id}

GetAllAccounts(gaa) [-v] [{domain}]

GetAllAdminAccounts(gaaa) [-v]

ModifyAccount(ma) {name@domain|id} [attr1 value1 [attr2 value2...]]

SetPassword(sp) {name@domain|id} {password}

AddAccountAlias(aaa) {name@domain|id} {alias@domain}

RemoveAccountAlias(raa) {name@domain|id} {alias@domain}

SetAccountCos(sac) {name@domain|id} {cos-name|cos-id}

SearchAccounts(sa) [-v] {ldap-query} [limit {limit}] [offset {offset}] [sortBy {attr}] [attrs {a1,a2...}] [sortAscending 0|1*] [applyCos [0|1*] [domain {domain}]

SearchGal(sg) {domain} {name}

RenameAccount(ra) {name@domain|id} {newName@domain}
CreateDomain(cd) {domain} [attr1 value1 [attr2 value2...]]

DeleteDomain(dd) {domain|id}

GetDomain(gd) {domain|id}

GetAllDomains(gad) [-v]

ModifyDomain(md) {domain|id} [attr1 value1 [attr2 value2...]]
CreateCos(cc) {name} [attr1 value1 [attr2 value2...]]

DeleteCos(dc) {name|id}

GetCos(gc) {name|id}

GetAllCos(gac) [-v]

ModifyCos(mc) {name|id} [attr1 value1 [attr2 value2...]]

RenameCos(rc) {name|id} {newName}
CreateServer(cs) {name} [attr1 value1 [attr2 value2...]]

DeleteServer(ds) {name|id}

GetServer(gs) {name|id}

GetAllServers(gas) [-v]

ModifyServer(ms) {name|id} [attr1 value1 [attr2 value2...]]
GetAllConfig(gacf)

GetConfig(gcf) {name}

ModifyConfig(mcf) attr1 value1 [attr2 value2...]
CreateDistributionList(cdl) {list@domain}

GetAllDistributionLists(gadl) [-v]

GetDistributionList(gdl) {list@domain|id}

DeleteDistributionList(ddl) {list@domain|id}

AddDistributionListMember(adlm) {list@domain|id} {member@domain}

RemoveDistributionListMember(rdlm) {list@domain|id} {member@domain}
exit (quit)

help (?)
COMMAND: zmmtainit rocky.me.com

COMMAND: zmlocalconfig -e av_notify_user=

COMMAND: zmlocalconfig -e av_notify_domain=

COMMAND: zmlocalconfig -e snmp_notify=no

COMMAND: zmlocalconfig -e smtp_notify=no

COMMAND: zmlocalconfig -e snmp_trap_host=rocky.me.com

COMMAND: zmlocalconfig -e smtp_source=none

COMMAND: zmlocalconfig -e smtp_destination=none

COMMAND: zmsnmpinit

creating /opt/zimbra/conf/swatchrc

COMMAND: zmprov ms rocky.me.com zimbraServiceInstalled ldap zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled snmp

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException rocky.me.com:389)

COMMAND: zmlocalconfig -e zimbra_services="ldap mailbox mta antivirus antispam snmp"

COMMAND: zmcreatecert

** Creating CA private key
Generating a 1024 bit RSA private key

............++++++

..........................++++++

writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'

-----

** Creating CA cert
Signature ok

subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite/CN=localhost.localdomain

Getting Private key

** Importing CA
Certificate was added to keystore

keytool error: java.io.FileNotFoundException: /opt/zimbra/java/jre/lib/security/cacerts (Permission denied)

** Creating keystore
** Creating server cert request
** Signing cert request
Signature ok

subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=localhost.localdomain

Getting CA Private Key

Signature ok

subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=localhost.localdomain

Getting Private key

COMMAND: zmcertinstall mailbox

** Importing server cert
keytool error: java.lang.Exception: Failed to establish chain from reply

COMMAND: zmtlsctl https

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException rocky.me.com:389)

COMMAND: zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key

** Importing server cert
COMMAND: zmlocalconfig -e ssl_allow_untrusted_certs=true

COMMAND: zmcontrol startup

Calling startup (rocky.me.com)
perl /opt/zimbra/zimbramon/zmmon &
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip 127.0.0.1

name rocky.me.com

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

COMMAND: zmlocalconfig -s > .localconfig.save.7145

COMMAND: zmprov gs rocky.me.com > .zmprov.rocky.me.com.save.7145

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException rocky.me.com:389)

COMMAND: zmprov gacf rocky.me.com > .zmprov.gacf.save.7145

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException rocky.me.com:389)

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152

DBI connect('database=zimbra;mysql_read_default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152


Thanks.
Tony
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

No luck installing on FC4

Postby marcmac » Wed Sep 21, 2005 5:13 pm

It looks like the install was either a failed upgrade, or processes from the first failed install were still stuck around - try ./install.sh -u for complete removal, then make sure all zimbra processes are indeed killed before reinstalling.
lledynot
Posts: 5
Joined: Fri Sep 12, 2014 9:55 pm

No luck installing on FC4

Postby lledynot » Wed Sep 21, 2005 8:35 pm

Worked great so far. Thanks for the great feedback and a great product. I will continue to provide feedback as I begin to use all of the features!
slylos
Posts: 11
Joined: Fri Sep 12, 2014 9:55 pm

No luck installing on FC4

Postby slylos » Tue Sep 27, 2005 3:01 pm

[quote user="lledynot"]I have installed a basic FC4 load in vmware (I did read the information about changing the innodb thing to 50).[/QUOTE]
Nice, I was just about to do the same exact thing - FC4 in VMware! What's the deal with the innodb thing? I've got SuSE Pro 9.3 and SLES9 in VMware right now running great, hopefully FC4+Zimbra will work the same.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

No luck installing on FC4

Postby 14319KevinH » Tue Sep 27, 2005 3:54 pm

You should be able to skip the changes to install.sh(aka innodb changes) in milestone 1. We've now got better logic to handle systems with less than 1GB RAM.
vaitguy
Posts: 15
Joined: Fri Sep 12, 2014 9:55 pm

No luck installing on FC4

Postby vaitguy » Thu Oct 13, 2005 4:41 pm

I am having a very similar problem. FC4. I have unistalled numerous times and verified that all processes are not working. When I run the install, the only results from the zmcontrol status are:

host

ip 172.19.12.6

name zimbra.xxxxxx.com
If I grep for mysql and slapd, they are both running. If I launch mysql, the zimbra table is there, etc. If I run a reload or stop and startup zimbra/zmcontrol, mysql fails to launch. the mysql.sock file (that was in the /opt/zimbra/db/ dir) is no longer there of course.
I'm currently running yum to update the system per another persons poast. As I said, I currently get:

DBI connect('database=zimbra;mysql_read_Default_file=/opt/zimbra/conf/my.cnf;mysql_socket=/opt/zimbra/db/mysql.sock','zimbra',...) failed: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 152
Line 152 is the dbi->connect line. Confused? yes I am.
Let me know if you want any logs, etc posted. Thanks, this forum seems pretty awesome as does the pproduct. Would be nice to get off of horde for something more functional.
Michael
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

No luck installing on FC4

Postby 14319KevinH » Thu Oct 13, 2005 6:27 pm

After you run yum update please try the install again. If you run into problems please post your install log from /tmp/install.log.
vaitguy
Posts: 15
Joined: Fri Sep 12, 2014 9:55 pm

No luck installing on FC4

Postby vaitguy » Fri Oct 14, 2005 1:56 pm

Working, makes me feel incompetent. I will have to see what packages were updated, etc.
ON a side, I know we have many posts here to this effect, but we have our own mailgateways using sophos/puremessage for spam/virus filtering and some large sun boxes running our postfix/imap setup and our own ldap server that we could modify the scheme. WHat steps are needed to only use Zimba as our web-mail client?
Will this be somewhat documented in the first release this november?
Thanks, looking for to getting all ajax'd up.
michael

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests