Yet Another cannot connect to server problem....

Ask questions about your setup or get help installing ZCS server (ZD section below).
slott_hansen
Posts: 7
Joined: Fri Sep 12, 2014 9:55 pm

Yet Another cannot connect to server problem....

Postby slott_hansen » Thu Sep 29, 2005 4:04 am

I didn't have the libs in my /lib as I'm running 64 bit.
However I have installed the 32 versions (yum install openssl.i386) and done the symlinks.
I tried to find 32 bit versions of the "missing" DBI.so but some how my fedora3 is missing those :-(
Here is what happens now:
[root@chicago lib64]# time /etc/init.d/zimbra start

Calling startup (localhost.localdomain)
perl /opt/zimbra/bin/zmmon &
Can't load '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi//auto/DBI/DBI.so' for module DBI: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi//auto/DBI/DBI.so: cannot open shared object file: No such file or directory at /usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi/DynaLoader.pm line 230.

at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi//DBI.pm line 254

BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi//DBI.pm line 254.

Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Admin.pm line 37.

BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Admin.pm line 37.

Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 35.

BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/StatusMon.pm line 35.

Compilation failed in require at /opt/zimbra/bin/zmmon line 41.

BEGIN failed--compilation aborted at /opt/zimbra/bin/zmmon line 41.

Soap call failed: 500 Can't connect to localhost:7777 (connect: Connection refused) at /opt/zimbra/bin/zmcontrol line 230


real 3m45.760s

user 0m4.492s

sys 0m0.866s


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Yet Another cannot connect to server problem....

Postby marcmac » Thu Sep 29, 2005 9:15 am

You'll need to download the source, and recompile the DBI and DBD modules (Or, grab them from CPAN, install them, and remove the shipped versions in /opt/zimbra/zimbramon/lib/)

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests