Page 1 of 1

SNMP not loading, can't connect to Admin

Posted: Sat Sep 24, 2005 9:19 am
by abtech
Installed the 3 release on FC4 after checking the hosts file and setting the sym links for SSL. When looking at service status, they are all running except snmp. I am still getting the ldap error in the install log, although ldap is loading (ran the scripts for checking it that are posted in some of the install threads).
Any thoughts would be greatly appreciated.

SNMP not loading, can't connect to Admin

Posted: Sat Sep 24, 2005 10:33 am
by marcmac
Any snmp errors in the install log?
As zimbra, run the zmswatchctl start command, and look for errors there. If it complains about a missing config file, you can re-create the swatch config with zmsnmpinit.

SNMP not loading, can't connect to Admin

Posted: Thu Oct 13, 2005 3:30 am
by Umeboshi
After kind of a long road, and a reinstall (including the OS), almost everything is working except SNMP.
I am using CentOS4.1 with the binary procedure. Reviewing the install log I found some java errors but nothing that seems related to SNMP.
(The very top of the install log)

Preparing packages for installation...


ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)

Preparing packages for installation...
(In the Key / Certification section)

Certificate was added to keystore

keytool error: /opt/zimbra/java/jre/lib/security/cacerts (Permission denied)

** Creating keystore

** Importing server cert
keytool error: java.lang.Exception: Failed to establish chain from reply

COMMAND: zmtlsctl mixed

COMMAND: zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key

** Importing server cert
That's it for errors. Then there is the serivce info as follows:

perl /opt/zimbra/bin/zmmon &
RESPONSE: (Zimbra::Mon::serviceInfo)


status Running


status Running


status Running


status Running


status Running


status Stopped

Aside from SNMP (and my not being able to add a domain from the admin login - I haven't tried to add a domain manually yet via the zmprov script yet) everything seems to be working so far.

I tried the suggested fix for SNMP (above in this thread) with no luck. zmswatchctl status returns "swatch: no process killed" and while zmswatchctl start returns nothing (no errors, nothing).
Can anyone let me know if I need to worry about the java errors I received and if so how to deal with them or possibly point me to any further places to look to find error messages?
Thank you,

SNMP not loading, can't connect to Admin

Posted: Thu Oct 13, 2005 11:01 am
by 14319KevinH
You can ignore the keytool errors...
Might want to look at this thread:

that doesn't help try re-running zmsnmpinit to recreate the config file.

SNMP not loading, can't connect to Admin

Posted: Fri Oct 14, 2005 2:38 am
by Umeboshi
Thank you very much. Changing the ownership on the /var/log/zimbra.log file solved the problem. I didn't work through the rest of the procedure as I was already getting 3 and 12 month statistics displays but not 24 hour for some reason. I suspect that may clear up now that SNMP is running. We'll see.
On to the next step. How to access the companies Exchange based GAL from Zimbra. Initial attemps have not been successful but I'm hopeful.
Thanks again for the help.