no luck on Centos 4.1 [H E L P ]

Ask questions about your setup or get help installing ZCS server (ZD section below).
antonio.meireles
Posts: 25
Joined: Fri Sep 12, 2014 9:56 pm

no luck on Centos 4.1 [H E L P ]

Postby antonio.meireles » Mon Oct 03, 2005 12:08 pm

Hi,
i' m trying to install Zimbra on Centos 4.1 (RHEL 4 clone) and install fails...
from the install log i can see that the drama start's with the ldap server ...
COMMAND: zmlocalconfig -e zimbra_server_hostname=zimbra.arq.up.pt

COMMAND: zmlocalconfig -e ldap_host=zimbra.arq.up.pt

COMMAND: zmlocalconfig -e ldap_port=389

COMMAND: /opt/zimbra/libexec/zmldapinit

Started slapd: pid

ldap_bind: Can't contact LDAP server (-1)

ldap_bind: Can't contact LDAP server (-1)


COMMAND: zmprov cs zimbra.arq.up.pt

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.arq.up.pt:389)

COMMAND: zmprov cd alumni.arq.up.pt

... which doesn' t start. after some research and following the instructions from here...
> su - zimbra

bash -x bin/ldap start
i get ...

(...) 

+ '[' -x /opt/zimbra/sleepycat/bin/db_recover ']'

+ /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data -v

db_recover: Finding last valid log LSN: file: 1 offset 28

+ /opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf

+ sleep 2

(...)

going after the slapd binary i found that it simply dies. With debug enabled i get...
[QUOTE] [zimbra@zimbra ~]$ /opt/zimbra/openldap/libexec/slapd -d 10 -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf

@(#) $OpenLDAP: slapd 2.2.26 (Aug 17 2005 00:15:16) $

marcmac@depot.liquidsys.com:/space/home/marcmac/p4/main/ThirdParty/openldap/openldap-2.2.26/servers/slapd

/opt/zimbra/openldap/etc/openldap/schema/zimbra.schema: line 1229: bad config line (ignored)

bdb_db_init: Initializing BDB database

bdb(): unable to initialize mutex: Function not implemented

bdb(): /opt/zimbra/openldap-data/__db.001: unable to initialize environment lock: Function not implemented

bdb_db_open: dbenv_open failed: Function not implemented (38)

backend_startup: bi_db_open failed! (38)

bdb(): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem

bdb(): txn_checkpoint interface requires an environment configured for the transaction subsystem

bdb_db_destroy: txn_checkpoint failed: Invalid argument (22)

slapd stopped.


connections_destroy: nothing to destroy.

[/QUOTE]


Any tips ?
thanxs in advance and best regards.


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

no luck on Centos 4.1 [H E L P ]

Postby 14319KevinH » Mon Oct 03, 2005 12:36 pm

What does ldd /opt/zimbra/openldap/libexec/slapd produce? Maybe there is a lib problem with the bdb libs. Also can you verify the permissions on /opt/zimbra and /opt/zimbra/openldap-data are correctly set to the zimbra user?
antonio.meireles
Posts: 25
Joined: Fri Sep 12, 2014 9:56 pm

no luck on Centos 4.1 [H E L P ]

Postby antonio.meireles » Mon Oct 03, 2005 12:53 pm

[zimbra@zimbra ~]$ ldd /opt/zimbra/openldap/libexec/slapd

linux-gate.so.1 => (0xf57fd000)

libdb-4.2.so => /opt/zimbra/lib/libdb-4.2.so (0xb7ec8000)

libsasl2.so.2 => /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2 (0xb7eb0000)

libssl.so.4 => /lib/libssl.so.4 (0xb7e7c000)

libcrypto.so.4 => /lib/libcrypto.so.4 (0xb7d93000)

libresolv.so.2 => /lib/libresolv.so.2 (0xb7d80000)

libpthread.so.0 => /lib/i686/libpthread.so.0 (0xb7d2e000)

libc.so.6 => /lib/i686/libc.so.6 (0xb7c05000)

libdl.so.2 => /lib/libdl.so.2 (0xb7c01000)

libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xb7bed000)

libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xb7b88000)

libcom_err.so.2 => /lib/libcom_err.so.2 (0xb7b85000)

libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xb7b64000)

libz.so.1 => /usr/lib/libz.so.1 (0xb7b53000)

/lib/ld-linux.so.2 (0xb7f74000)



[zimbra@zimbra ~]$ ls -al /opt/ | grep zimbra

drwxr-xr-x 23 zimbra zimbra 4096 Oct 3 13:05 zimbra

[zimbra@zimbra ~]$ ls -al /opt/zimbra/| grep data

drwxr-xr-x 2 zimbra zimbra 4096 Oct 3 13:06 openldap-data



both appear to be ok. Regards
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

no luck on Centos 4.1 [H E L P ]

Postby 14319KevinH » Mon Oct 03, 2005 1:13 pm

Yes that looks good. Not sure what else to try. We've never testing on CentOS ourselves although others on the forum here have reported success with it.
dkarp
Elite member
Elite member
Posts: 1410
Joined: Fri Sep 12, 2014 9:52 pm

no luck on Centos 4.1 [H E L P ]

Postby dkarp » Mon Oct 03, 2005 1:52 pm

antonio.meireles
Posts: 25
Joined: Fri Sep 12, 2014 9:56 pm

no luck on Centos 4.1 [H E L P ]

Postby antonio.meireles » Mon Oct 03, 2005 2:44 pm

[quote user="dkarp"]Does this solution work for you? http://zimbra.com/forums/showpost.php?p=845&postcount=5[/QUOTE>

Could you elaborate ?
simply putting ...

moduleload     back_bdb

# .la

backend bdb

checkpoint 512 30



on the slapdf.conf didn ´ t change anything :(
Regards.
dkarp
Elite member
Elite member
Posts: 1410
Joined: Fri Sep 12, 2014 9:52 pm

no luck on Centos 4.1 [H E L P ]

Postby dkarp » Mon Oct 03, 2005 3:27 pm

http://zimbra.com/forums/showthread.php?t=186
I think the original post also says:

[QUOTE]where it says Modulepath /usr/local/libexec whatever-

change it to:

modulepath /usr/lib/ldap

moduleload back_bdb

(note, i removed the .la that was originally there).
This is of course assuming you already have the debian openldap prereq's, which will put back_bdb.so in /usr/lib/ldap.[/QUOTE]

Not sure if this is applicable, but it did solve their OpenLDAP startup issue.
antonio.meireles
Posts: 25
Joined: Fri Sep 12, 2014 9:56 pm

no luck on Centos 4.1 [H E L P ]

Postby antonio.meireles » Mon Oct 03, 2005 6:33 pm

[quote user="dkarp"]http://zimbra.com/forums/showthread.php?t=186
I think the original post also says:
Not sure if this is applicable, but it did solve their OpenLDAP startup issue.[/QUOTE]
yes... but that was in the context of using a DISTRO supplied openldap rpm, which isn 't the idea here (i 'm running a pristine CentOS install which is supposed to be equivalent to RHEL 4... ) , or it is ?
meanwhile here it goes the list of locally installed rpms...



filesystem-2.3.0-1

hwdata-0.146.10.EL-1

termcap-5.4-3

glibc-common-2.3.4-2.9

libselinux-1.19.1-7

e2fsprogs-1.35-12.1.EL4

chkconfig-1.3.13.2-1

bash-3.0-19.2

info-4.7-5

sed-4.1.2-4

gawk-3.1.3-10.1

readline-4.3-13

gzip-1.3.3-15.rhel4

net-tools-1.60-37.EL4.6

centos-release-4-1.2

libacl-2.2.23-5

iputils-20020927-16

db4-4.2.52-7.1

hotplug-2004_04_01-7.5

ethtool-1.8-4

grep-2.5.1-31

device-mapper-1.01.01-1.RHEL4

coreutils-5.2.1-31.1

krb5-libs-1.3.4-17

cracklib-2.7-29

pam-0.77-66.5

SysVinit-2.85-34

openssl-0.9.7a-43.2

lvm2-2.01.08-1.0.RHEL4

mkinitrd-4.2.1.3-1

elfutils-libelf-0.97-5

rpm-libs-4.3.3-9_nonptl

binutils-2.15.92.0.2-13

gmp-4.1.4-3

gdbm-1.8.0-24

rpm-python-4.3.3-9_nonptl

libxml2-python-2.6.16-6

nmap-3.70-1

openssh-3.9p1-8.RHEL4.4

openssh-server-3.9p1-8.RHEL4.4

dhclient-3.0.1-12_EL.centos4

diffutils-2.8.1-12

man-1.5o1-9

openldap-2.2.13-2

passwd-0.68-10

freetype-2.1.9-1

libjpeg-6b-33

fontconfig-2.2.3-7

libpng-1.2.7-1

perl-5.8.5-12.1

xorg-x11-xfs-6.8.2-1.EL.13.16

fonts-xorg-75dpi-6.8.1.1-1.EL.1

libungif-4.1.3-1

perl-Filter-1.30-6

emacs-21.3-19.EL.1

exim-4.43-1.RHEL4.5

fetchmail-6.2.5-6.el4.2

kernel-2.6.9-11.EL

crontabs-1.10-7

file-4.10-2

make-3.80-5

zimbra-core-3.0.M1_21.RHEL4-20050920162541_

zimbra-mta-3.0.M1_21.RHEL4-20050920162541_

wget-1.10.1-2.4E.1

setup-2.5.37-1.1

libgcc-3.4.3-22.1

basesystem-8.0-4

tzdata-2005f-1.EL4

glibc-2.3.4-2.9

mktemp-1.5-20

zlib-1.2.1.2-1.2

libtermcap-2.0.8-39

ncurses-5.4-13

findutils-4.1.20-7

tar-1.14-4

cpio-2.5-8.RHEL4

less-382-4

psmisc-21.4-4

iproute-2.6.9-3

libattr-2.4.16-3

libsepol-1.1.1-2

libstdc++-3.4.3-22.1

usbutils-0.11-6.1

glib2-2.4.7-1

pcre-4.5-3.2.RHEL4

popt-1.9.1-9_nonptl

mingetty-1.07-3

module-init-tools-3.1-0.pre5.3

shadow-utils-4.0.3-41.1

cracklib-dicts-2.7-29

util-linux-2.12a-16.EL4.6

MAKEDEV-3.15-2

procps-3.2.3-8.1

sysklogd-1.4.1-26_EL

udev-039-10.8.EL4

initscripts-7.93.13.EL-2.centos4

bzip2-libs-1.0.2-13.EL4.2

beecrypt-3.1.0-6

rpm-4.3.3-9_nonptl

elfutils-0.97-5

centos-yumconf-4-4.2

python-2.3.4-14.1

libxml2-2.6.16-6

yum-2.2.1-1.centos4

nano-1.2.4-1

tcp_wrappers-7.6-37.2

openssh-clients-3.9p1-8.RHEL4.4

bzip2-1.0.2-13.EL4.2

groff-1.18.1.1-3

cyrus-sasl-2.1.19-5.EL4

libuser-0.52.5-1

cyrus-sasl-md5-2.1.19-5.EL4

expat-1.95.7-4

libtiff-3.6.1-8

ttmkfdir-3.0.9-14

xorg-x11-libs-6.8.2-1.EL.13.16

xorg-x11-font-utils-6.8.2-1.EL.13.16

chkfontpath-1.10.0-2

emacs-common-21.3-19.EL.1

Xaw3d-1.5-24

xorg-x11-Mesa-libGL-6.8.2-1.EL.13.16

hesiod-3.0.2-30

libidn-0.5.6-1

curl-7.12.1-5.rhel4

iptables-1.2.11-3.1.RHEL4

vixie-cron-4.1-20_EL

patch-2.5.4-20

rpm-build-4.3.3-9_nonptl

which-2.16-4

zimbra-ldap-3.0.M1_21.RHEL4-20050920162541_

zimbra-store-3.0.M1_21.RHEL4-20050920162541_

reproduce the problem is easy if using xen. download the centos4.1 from http://jailtime.org/[/url] and then

yum install libidn curl fetchmail iptables crontabs vixie-cron

after this define network settings and attempt to install zimbra...


ALL the Best. Thanxs in advance,
antonio.meireles
Posts: 25
Joined: Fri Sep 12, 2014 9:56 pm

no luck on Centos 4.1 [H E L P ]

Postby antonio.meireles » Tue Oct 04, 2005 8:31 am

anyone from zimbra with 'any' idea about what could be causing this erroneous behaviour ?
TIA
PS. BTW those who got to run zimba on RHEL 4 or centos4 could plz post the list of installed rpms on they 're systems ?
antonio.meireles
Posts: 25
Joined: Fri Sep 12, 2014 9:56 pm

no luck on Centos 4.1 [H E L P ]

Postby antonio.meireles » Tue Oct 04, 2005 9:33 am

the bundled openldap won 't run without NPTL enabled. reenabling it solved the problem. sorry the noise.
Regards.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 17 guests