Local Delivery LMTP Problem

Ask questions about your setup or get help installing ZCS server (ZD section below).
CaptainFiesta
Posts: 20
Joined: Fri Sep 12, 2014 9:56 pm

Local Delivery LMTP Problem

Postby CaptainFiesta » Mon Oct 03, 2005 8:34 pm

I've added more RAM to accomodate mysql, got the hosts file correct and successfully setup Zimbra. I can login to the admin interface and the web client.
There's only one problem remaining that I'm stuck on. When I try to send email to internal users, Postfix fails on trying to deliver the mail with lmtp. Here's what the zimbra.log tells me.
Oct 3 19:47:31 mackenreusch postfix/lmtp[13927]: 0D0981772AF: to=, relay=none, delay=84404, status=deferred (connect to mackenreusch.reusch.net[209.149.57.168]: Connection refused)
I *think* I understand what's happening, but I'm not sure how to fix it. The server lives behind a NAT router. The external IP is the 209.149.57.168 address and is what the hostname mackenreusch.reusch.net resolves to in DNS. It looks like postfix is doing a DNS lookup and trying to delivery to the public IP address instead of the server's internal IP, 192.168.2.52.
I could setup an internal DNS server that would tell postfix mackenreusch.reusch.net resolves to 192.168.5.2, but I'd rather avoid having to setup bind if possible.
From digging into the zimbra postfix setup, it looks like postfix gets the transport map from LDAP. Could I change the transport map to tell it to deliver mail to mackenreusch.reusch.net to the localhost LMTP server?
I suspect I won't be the last person to run into this problem given how popular NAT is and hope the solution will be useful to others!
I've been waiting for a viable open alternative to MS Exchange for a while, and Zimbra is by far the best I've seen. Way to go!


17629anand
Zimbra Alumni
Zimbra Alumni
Posts: 273
Joined: Fri Sep 12, 2014 9:53 pm

Local Delivery LMTP Problem

Postby 17629anand » Mon Oct 03, 2005 8:36 pm

You should disable DNS lookups that postfix is doing by going to admin UI MTA tab.
17629anand
Zimbra Alumni
Zimbra Alumni
Posts: 273
Joined: Fri Sep 12, 2014 9:53 pm

Local Delivery LMTP Problem

Postby 17629anand » Mon Oct 03, 2005 8:38 pm

just a clarification: disable_dns_lookups causes postfix to not use DNS directly (ie, libresolv), but instead causes it to use the glibc routines which respect /etc/hosts, /etc/resolv.conf etc.
CaptainFiesta
Posts: 20
Joined: Fri Sep 12, 2014 9:56 pm

Local Delivery LMTP Problem

Postby CaptainFiesta » Mon Oct 03, 2005 8:49 pm

Brilliant, thanks!
I appreciate the clarification on what disable_dns_lookups actually does. I thought about turning it off, but figured postfix wouldn't be able to lookup remote domains to deliver mail to.
CaptainFiesta
Posts: 20
Joined: Fri Sep 12, 2014 9:56 pm

Local Delivery LMTP Problem

Postby CaptainFiesta » Tue Oct 04, 2005 10:07 am

This fixed my internal mail delivery problem, but then I noticed deliver of external mail wasn't quite working right (it looks like with this DNS setting, postfix looks up A records, not MX records).
I picked up the tip from this thread about setting the relay_host parameter (through the global settings, MTA tab in the UI).
I set it to my ISP's SMTP server and both internal and external delivery are now working.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests