FC3 Install Hanging on core RPM

Ask questions about your setup or get help installing ZCS server (ZD section below).
hawlej2
Posts: 2
Joined: Fri Sep 12, 2014 9:58 pm

FC3 Install Hanging on core RPM

Postby hawlej2 » Thu Oct 20, 2005 6:04 pm

Hi,

I'm installing on FC3 and during the install script when the rpms are installing, they never finish, they just hang. I tried installing the rpm's separately with the same result. Here's the output and at the very bottom is the point of hanging. Thanks in advance for any help.


[root@localhost zcs]# ./install.sh
Operations logged to /tmp/install.log.5079


PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE. ZIMBRA, INC.

("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU FIRST ACCEPT THE TERMSOF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING THE SOFTWARE, OR USING THE

PRODUCT, YOU ARE CONSENTING TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT AGREETO ALL OF THE TERMS OF THIS AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THEPRODUCT.
Open Source License Terms for the Zimbra Collaboration Suite:

http://www.zimbra.com/downloads/sourcebinary/index.php?dl=2
>

Checking for prerequisites...

libidn...FOUND libidn-0.5.6-1

curl...FOUND curl-7.12.3-3.fc3

fetchmail...FOUND fetchmail-6.2.5-7.fc3.1
Checking for installable packages
Found zimbra-core

Found zimbra-ldap

Found zimbra-mta

Found zimbra-snmp

Found zimbra-store


Checking for sendmail/postfix


Sendmail appears to be running. Shut it down? [Y]

Shutting down sendmail: [ OK ]

Shutting down sm-client: [ OK ]
Checking for mysqld


Mysql appears to be running. Shut it down? [Y]

Stopping MySQL: [ OK ]

Checking for existing installation...

zimbra-ldap...not found

zimbra-logger...not found

zimbra-mta...not found

zimbra-snmp...not found

zimbra-store...not found

zimbra-core...FOUND zimbra-core-3.0.M1_21.FC3-20050920155949_
Saving existing configuration file to /tmp/saveconfig.5079

cp: cannot stat `/opt/zimbra/tomcat/conf/keystore': No such file or directory

cp: cannot stat `/opt/zimbra/conf/smtpd.key': No such file or directory

cp: cannot stat `/opt/zimbra/conf/smtpd.crt': No such file or directory
Setting defaults from saved config in /tmp/saveconfig.5079/config.save

HOSTNAME=localhost.localdomain

LDAPHOST=localhost

LDAPPORT=389

SNMPTRAPHOST=

SMTPSOURCE=

SMTPDEST=

SNMPNOTIFY=0

SMTPNOTIFY=0

LDAPROOTPW=zimbra

LDAPZIMBRAPW=zimbra
Please enter the logical hostname for this host [localhost.localdomain]
The Zimbra Collaboration Suite appears already to be installed.

It can be upgraded with no effect on existing accounts,

or the current installation can be completely removed prior

to installation for a clean install.
Do you wish to upgrade? [Y]
Select the packages to install

Upgrading zimbra-core
Install zimbra-ldap [Y]
Install zimbra-mta [Y]
Install zimbra-snmp [Y]
Install zimbra-store [Y]
Installing:

zimbra-core

zimbra-ldap

zimbra-mta

zimbra-snmp

zimbra-store
Configuration section
Enter web server mode (http, https, mixed) [http]
System configuration section complete

Package installation ready
Save installation configuration? [Y]
Filename: [/tmp/config.5079]
Start servers after installation? [Y]
The system will be modified. Continue? [N] Y
Shutting down zimbra mail
Removing legacy packages


Removing existing packages
zimbra-core...done
Removing deployed webapp directories

Installing packages
zimbra-core......zimbra-core-3.0.M1_21.FC3-20050920155949_.i386.rpm...


(THIS NEVER PRINTS "DONE")


andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

FC3 Install Hanging on core RPM

Postby andreychek » Thu Oct 20, 2005 6:57 pm

[quote user="hawlej2"]Hi,

I'm installing on FC3 and during the install script when the rpms are installing, they never finish, they just hang. I tried installing the rpm's separately with the same result. Here's the output and at the very bottom is the point of hanging.[/QUOTE]
Hmm... that almost sounds like there could be something wrong with the RPM database.
Can you install other non-Zimbra RPM's at the moment?
You may also want to verify that your Zimbra download isn't corrupted.. perhaps you could re-download it.
If it's a RPM database problem, you could look into RPM's --rebuilddb option.
If, by chance, you had installed Zimbra before on this machine, verify that no Zimbra related processes are running.
Good luck,

-Eric
hawlej2
Posts: 2
Joined: Fri Sep 12, 2014 9:58 pm

FC3 Install Hanging on core RPM

Postby hawlej2 » Thu Oct 20, 2005 7:44 pm

Thanks for the suggestions, I tried;

Installing another rpm, that worked (fte text editor from source forge)

Re-downloading and extracting the rpms again

Rebuilding the db's of the zimbra rpms

Erasing the previous half installs of the rpms

(Not sure which processes are related to zimbra that need to be killed, yet mysql, ldap, smtp, are not running)

Same spot with hanging on the install script and never printing Done when installing the core rpm.
Any other ideas? Thanks again for the help it's much appreciated! Props to PA, I'm from there, yet live in MA (hope to be back soon to PA)!
andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

FC3 Install Hanging on core RPM

Postby andreychek » Fri Oct 21, 2005 10:17 am

[quote user="hawlej2"] Any other ideas? Thanks again for the help it's much appreciated! Props to PA, I'm from there, yet live in MA (hope to be back soon to PA)![/QUOTE]

Hey there,
That problem is most odd :-)
Even though you were able to install other RPM's, I'm still a little suspicious of the RPM database on your system. I've had some of the oddest problems with RPM databases, though mostly with RedHat 8 and 9.
I might try rebuilding your RPM database. Hopefully, this isn't a mission critical box, as I haven't done this in awhile and my steps might be out of order, misspelled, or missing a component :-)
However, I might try this:

* cd /var/lib/rpm

* mkdir old

* mv __db* old

* rpm --rebuilddb
This moves your existing RPM database into the dir 'old' (essentially making a backup), then rebuilds it. When complete, you should see the recreated __db* files in /var/lib/rpm.
Again, please do a sanity check on these instructions, especially if you use this box for something else :-) Also, you'll find RPM's --rebuilddb option in the man page, you can read about what it does there if you're curious.
After that, try installing Zimbra again.
Oh, and I hope you make it back to PA. At least for the moment, the cost of living is a bit lower here :-)
Good luck,

-Eric
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

FC3 Install Hanging on core RPM

Postby marcmac » Fri Oct 21, 2005 10:32 am

I've never seen this (and I've done a LOT of installs :)
The rpm db may indeed be bad, though if it allowed you to install a different RPM, it's _probably_ ok.
Try this:
rpm -e --noscripts --allmatches zimbra-core
If that works, install by hand:
rpm -i -vv zimbra-core-whatever.rpm
Try to see where that hangs, if it does.
If it does hang, repeat the above rpm -e, then reinstall without the scripts:

rpm -i -vv --noscripts zimbra-core-whatever.rpm
If that works, then the problem is in the pre or postinstall scripts of the rpm, and we can track that down.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests