Zimbra on FC4

Ask questions about your setup or get help installing ZCS server (ZD section below).
daly1
Posts: 18
Joined: Fri Sep 12, 2014 9:58 pm

Zimbra on FC4

Postby daly1 » Fri Oct 21, 2005 3:08 pm

I had a problem which I already fixed, concerning Copyright not being a know keyword. I fixed it by editing ZimbraBuild/Makefile and in each of the spec files (search for spec, you'll find 3 files) I did a sed -e '/Copyright/License/' with all the other sed's in there.
I now have another problem, which I can't seem to fix:

[javac] 1. ERROR in /home/aeldaly/zcs/Ajax/src/com/zimbra/ajax/imagemerge/DecodedFullColorImage.java

[javac] (at line 100)

[javac] mBufImg = reader.read(0);

[javac] ^^^^

[javac] The method read(int, ImageReadParam) in the type ImageReader is not applicable for the arguments (int)

[javac] ----------

[javac] ----------

[javac] 2. ERROR in /home/aeldaly/zcs/Ajax/src/com/zimbra/ajax/imagemerge/ImageMerge.java

[javac] (at line 440)

[javac] writer.write(buffImg);

[javac] ^^^^^

[javac] The method write(IIOMetadata, IIOImage, ImageWriteParam) in the type ImageWriter is not applicable for the arguments (BufferedImage)

[javac] ----------

[javac] ----------

[javac] 3. WARNING in /home/aeldaly/zcs/Ajax/src/com/zimbra/ajax/imagemerge/ImageMergeException.java

[javac] (at line 28)

[javac] public class ImageMergeException extends Exception {

[javac] ^^^^^^^^^^^^^^^^^^^

[javac] The serializable class ImageMergeException does not declare a static final serialVersionUID field of type long

[javac] ----------

[javac] 3 problems (2 errors, 1 warning)
BUILD FAILED

/home/aeldaly/zcs/ZimbraWebClient/build.xml:108: Compile failed; see the compiler error output for details.
Total time: 41 seconds

make: *** [/home/aeldaly/zcs/ZimbraBuild/../ZimbraWebClient/build/dist/tomcat/webapps/zimbraAdmin.war] Error 1


Does anyone know how to get around this?
Thanks,

Ahmed


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Zimbra on FC4

Postby 14319KevinH » Fri Oct 21, 2005 3:42 pm

What JDK are you using? Try 'which javac', we use SUN's 1.5_05 JDK. If you are using something different than your results may vary.
daly1
Posts: 18
Joined: Fri Sep 12, 2014 9:58 pm

Zimbra on FC4

Postby daly1 » Sun Oct 23, 2005 4:42 pm

Yes. That was the problem. FC4 comes with the IBM version. I removed java with yum, which removed ant and other java related things as well.
I then installed Sun's java, apache ant and installed them. Made a symlink in /usr/local/java, updated PATH to include where java and ant are, and all worked with no issues.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests