Installation problem

Ask questions about your setup or get help installing ZCS server (ZD section below).
sywong70
Posts: 3
Joined: Fri Sep 12, 2014 9:59 pm

Installation problem

Postby sywong70 » Thu Oct 27, 2005 12:34 am

I am using Fedora Core 3 :
# cat /etc/redhat-release

Fedora Core release 3 (Heidelberg)
When first installation, it showed a error. And when I use zmcontrol status to see the servers, there is no servers running.
I think it is the problem of resolving the host name I input. So I add the host name in the /etc/hosts and then re-install again. The followings are the output from the installation process:
./install.sh
Operations logged to /tmp/install.log.22408


PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE. ZIMBRA, INC.

("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU FIRST ACCEPT THE TERMS

OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING THE SOFTWARE, OR USING THE

PRODUCT, YOU ARE CONSENTING TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT AGREE

TO ALL OF THE TERMS OF THIS AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE

PRODUCT.
Open Source License Terms for the Zimbra Collaboration Suite:

http://www.zimbra.com/downloads/sourcebinary/index.php?dl=2
>

Checking for prerequisites...

libidn...FOUND libidn-0.5.6-1

curl...FOUND curl-7.12.1-1

fetchmail...FOUND fetchmail-6.2.5-6
Checking for installable packages
Found zimbra-core

Found zimbra-ldap

Found zimbra-mta

Found zimbra-snmp

Found zimbra-store


Checking for sendmail/postfix


Checking for mysqld
Checking for existing installation...

zimbra-ldap...FOUND zimbra-ldap-3.0.M1_21.FC3-20050920155949_

zimbra-logger...not found

zimbra-mta...FOUND zimbra-mta-3.0.M1_21.FC3-20050920155949_

zimbra-snmp...FOUND zimbra-snmp-3.0.M1_21.FC3-20050920155949_

zimbra-store...FOUND zimbra-store-3.0.M1_21.FC3-20050920155949_

zimbra-core...FOUND zimbra-core-3.0.M1_21.FC3-20050920155949_
Saving existing configuration file to /tmp/saveconfig.22408

cp: cannot stat `/opt/zimbra/tomcat/conf/keystore': No such file or directory

cp: cannot stat `/opt/zimbra/conf/smtpd.key': No such file or directory

cp: cannot stat `/opt/zimbra/conf/smtpd.crt': No such file or directory
Setting defaults from saved config in /tmp/saveconfig.22408/config.save

HOSTNAME=localhost

LDAPHOST=localhost

LDAPPORT=389

SNMPTRAPHOST=

SMTPSOURCE=

SMTPDEST=

SNMPNOTIFY=0

SMTPNOTIFY=0

LDAPROOTPW=zimbra

LDAPZIMBRAPW=zimbra
Please enter the logical hostname for this host [localhost] cg1.mydomain.com
The Zimbra Collaboration Suite appears already to be installed.

It can be upgraded with no effect on existing accounts,

or the current installation can be completely removed prior

to installation for a clean install.
Do you wish to upgrade? [Y]
Select the packages to install

Upgrading zimbra-core

Upgrading zimbra-ldap

Upgrading zimbra-mta

Upgrading zimbra-snmp

Upgrading zimbra-store
Installing:

zimbra-core

zimbra-ldap

zimbra-mta

zimbra-snmp

zimbra-store
Configuration section
Enter web server mode (http, https, mixed) [http]
System configuration section complete

Package installation ready
Save installation configuration? [Y]
Filename: [/tmp/config.22408]
Start servers after installation? [Y]
The system will be modified. Continue? [N] Y
Shutting down zimbra mail
Removing legacy packages


Removing existing packages
zimbra-ldap...done

zimbra-mta...done

zimbra-snmp...done

zimbra-store...done

zimbra-core...done
Removing deployed webapp directories

Installing packages
zimbra-core......zimbra-core-3.0.M1_21.FC3-20050920155949_.i386.rpm...done

zimbra-ldap......zimbra-ldap-3.0.M1_21.FC3-20050920155949_.i386.rpm...done

zimbra-mta......zimbra-mta-3.0.M1_21.FC3-20050920155949_.i386.rpm...done

zimbra-snmp......zimbra-snmp-3.0.M1_21.FC3-20050920155949_.i386.rpm...done

zimbra-store......zimbra-store-3.0.M1_21.FC3-20050920155949_.i386.rpm...done
Post installation configuration
Restoring existing configuration file from /tmp/saveconfig.22408/config.save...done

Setting the hostname to cg1.gtomato.com...done

Setting the LDAP host to cg1.gtomato.com...done

Starting ldap...done

Adding cg1.gtomato.com to zimbraMailHostPool in default COS...done

Initializing mta config...done

Configuring SNMP...done

Setting services on cg1.gtomato.com...done

Setting up SSL...done

cp: cannot stat `/tmp/saveconfig.22408/keystore': No such file or directory

cp: cannot stat `/tmp/saveconfig.22408/smtpd.key': No such file or directory

cp: cannot stat `/tmp/saveconfig.22408/smtpd.crt': No such file or directory

chown: cannot access `/opt/zimbra/tomcat/conf/keystore': No such file or directory

chown: cannot access `/opt/zimbra/conf/smtpd.key': No such file or directory

chown: cannot access `/opt/zimbra/conf/smtpd.crt': No such file or directory

Starting servers...Calling GetServiceInfoRequest (cg1.mydomain.com)
RESPONSE: (Zimbra::Mon::serviceInfo)

host

ip 192.168.1.24

name cg1.gtomato.com

done

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
Installation complete!
Operations logged to /tmp/install.log.22408

Stephen


andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

Installation problem

Postby andreychek » Thu Oct 27, 2005 10:00 am

[quote user="sywong70"]When first installation, it showed a error. And when I use zmcontrol status to see the servers, there is no servers running.
I think it is the problem of resolving the host name I input. So I add the host name in the /etc/hosts and then re-install again. The followings are the output from the installation process:[/QUOTE]

Yeah, that's a bugger of a problem, and you don't seem to be the only who's seeing that.
There's some info about it in this post:

It">http://www.zimbra.com/forums/showthread.php?t=399&highlight=LDAP%3A+error+code
It
suggests verifying your /etc/hosts entry (can you post that here if you don't get things working?), as well as doing a reinstall, ensuring that no Zimbra related processes, especially LDAP/slapd, are running when the reinstall is performed.

-Eric
sywong70
Posts: 3
Joined: Fri Sep 12, 2014 9:59 pm

Installation problem

Postby sywong70 » Thu Nov 03, 2005 6:59 am

I uninstall it and also install it again, but still unsuccessful. Please find attached the install.log file:
What is my problem?
Stephen

install.log.16490.txt

marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Installation problem

Postby marcmac » Thu Nov 03, 2005 9:33 am

SHut everything down, the do ps auxww | grep zimbra, and kill all of the remaining processes (especially slapd).
Then reinstall
sywong70
Posts: 3
Joined: Fri Sep 12, 2014 9:59 pm

Installation problem

Postby sywong70 » Mon Nov 07, 2005 9:24 pm

Thank you.
After I uninstalled all the stuffs, I actually found the following process is still running :
$ ps -ef | grep zimbra

505 2391 1 0 Oct27 ? 00:00:00 /opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf


but the /opt/zimbra directory is already empty!
Then I installed again after I killed the process. This time the server was successfully installed, and all the services were up except mailbox. And when I try to login through
perl /opt/zimbra/bin/zmmon &
RESPONSE: (Zimbra::Mon::serviceInfo)

antispam

status Running

antivirus

status Running

ldap

status Running

mailbox

status Stopped

mta

status Running

snmp

status Running

host

ip 192.168.1.24

name cg1.mydomain.com



and">https://cg1.mydomain.com:7071/zimbraAdmin
and
there was no page showing up. And when I use netstat -na and found no port listening for 7071. Is this because the mailbox service was not up?


What is my problem this time ? The install log is attached.
Stephen

install.log.14136.txt

14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Installation problem

Postby 14319KevinH » Mon Nov 07, 2005 10:01 pm

Are you saying "Y" to the upgrade question? Looks like you did from your first post. You need to say "N" for that question or it will try to upgrade the system.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests