HTTPS Is Working, HTTP Not Working

Ask questions about your setup or get help installing ZCS server (ZD section below).
uh-nu-bu
Posts: 10
Joined: Fri Sep 12, 2014 10:00 pm

HTTPS Is Working, HTTP Not Working

Postby uh-nu-bu » Tue Nov 08, 2005 7:10 am

On my 6'th install I got everything working (I think) via https, but http access gets me "The connection was refused when attempting to contact zimbra.sample.com".
I can do administrative stuff via https://zimbra.sample.com/zimbraAdmin, I can access email via https://zimbra.sample.com/zimbra/mail, but I cannot access
The">http://zimbra.sample.com/
The
install was mixed https and http. It was a clean Fedora Core 3, minimal install, no firewall. Any ideas? Let me know what logs or etc. to post....


agnOstos
Advanced member
Advanced member
Posts: 96
Joined: Fri Sep 12, 2014 9:57 pm

HTTPS Is Working, HTTP Not Working

Postby agnOstos » Tue Nov 08, 2005 7:25 am

Mixed access means you login to https for secure logins. The rest of it is then sent via http. You won't be able to login via http with a mixed setting.
uh-nu-bu
Posts: 10
Joined: Fri Sep 12, 2014 10:00 pm

HTTPS Is Working, HTTP Not Working

Postby uh-nu-bu » Tue Nov 08, 2005 7:40 am

That's weird. The docs support you (Quick Start):
"Mixed mode uses HTTPS for logging in and HTTP for normal session

traffic. All modes use SSL encryption for back-end administrative traffic."
However, I notice HUGE cpu leaps on my desktop pc everytime I send/receive info from the zimbra server. Also, it is pretty slow despite being on a dual cpu server with loads of ram and only 3 people using zimbra--and no other apps hosted on it. I was just assuming it was slow due to the encryption.
Any other explanation?
13445raj
Outstanding Member
Outstanding Member
Posts: 743
Joined: Fri Sep 12, 2014 9:59 pm
Location: Canada
Contact:

HTTPS Is Working, HTTP Not Working

Postby 13445raj » Tue Nov 08, 2005 8:58 am

Hi..No HTTPS dont take that much RAM and CPU, i have run 100's of HTTPS sites on shared server with no issue like that.
my guess is server is slow due to WATCHDOG script zimbra is running in monitoring in this version

This will take LOT OF CPU and RAM and java us very bad in taking all available memory if some special settings are not done to stop it.
We expect Zimbra team to fix this in next version
1) Remove Monitoring or watchdog scripts they run every 30 seconds or at least it should be OPTIONAL so we can turn them off to see Real Usage of server
2) Give some special Setting so we can FIX how much RAM JAVA should take on server. as of right now no matter what server i run ZIMBRA on it take 90% CPU and 98% RAM
3) ability to Restart services form ADMIN interface..right now if we make any change in Global settings you need to log to server to restart services.
hope this answer some of your Q's..

Raj S Vrach
uh-nu-bu
Posts: 10
Joined: Fri Sep 12, 2014 10:00 pm

HTTPS Is Working, HTTP Not Working

Postby uh-nu-bu » Tue Nov 08, 2005 9:40 am

Thanks for your reply, Raj. Here's a breakdown of what I have observed:
client pc: P-IV 3.2Ghz, 2GB ram, when I click on inbox in Firefox or IE my cpu rises from 0-3% utilization up to 85-90% utilization. Ram stays around 40% due to windows and programs I have open. This also happens when I click on any other folder, when I open a message, or pretty much anything that interacts with the server. This PC is showing a huge load due to Zimbra, all cpu.
server: 2 P-III 1.1Ghz, 512Mb ram, Fedora Core 3, minimal install, desktop, no firewall, running only Zimbra as a service. I'm using the default multi-cpu kernel. I have even turned off extra services like gpm and apmd to streamline it a bit. First of all, I am using swap--about 100Mb of swap. VMstat shows no active si or so however. An average load would look like this: 0.97, 0.57, 0.57. CPU is being used at anywhere from 0-40% (Idles at anywhere from 100-58). The server is not showing any kind of load, imho.
I am not sure the server-side watch scripts are the source of the speed issues.... It seems more likely due to the client javascript or some kind of client-side something or other.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

HTTPS Is Working, HTTP Not Working

Postby 14319KevinH » Tue Nov 08, 2005 10:09 am

>>> server: 2 P-III 1.1Ghz, 512Mb ram
This is on the low end of our test server reccomendation. So you can expect it to be a little slow. The next release will help but in general this isn't a production class server even for a very small number of servers.
13445raj
Outstanding Member
Outstanding Member
Posts: 743
Joined: Fri Sep 12, 2014 9:59 pm
Location: Canada
Contact:

HTTPS Is Working, HTTP Not Working

Postby 13445raj » Tue Nov 08, 2005 10:54 am

Hi Kevin:

its really surprising that DUAL 1.1 Ghz is a LOW END somehow. Are you talking about RAM or CPU..

i understand 512 RAM is low and more ram their is the better, but DUAL CPU 1.1 Ghz for linux OS kicks some ass for any kind of hosting where we load more than 500 Sites serving 100's of thousands of servings and same machine for POSTFIX or mails server will get/send millions of emails a day.
Can you please clarify actual HW needs for production server with Number of Email users and usage stats matrix if you have any.

To run Zimbra in web hosting environment what is required in terms of HW needs to Number of average users i.e 50-100 emails a day per user with 20% Web Users and 80% Desktop Email Client users.
Thanks

Raj S Vrach
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

HTTPS Is Working, HTTP Not Working

Postby 14319KevinH » Tue Nov 08, 2005 11:16 am

[quote user="13445raj"]Hi Kevin:

its really surprising that DUAL 1.1 Ghz is a LOW END somehow. Are you talking about RAM or CPU..

i understand 512 RAM is low and more ram their is the better, but DUAL CPU 1.1 Ghz for linux OS kicks some ass for any kind of hosting where we load more than 500 Sites serving 100's of thousands of servings and same machine for POSTFIX or mails server will get/send millions of emails a day.
Can you please clarify actual HW needs for production server with Number of Email users and usage stats matrix if you have any.

To run Zimbra in web hosting environment what is required in terms of HW needs to Number of average users i.e 50-100 emails a day per user with 20% Web Users and 80% Desktop Email Client users.
Thanks

Raj S Vrach[/QUOTE]
The RAM. With 512 we need to limit the number of MySQL threads and caching. Also hurts Java's perf to not have enough RAM. I've talked about a decent prod config here:

In">http://www.zimbra.com/forums/showthread.php?t=368
In
general we are seeing 1500 users per CPU for a normal/heavy profile and more if it's light usage. We don't have an official matrix yet since we are still in beta and not done with all our performance work.
13445raj
Outstanding Member
Outstanding Member
Posts: 743
Joined: Fri Sep 12, 2014 9:59 pm
Location: Canada
Contact:

HTTPS Is Working, HTTP Not Working

Postby 13445raj » Tue Nov 08, 2005 11:31 am

hi..i guessed it has to be RAM in this case..and yes performance is very subjective based on usage and lots of other pramas.
Waiting for Zimbra to get out of beta so we all can do some stress testes..

i have tested on a really low end 700Mhz, 512 MB ram dell server by sending 20,000 + emails it worked at 100% CPU for some 40 min but again that is Postfix..its really good MTA.

Web interface could easily list my mails and stuff..i like to keep thousands of emails :) so that was my first test to load up 20000 email and see search and stuff
I have some Q's

1) Do you have any information on INDEX and MySQL space usage based on Messages + size

i.e: 10,000 message of 10 Kb will take how much INDEX resources disk space and Mysql size.

I see Zimbra Folder has huge disk usage. i have not gone down on each folder and done USAGE tests.
2) Will "Open Source" version be easily scalable as distributed install..i think if Zimbra folks can point out some pointers to try this then few of us will give input.
Thanks for following up..i think key to any open source project is to keep up the community support...specially from the development company/source :)
Raj S Vrach
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

HTTPS Is Working, HTTP Not Working

Postby 14319KevinH » Tue Nov 08, 2005 11:58 am

[quote user="13445raj"]1) Do you have any information on INDEX and MySQL space usage based on Messages + size i.e: 10,000 message of 10 Kb will take how much INDEX resources disk space and Mysql size. I see Zimbra Folder has huge disk usage. i have not gone down on each folder and done USAGE tests.

[/QUOTE]
Assume roughly triple. This is an over kill but makes the math easy. We do have the option to compress message files at the expense of CPU if you really want to try and save disk space.
[quote user="13445raj"]

2) Will "Open Source" version be easily scalable as distributed install..i think if Zimbra folks can point out some pointers to try this then few of us will give input./QUOTE]
Yes the open source version supports multi-node installs. Just run the installer on each host and point to your master LDAP.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests