Page 1 of 1

Email Routing

Posted: Wed Nov 09, 2005 1:58 pm
by rsharpe
I just enabled antivirus and antispam. But now have a problem routing my email. My MTA is trying to route mail to 127.0.0.1, but my mail store is not on the localhost.
Nov 9 13:56:00 zimbra postfix/smtp[25176]: BB44050F313: to=, relay=127.0.0.1[127.0.0.1], delay=0, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
I need it to relay to 198.x.x.220 not 127.0.0.1. How do I make this change? Thank you.

Email Routing

Posted: Wed Nov 09, 2005 2:05 pm
by marcmac
It's probably trying to hand off to amavis on 127.0.0.1 - is amavisd running, on port 10024?

Email Routing

Posted: Mon Nov 14, 2005 8:19 am
by rsharpe
Okay, it took me a while but I finally got the virus scanning daemon to actually start and stay started. The log shows it's accepting the mail and attempting the scan, but it's puking at the LDAP server. According to the amavisd.conf and zimbra.log it is trying to connect to the wrong server for LDAP. I have edited the amavisd.conf file to reflect the correct settings. But when I bounce zimbra to try to apply the new settings it reverts back to the incorrect server. So.... how do I get amavisd.conf to talk to the correct server?

Email Routing

Posted: Mon Nov 14, 2005 8:31 am
by 7323graffiti

You">http://www.zimbra.com/forums/showthread.php?t=437&highlight=amavisd.conf.in
You
should edit amavisd.conf.in, not amavisd.conf. In fact, there is a cron job that generate amavisd.conf from amavisd.conf.in.