Error Upgrading from M1

Ask questions about your setup or get help installing ZCS server (ZD section below).
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Error Upgrading from M1

Postby marcmac » Tue Nov 15, 2005 10:37 am

If ldap doesn't start (on the ldap master) set this config key:

zmlocalconfig -e ldap_is_master=true


incarose
Posts: 9
Joined: Fri Sep 12, 2014 10:00 pm

Error Upgrading from M1

Postby incarose » Tue Nov 15, 2005 10:54 am

Checking the error log in zimbra.log I check then the db directory

and found several sql files with sql scripts.

One of those just update a "version" number to e "21" ( all magic for me :) )

We just apply the sql scipts to the mysql database and now it works.
The only problem is that the mail index gone away and I see nothing on my mail folder.
Now, my question is:

How can I make Zimbra to re-index my mailbox ?

I found my messages ( raw mail files ) but I cannot see them on the server.
About the LDAP I run it manually, it is the only way it will work.
Thanks
incarose
Posts: 9
Joined: Fri Sep 12, 2014 10:00 pm

Error Upgrading from M1

Postby incarose » Tue Nov 15, 2005 11:17 am

while running the sql scripts we found the following error:

ERROR 1005 (HY000) at line 58: Can't create table './zimbra/volume.frm' (errno: 121)
How to proceed ?

It is something related to InnoDB foreing keys
Thanks
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Error Upgrading from M1

Postby 14319KevinH » Tue Nov 15, 2005 12:09 pm

[quote user="incarose"]while running the sql scripts we found the following error:

ERROR 1005 (HY000) at line 58: Can't create table './zimbra/volume.frm' (errno: 121)
How to proceed ?

It is something related to InnoDB foreing keys
Thanks[/QUOTE]
We don't recomend you try to just hack on the DB. Bad things can happen.
DeusExLibris
Posts: 3
Joined: Fri Sep 12, 2014 10:00 pm

Error Upgrading from M1

Postby DeusExLibris » Tue Nov 15, 2005 12:40 pm

Are there instructions for maintaining data from an M1 system when installing a clean M2 system? In other words, how can I "upgrade" while doing a clean install?
17322JustinC
Posts: 34
Joined: Fri Sep 12, 2014 9:56 pm

Error Upgrading from M1

Postby 17322JustinC » Tue Nov 15, 2005 10:32 pm

I've just done an upgrade from M1 to M2 and experiencing some of the same problems mentioned in this thread. After a reboot the server wouldn't start, setting ldap to be a master fixed this. I can not see the admin page I just get a blank page. Logging in to zimbra results in INVALID_PDU.
These lines appear in zimbra.log:
2005-11-16 13:57:08,500 INFO  [http-7071-Processor48] [] StandardWrapper[/service:AdminServlet] - Servlet AdminServlet is currently unavailable

2005-11-16 13:57:10,800 INFO [http-7071-Processor50] [] StandardWrapper[/service:AdminServlet] - Servlet AdminServlet is currently unavailable

2005-11-16 13:57:39,135 INFO [http-80-Processor98] [] StandardWrapper[/service:SoapServlet] - Servlet SoapServlet is currently unavailable

2005-11-16 13:57:44,376 INFO [http-80-Processor98] [] StandardWrapper[/service:SoapServlet] - Servlet SoapServlet is currently unavailable

2

I've gone to the login page with debug enabled. Here's the debug:
http://www.w3.org/2003/05/soap-envelope">



















myaccount





mypassword








XML">http://www.mozilla.org/newlayout/xml/parsererror.xml">XML Parsing Error: mismatched tag. Expected: .

Location: http://zimbra.redfish.local/?debug=1

Line Number 1, Column 1047:Apache Tomcat/5.5.7 - Error report

HTTP Status 404 - Servlet SoapServlet is not available


type Status report

message Servlet SoapServlet is not available

description The requested resource (Servlet SoapServlet is not available) is not available.


Apache Tomcat/5.5.7


code: "INVALID_PDU",

detail: [undefined],

method: "AjxSoapDoc.createFromXml:2",

msg: "Invalid SOAP PDU"

If there's any other info you need let me know.
If a clean install is the only way to get things going, is there a way to bring across the mail from the old install?
Justin.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Error Upgrading from M1

Postby 14319KevinH » Tue Nov 15, 2005 10:35 pm


Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests