Page 2 of 2

Fedora Core 3, Clean Install - Not working!

Posted: Tue Nov 15, 2005 11:33 am
by marcmac
If you're installing on a box you've run zimbra on before, make sure you clear out the iptables forwarding, since it's no longer used:
as root run

iptables -t nat -F

Fedora Core 3, Clean Install - Not working!

Posted: Tue Nov 15, 2005 11:34 am
by pcjackson
Looks like a shared library isn't working:
/opt/zimbra/openldap-2.2.28/libexec/slapd: error while loading shared libraries: libbind.so.3: cannot open shared object file: No such file or directory
Started slapd: pid

Fedora Core 3, Clean Install - Not working!

Posted: Tue Nov 15, 2005 11:42 am
by pcjackson
I did a yum-update bind-libs and that took care of the dependency not being found. Attempting a re-install. I won't change the password this time - see if that makes a dif.

Fedora Core 3, Clean Install - Not working!

Posted: Tue Nov 15, 2005 11:51 am
by pcjackson
The above post fixed stuff! Cool. Everything seems to be working now.

Fedora Core 3, Clean Install - Not working!

Posted: Tue Nov 15, 2005 4:11 pm
by Coilcore
I have exactly the same problem on a machine that was running M1 previously...
/opt/zimbra/openldap-2.2.28/libexec/slapd: error while loading shared libraries: libbind.so.3: cannot open shared object file: No such file or directory

Fedora Core 3, Clean Install - Not working!

Posted: Tue Nov 15, 2005 4:20 pm
by marcmac
On my box (which is the FC3 build machine :) I got this:
[root@build-fc3 ~]# rpm -qf /usr/lib/libbind.so.3

bind-libs-9.2.5-3
So run yum update (or yum install bind-libs) to bring that up to date.

Fedora Core 3, Clean Install - Not working!

Posted: Sun Mar 05, 2006 12:16 pm
by 12124springnet
Getting following errors:
[zimbra@www bin]$ ./zmcontrol start

Host http://www.sportsgametime.com">http://http://www.sportsgametime.com">http://http://www.sportsgametime.com">http://http://www.sportsgametime.com

[zimbra@www bin]$ ./zmcontrol stop

Host http://www.sportsgametime.com">http://http://www.sportsgametime.com">http://http://www.sportsgametime.com">http://http://www.sportsgametime.com

Stopping antispam...Done

Stopping antivirus...Done

Stopping ldap...Done

Stopping logger...Done

Stopping mailbox...FAILED

Error: tomcat not running (pid 13357), stale pid file?

Error: assertion '-r /opt/zimbra/conf/my.cnf' failed


Stopping mta...Done

Stopping snmp...Done

Stopping spell...Done

[zimbra@www bin]$ service tomcat start

-bash: service: command not found

[zimbra@www bin]$ ./tomcat start

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)

[zimbra@www bin]$ ./zmcontrol start

Host http://www.sportsgametime.com">http://http://www.sportsgametime.com">http://http://www.sportsgametime.com">http://http://www.sportsgametime.com

[zimbra@www bin]$

Fedora Core 3, Clean Install - Not working!

Posted: Sun Mar 05, 2006 8:38 pm
by 14319KevinH
Looks like you've got a few problems, LDAP doesn't seem to be running. Take a look at the installation FAQ:
http://wiki.zimbra.com/index.php?title=Installation_Issues