Error in upgrade M1->M2

Ask questions about your setup or get help installing ZCS server (ZD section below).
DeusExLibris
Posts: 3
Joined: Fri Sep 12, 2014 10:00 pm

Error in upgrade M1->M2

Postby DeusExLibris » Tue Nov 15, 2005 12:48 pm

Not sure where else to post this. When upgrading from M1 to M2, I got an error during package checking because there were multiple versions of a required package installed on my system. For example, rpm -q -a | grep fetchmail returned:
[root@mail zcs]# rpm -q -a | grep fetchmail

fetchmail-6.2.5-6

fetchmail-6.2.5-7.fc3.1
This resulted in the following message from ./install.sh:
Checking for prerequisites...

NPTL...FOUND

libidn...FOUND libidn-0.5.6-1

curl...FOUND curl-7.12.3-4.fc3

fetchmail..../util/utilfunc.sh: line 262: [: too many arguments

MISSING

gmp...FOUND gmp-4.1.4-3

/usr/lib/libstdc++.so.5...FOUND
When I removed fetchmail-6.2.5-6, the package check ran fine.
No need to respond as I have found the problem and resolved it, but wanted others who may run into this problem to have this info.


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Error in upgrade M1->M2

Postby marcmac » Tue Nov 15, 2005 12:54 pm

Looks like I forgot to quote something - thanks for the report.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 12 guests