SMTP send relay problem

Ask questions about your setup or get help installing ZCS server (ZD section below).
jgao
Advanced member
Advanced member
Posts: 74
Joined: Fri Sep 12, 2014 10:02 pm

SMTP send relay problem

Postby jgao » Thu Dec 22, 2005 12:21 pm

[quote user="marcmac"]Restart saslauthd, but make sure you've got it enabled, too, in the admin UI.[/QUOTE]
Could you be specific about the setting of admin UI? Do you mean "Relay MTA for external delivery:"?
Thanks.


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

SMTP send relay problem

Postby marcmac » Thu Dec 22, 2005 12:25 pm

No, I mean enable smtp authentication.
jgao
Advanced member
Advanced member
Posts: 74
Joined: Fri Sep 12, 2014 10:02 pm

SMTP send relay problem

Postby jgao » Tue Dec 27, 2005 5:38 pm

my test results are pretty weird:
If the zimbra server and email clients are on the same network(s)(such as networks in the same ISP), the outlook works fine on sending outbound emails.
But if the email clients and zimbra server are on the different networks(like one network in my home, and another network in the work place), outlook still can't send outbound email, and I got the error message "Relay access denied".
Any thought?
Thanks.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

SMTP send relay problem

Postby marcmac » Tue Dec 27, 2005 5:46 pm

TUrn on smtp authentication (search the forums, this has been covered extensively.)
jgao
Advanced member
Advanced member
Posts: 74
Joined: Fri Sep 12, 2014 10:02 pm

SMTP send relay problem

Postby jgao » Wed Dec 28, 2005 10:43 am

If turn https on, outlook will enter an endless user/password loop, as Billy addressed in this tread.
???
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

SMTP send relay problem

Postby marcmac » Wed Dec 28, 2005 10:48 am

This has been covered, too.
Your smtp auth setup is misconfigured. THere's a thread about fixing a bug in saslauthd.conf.in (search on that) that should get you going.
jgao
Advanced member
Advanced member
Posts: 74
Joined: Fri Sep 12, 2014 10:02 pm

SMTP send relay problem

Postby jgao » Wed Dec 28, 2005 11:23 am

Thanks for the quick response, but problems still there.
My saslauthd.conf.in is the same as saslauthd.conf now. Any of both says:
zimbra_url: https://qa.cirrata.net/service/soap/

zimbra_cert_file: /opt/zimbra/conf/smtpd.crt

zimbra_cert_check: off
MTA settings are: Authentication Enabled, and TLS authentication only, for Global level and Server level.
In one test of outlook, I turned the SSL on for SMTP. Then I got the user/password loop. Can't go further.
In the another test of outlook, I turned the SSL off for SMTP. Then I don't get the loop. It works (sending outbound email) on the networks of the same ISP, but does not work on the networks of different ISPs.
In the third test of outlook, I turned the SSL off for SMTP. In the zimbra, I changed the https to http for saslauth files. It works (sending outbound email) on the networks of the same ISP, but does not work on the networks of different ISPs.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

SMTP send relay problem

Postby marcmac » Wed Dec 28, 2005 11:40 am

smtp auth doesn't apply when you're sending from a local network, so you can stop testing that.
What mode is your we server running in? Do you access via http, or https? Make sure saslauthd.conf.in reflects that.
After you enabled smtp auth, with TLS auth, did you restart postfix?
is the host qa.cirrata.net hosting your web server, or just the MTA? If it's not hosting the web server, change the file to reflect the URL of the webmail host.
Are you receiving a certificate from the smtpd server when you connect, with TLS turned on?
How is your client configured to send? You want user/pass auth enabled, with TLS (not SSL) turned on.
jgao
Advanced member
Advanced member
Posts: 74
Joined: Fri Sep 12, 2014 10:02 pm

SMTP send relay problem

Postby jgao » Wed Dec 28, 2005 1:31 pm

I disabled TLS authentication, used plain SMTP authentication, and changed saslauth files to http, Outlook worked pretty well on sending outbound message.
If I want to turn the secure layer on, what I need to do to

1.MTA settings,

2. saslauth files,

3. Outlook settings
Thanks.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests