Another installation ldap problem

Ask questions about your setup or get help installing ZCS server (ZD section below).
5633genesis
Posts: 7
Joined: Fri Sep 12, 2014 10:02 pm

Another installation ldap problem

Postby 5633genesis » Thu Dec 22, 2005 6:42 am

Hello
I'm trying to install Zimbra on a fedora core 3 server and always get the same error : system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)

during the installation.

I've already checked other threads and ./install.sh -u then kill all ldap running process but installation still fails.

I've got a windows 2000 server running with active directory and "of course" DNS services.

I have tried install zimbra after creating a new "ldap service record" on my DNS (w2K)... but it always failed.
it seems to me that, for a reason i don't know, ldap resolution doesn't succeed.

Is it coming from hostname or localhost.localdomain settings ?

or from dns resolution settings ?

Thank you for your help....


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Another installation ldap problem

Postby marcmac » Thu Dec 22, 2005 8:35 am

When you're installing ldap, the hostname you set up for your server (first item in the config menu) must be resolveable via DNS.
You also have to have port 389 open in your firewall.
Try this:
after a failed installation, run /opt/zimbra/libexec/zmldapinit (as the zimbra user).
What happens?
Does ldap start? (ps auxww | grep slapd)
If it doesn't start - why not?
5633genesis
Posts: 7
Joined: Fri Sep 12, 2014 10:02 pm

Another installation ldap problem

Postby 5633genesis » Thu Dec 22, 2005 2:12 pm

Thank you for your answer.
I have created a new dns record for my zimbra server and hostname is resolveable via dns from every computer on the network but when I do a ping "zimbra hostname" from the fedora server it resolve on 127.0.0.1.
I don't have any firewall on the LAN and didn't set any firewall with fedora installation.

I'm going to try what you suggest and let you know asap the results.
phoenix
Ambassador
Ambassador
Posts: 26682
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Another installation ldap problem

Postby phoenix » Thu Dec 22, 2005 2:23 pm

Hi
Have you made sure that your DNS is setup as per these instructions That will make sure your server is set-up correctly and can be seen by zimbra.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
bobby
Zimbra Employee
Zimbra Employee
Posts: 515
Joined: Fri Sep 12, 2014 10:01 pm

Another installation ldap problem

Postby bobby » Thu Dec 22, 2005 2:25 pm

it's been mentioned here before :eek: that ping uses /etc/hosts. try running this:
$ dig a [zimbra hostname] # or

$ host [zimbra hostname]
those must return the local IP address of the machine. if you're planning to connect via localhost (i.e. 127.0.0.1), then zimbra must consider its hostname to be "localhost"
hmm.

[QUOTE]hostname is resolveable via dns from every computer on the network but when I do a ping "zimbra hostname" from the fedora server it resolve on 127.0.0.1.[/QUOTE]

what's in /etc/resolv.conf and /etc/hosts?
5633genesis
Posts: 7
Joined: Fri Sep 12, 2014 10:02 pm

Another installation ldap problem

Postby 5633genesis » Thu Dec 22, 2005 3:58 pm

here is the result of running /opt/zimbra/libexec/zmldapinit

/opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libb

ind.so.3: cannot open shared object file: No such file or directory

/opt/zimbra/openldap/sbin/slappasswd: error while loading shared libraries: libb

ind.so.3: cannot open shared object file: No such file or directory

db_recover: Finding last valid log LSN: file: 1 offset 28

/opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: libbin

d.so.3: cannot open shared object file: No such file or directory

Started slapd: pid

/opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libbi

nd.so.3: cannot open shared object file: No such file or directory

/opt/zimbra/openldap/bin/ldapmodify: error while loading shared libraries: libbi

nd.so.3: cannot open shared object file: No such file or directory

ls: /opt/zimbra/lib/conf/*ldif: Aucun fichier ou répertoire de ce type

[zimbra@zimbra ~]$ /opt/zimbra/openldap/sbin/slappasswd: error while loading sha

red libraries: libbind.so.3: cannot open shared object file: No such file or dir

ectory

-bash: /opt/zimbra/openldap/sbin/slappasswd:: Aucun fichier ou répertoire de ce type
and host [zimbra hostname] give me this : Host [zimbra hostname] not found: 3(NXDOMAIN)
and dig a [zimbra.mydomain.local]
; <<>> DiG 9.2.4 <<>> a [zimbra.mydomain.local]

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:

;[zimbra.mydomain.local]. IN A
;; AUTHORITY SECTION:

. 10800 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2005122101 1800 900 604800 86400
;; Query time: 249 msec

;; SERVER: 192.168.10.122#53(192.168.10.122)

;; WHEN: Thu Dec 22 03:49:51 2005

;; MSG SIZE rcvd: 114


Any ideas ?
5633genesis
Posts: 7
Joined: Fri Sep 12, 2014 10:02 pm

Another installation ldap problem

Postby 5633genesis » Thu Dec 22, 2005 4:15 pm

here the /etc/resolv.conf :
search mydomain.local

nameserver 192.168.10.122

~


and the /etc/hosts :

# Do not remove the following line, or various programs

# that require network functionality will fail.

127.0.0.1 localhost.localdomain localhost

192.168.10.90 zimbra.mydomain.local zimbra
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Another installation ldap problem

Postby marcmac » Thu Dec 22, 2005 4:34 pm

install libbind and re-install zimbra.
5633genesis
Posts: 7
Joined: Fri Sep 12, 2014 10:02 pm

Another installation ldap problem

Postby 5633genesis » Fri Dec 23, 2005 3:33 pm

I've totally re-install fedora core 3 including all bind services.

before installing ZCS I have checked name resolution with command host zimbra.mydomain.local and dig a zimbra.mydomain.local and both work fine.

:D
I install ZCS I've got an error message at the end of installation process when trying to start zmcontrol.
It seems that I'm close to succeed but :(
here is the installation log :

*** CONFIGURATION COMPLETE - press 'a' to apply

Select from menu, or press 'a' to apply config (? - help) a

Save configuration data to a file? [Yes] Y

Save config in file: [/opt/zimbra/config.3734]

Saving config in /opt/zimbra/config.3734...Done

The system will be modified - continue? [No] Y

Operations logged to /tmp/zmsetup.log.3734

Setting local config zimbra_server_hostname to zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname=zimbra.mydomain.local

Setting local config ldap_master_url to ldap://zimbra.mydomain.local:389

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url=ldap://zimbra.mydomain.local:389

Setting local config ldap_url to ldap://zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url=ldap://zimbra.mydomain.local

Setting local config zimbra_uid to 500

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid=500

Setting local config zimbra_gid to 500

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid=500

Setting local config zimbra_user to zimbra

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user=zimbra

Setting local config av_notify_user to admin@zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user=admin@zimbra.mydomain.local

Setting local config ssl_allow_untrusted_certs to TRUE

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs=TRUE

Setting up CA...

*** Running as zimbra user: cd /opt/zimbra; zmcreateca

Done

Setting up SSL...

*** Running as zimbra user: cd /opt/zimbra; zmcreatecert

*** Running as zimbra user: cd /opt/zimbra; zmtlsctl http

*** Running as zimbra user: cd /opt/zimbra; zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key

Done

Initializing ldap...

*** Running as zimbra user: /opt/zimbra/libexec/zmldapinit

Done

Saving CA in ldap...

*** Running as zimbra user: zmprov mcf zimbraCertAuthorityCertSelfSigned "-----BEGIN TRUSTED CERTIFICATE-----

MIICRzCCAbACAQAwDQYJKoZIhvcNAQEEBQAwbDELMAkGA1UEBhMCVVMxDDAKBgNV

BAgTA04vQTEMMAoGA1UEBxMDTi9BMSMwIQYDVQQKExpaaW1icmEgQ29sbGFib3Jh

dGlvbiBTdWl0ZTEcMBoGA1UEAxMTemltYnJhLm5ldGFjdC5sb2NhbDAeFw0wNTEy

MjMwMDU2MzBaFw0wNjEyMjMwMDU2MzBaMGwxCzAJBgNVBAYTAlVTMQwwCgYDVQQI

EwNOL0ExDDAKBgNVBAcTA04vQTEjMCEGA1UEChMaWmltYnJhIENvbGxhYm9yYXRp

b24gU3VpdGUxHDAaBgNVBAMTE3ppbWJyYS5uZXRhY3QubG9jYWwwgZ8wDQYJKoZI

hvcNAQEBBQADgY0AMIGJAoGBALLJVJfDhC380Zf5BokzOxKGmdkbRxXhs7XZUTeJ

noTUVh2kN94p6JzsJIKpBkscUkQcsiWFeubtpV3grlhC3uth1SkrG/LKeUgooxmF

AOorCM2IpUFUKwOGDuAHb5Qm/DscWB2j8K3gTohXogMysJjdZsFCScZGrz51FkQu

kyfnAgMBAAEwDQYJKoZIhvcNAQEEBQADgYEAMImPrKC6XPv1wGuUBERDEcV2Evcv

rH6W4Y9QJQXlnakPj3dztg3JkKmZ1NSqFmZk0LEs62JrszBdL1a1kLb5ZFXoifec

c2UZGddVPwNWS3qiOiWbckcDx8WxC6FzmLUm/YwHK6RyLo9/8Ys3jvyJEL5dwl+m

E6vEcG2xbSO+UXo=

-----END TRUSTED CERTIFICATE-----"

*** Running as zimbra user: zmprov mcf zimbraCertAuthorityKeySelfSigned "-----BEGIN RSA PRIVATE KEY-----

MIICXgIBAAKBgQCyyVSXw4Qt/NGX+QaJMzsShpnZG0cV4bO12VE3iZ6E1FYdpDfe

Keic7CSCqQZLHFJEHLIlhXrm7aVd4K5YQt7rYdUpKxvyynlIKKMZhQDqKwjNiKVB

VCsDhg7gB2+UJvw7HFgdo/Ct4E6IV6IDMrCY3WbBQknGRq8+dRZELpMn5wIDAQAB

AoGAHt1m/zQ/s3i77lKNcE4p2o7mLHbrFLn8Pl6gCMh3V1MY8tEQ3Ae8IqsZunzX

m0vuX9fcYWHjz84jCEvrjU0uEobGfYc+6auWW/YxBqc02CvAdJustzUBpFku4ToO

AD4m3NeQ7Ne4IvOP5cwms28TyO7L7enzjBijsUkZpwq9N4ECQQDfppUjd/RIT63f

ZYBVa3UftInk2bPGxgasum/iq1G0s9QoqGTJr3dv3RdqIqLf0T4dthK5uJHaDEgR

KSExEYWhAkEAzKV/fZtgEGTlKx/kkr74CkYuo6EhW2pMBjGVXcIr0O2w+im3evk+

gE7WKLkssb3pa6J0v0qEeU/4C/oqoRewhwJBALJJhZJkyaPrgNwZehieNRw1O8fn

lFzc9+0yIoc7s0KuKG7Q7qeo7TmLsmK1gcmScEYXIw5SiFKef8TOWNtY8IECQQC4

/VmTx6I875ehNgE/DdXWI78BNySaKCp05tlomZ9WC6cRXCh5x1jST3GT+mAGg+++

1mnGiavapYlJ+mgSmwF9AkEA0MVDiJqYPS74Z2hx4V7SGXattJw/OLikXrSUa/Mt

O8GmM/6sx3ns9fLusThdd/CrrQfxvVw+kWpxZqe5vAZmuQ==

-----END RSA PRIVATE KEY-----"

Done

Creating server entry for zimbra.mydomain.local...*** Running as zimbra user: /opt/zimbra/bin/zmprov cs zimbra.mydomain.local

Done

Setting spell check URL to http://zimbra.mydomain.local:7780/aspell.php">http://zimbra.mydomain.local:7780/aspell.php...

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms zimbra.mydomain.local zimbraSpellCheckURL http://zimbra.mydomain.local:7780/aspell.php">http://zimbra.mydomain.local:7780/aspell.php

Done

Setting service ports on zimbra.mydomain.local...

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms zimbra.mydomain.local zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995

Done

Adding zimbra.mydomain.local to zimbraMailHostPool in default COS

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.mydomain.local:389)

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.mydomain.local:389)

Done

Creating domain zimbra.mydomain.local...

*** Running as zimbra user: /opt/zimbra/bin/zmprov cd zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraDefaultDomainName zimbra.mydomain.local

Done

Creating user admin@zimbra.mydomain.local...

*** Running as zimbra user: /opt/zimbra/bin/zmprov

Done

Creating postmaster alias...

*** Running as zimbra user: /opt/zimbra/zmprov aaa admin@zimbra.mydomain.local root@zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/zmprov aaa admin@zimbra.mydomain.local postmaster@zimbra.mydomain.local

Done

Initializing store sql database...

*** Running as zimbra user: /opt/zimbra/libexec/zmmyinit

Done

Setting zimbraSmtpHostname for zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms zimbra.mydomain.local zimbraSmtpHostname zimbra.mydomain.local

Done

Initializing store sql database...

*** Running as zimbra user: /opt/zimbra/libexec/zmloggerinit

Done

*** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraLogHostname zimbra.mydomain.local

Initializing mta config...

*** Running as zimbra user: /opt/zimbra/libexec/zmmtainit

Done

Configuring SNMP...

Setting local config snmp_notify to yes

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e snmp_notify=yes

Setting local config smtp_notify to yes

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_notify=yes

Setting local config snmp_trap_host to zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e snmp_trap_host=zimbra.mydomain.local

Setting local config smtp_source to admin@zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_source=admin@zimbra.mydomain.local

Setting local config smtp_destination to admin@zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_destination=admin@zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/libexec/zmsnmpinit

Done

Configuring Spell server...

Done

Setting services on zimbra.mydomain.local

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms zimbra.mydomain.local zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled logger zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled snmp zimbraServiceInstalled ldap zimbraServiceInstalled spell

*** Running as zimbra user: /opt/zimbra/bin/zmprov ms zimbra.mydomain.local zimbraServiceEnabled antivirus zimbraServiceEnabled antispam zimbraServiceEnabled spell zimbraServiceEnabled logger zimbraServiceEnabled mailbox zimbraServiceEnabled mta zimbraServiceEnabled snmp zimbraServiceEnabled ldap zimbraServiceEnabled spell

Done

no crontab for zimbra

*** Running as zimbra user: /opt/zimbra/bin/zmcontrol start

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.mydomain.local:389)

*** Running as zimbra user: /opt/zimbra/bin/zmsshkeygen

*** Running as zimbra user: /opt/zimbra/bin/zmupdateauthkeys


Operations logged to /tmp/zmsetup.log.3734


Configuration complete - press return to exit


[root@zimbra zcs]# su - zimbra

[zimbra@zimbra ~]$ zmcontrol status

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.mydomain.local:389)

[zimbra@zimbra ~]$ zmcontrol start

Host zimbra.mydomain.local

Starting ldap...Done.

ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException zimbra.mydomain.local:389)

[zimbra@zimbra ~]$
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Another installation ldap problem

Postby marcmac » Fri Dec 23, 2005 3:38 pm

what does zmldapinit return when you run it?

does slapd start? Why not?
Firewall running?

SELinux enabled?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: Baidu [Spider] and 5 guests