Installing a second Zimbra server

Ask questions about your setup or get help installing ZCS server (ZD section below).
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Sat Dec 31, 2005 8:33 pm

I have Zimbra m2 running fine, and want to install a second server using the same LDAP, but when I don't install LDAP, I don't get the 'a' apply option with install.sh? Am I missing something?
Thanks


marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Installing a second Zimbra server

Postby marcmac » Sat Dec 31, 2005 10:11 pm

When you install a second server, you have to point the ldap host (option 1) at it, and set the password correctly (option 3). You can get the password from the first server, with:
zmlocalconfig -s zimbra_ldap_password
After that, you'll get the 'a' apply option (note that the line now says, correct ldap or select menu item.)
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Sat Dec 31, 2005 11:09 pm

Actually, I edited both the server name (option 2 - LDAP master host) and option 4 (LDAP Password), but that sets my local name to the same as my LDAP host, weird, or am i missing something?
Do you know if the LDAP server has to be a name or is an IP good enough?
Thanks
John
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Installing a second Zimbra server

Postby marcmac » Sun Jan 01, 2006 12:35 am

Did you install the ldap server on the second host? If you did, make sure it's disabled. (Ldap menu, first option)
The ldap host should be the hostname, not the IP - and if it's not on the local host, it should be different from the local host.
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Sun Jan 01, 2006 9:39 am

Still not having any luck here, sorry.
So, here's the scenario:
- First server (zimbra.compunique.com) is installed with everything and running great!

- Second server (mail2.compunique.com) is fully uninstalled (install.sh -u) and going to be installed w/o zimbra ldap.
When I get to the install menu I have :

1. hostname: localhost.localdomain

** 2. ldap master host: localhost.localdomain

3. ldap port 389

** 4. ldap password: noset
So I set the option 2 to zimbra.compunique.com, and the password accordingly.
I still don't get the 'a' apply option, unless I set the option 1 hostname to the same as the ldap server,is that correct? If it is, thats confusing!
Any help would be appreciated.
John
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Sun Jan 01, 2006 10:08 am

AH HA!!!! Now I see the problem! (note to self, turn off all firewalls and listen to forum suggestions :p )
OK, so the problem is two fold: 1. the firewall was limiting port 389 from connecting, fixed that. 2. The password was differnet than what I had initially set on server 1, which thankfully you told me how to get!
so after all that was fixed, it worked great!
BTW, I love the logging you guys do during setup, after hunting around in the scripts for a bit, I found what you were doing and saw them in the log :
/tmp/zmsetup.ldap.out
Very cool product!
Thanks for all the help
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Installing a second Zimbra server

Postby marcmac » Sun Jan 01, 2006 7:42 pm

When you ran install.sh, which options did you select BEFORE the menu? Did you tell it to install zimbra-ldap? If so, you need to disable that in the menu. (Select the ldap sub-menu, and the first option should be to disable ldap).
With ldap disabled (or not installed) you should see the ldap host as UNSET.
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Sun Jan 01, 2006 7:54 pm

I didn't install LDAP, and finally figured it out, the pasword was the big one, but the LDAP check in the install script helped me troubleshoot my issue.
Thanks again
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Mon Jan 02, 2006 1:50 pm

OK, I installed a second server, saw that the OSS version didn't have move user and decided to remove the server from LDAP after uninstalling, now I get the following: (sorry, don't know how to do those cool text boxes)
2006-01-02 12:53:23,070 INFO [http-7071-Processor50] [ip=192.168.1.195;name=john@thomaswalter.org;] SoapEngine - handler exception

com.zimbra.cs.account.AccountServiceException: no such server: 4622755f-7adf-11da-b0c1-298452e2bd36

at com.zimbra.cs.account.AccountServiceException.NO_SUCH_SERVER(AccountServiceException.java:131)

at com.zimbra.cs.service.admin.GetServer.handle(GetServer.java:86)

at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:249)

at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:163)

at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:84)

at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:226)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)

at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:148)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
phoenix
Ambassador
Ambassador
Posts: 26682
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Installing a second Zimbra server

Postby phoenix » Mon Jan 02, 2006 2:37 pm

[quote user="retireoncsco"] (sorry, don't know how to do those cool text boxes)[/QUOTE]

You can do that by highlighting a bunch of text and then click on the 'Wrap QUOTE tags....' button just above the box where you type. It's the one on the right that looks more like a speech bubble (well, it does to me :D ).
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests