Installing a second Zimbra server

Ask questions about your setup or get help installing ZCS server (ZD section below).
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Installing a second Zimbra server

Postby marcmac » Mon Jan 02, 2006 4:52 pm

The deleted server is still listed in the mail host pool in the default cos - reset this attribute via zmprov to list only the server ID of the existing server, and you'll be ok.


retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Mon Jan 02, 2006 6:12 pm

[quote user="10330phoenix"]You can do that by highlighting a bunch of text and then click on the 'Wrap QUOTE tags....' button just above the box where you type. It's the one on the right that looks more like a speech bubble (well, it does to me :D ).[/QUOTE]


Thank you for the help
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Mon Jan 02, 2006 6:13 pm

[quote user="marcmac"]The deleted server is still listed in the mail host pool in the default cos - reset this attribute via zmprov to list only the server ID of the existing server, and you'll be ok.[/QUOTE]
HMM, Easier said than done, now I just have to find those instructions :rolleyes:
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Mon Jan 02, 2006 6:26 pm

[quote user="marcmac"]The deleted server is still listed in the mail host pool in the default cos - reset this attribute via zmprov to list only the server ID of the existing server, and you'll be ok.[/QUOTE]
Ok, I give up.
I can see how to use zmprov, and do see that the details of the default COS has two server ID's listed, but how do I delete one?
I was thinking of creating a new default, moving the existing server to it and deleting the other, but that seems like more trouble.
Any help is appreciated MarcMac
John
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Installing a second Zimbra server

Postby marcmac » Mon Jan 02, 2006 7:33 pm

Sorry, used to shorthand.
So, zmprov gs will get all the info for the only server you've still got. Look for the ID.
Did I say cos? I think I meant domain

Then, zmprov md zimbraMailHostPool will reset the attrib to ONLY the ID of the existing server.
So, if your server is foo.bar.com

zmprov gs foo.bar.com | grep -i id
will return the UUID string (it's long).
zmprov md bar.com zimbraMailHostPool xxxx-yyyy-zzzz-aaaa-bbbb
will reset things.
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Tue Jan 03, 2006 11:35 am

[quote user="marcmac"]Sorry, used to shorthand.
So, zmprov gs will get all the info for the only server you've still got. Look for the ID.
Did I say cos? I think I meant domain

Then, zmprov md zimbraMailHostPool will reset the attrib to ONLY the ID of the existing server.
So, if your server is foo.bar.com

zmprov gs foo.bar.com | grep -i id
will return the UUID string (it's long).
zmprov md bar.com zimbraMailHostPool xxxx-yyyy-zzzz-aaaa-bbbb
will reset things.[/QUOTE]
I'll try this tonight when I get home.
You guys Rock, this is the type of support that will launch Zimbra to the top, when are you releasing stock :D
John
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Installing a second Zimbra server

Postby retireoncsco » Tue Jan 03, 2006 8:32 pm

[quote user="marcmac"]Sorry, used to shorthand.
So, zmprov gs will get all the info for the only server you've still got. Look for the ID.
Did I say cos? I think I meant domain

Then, zmprov md zimbraMailHostPool will reset the attrib to ONLY the ID of the existing server.
So, if your server is foo.bar.com

zmprov gs foo.bar.com | grep -i id
will return the UUID string (it's long).
zmprov md bar.com zimbraMailHostPool xxxx-yyyy-zzzz-aaaa-bbbb
will reset things.[/QUOTE]
Actually, you were on track with COS, and the remainder of the parts I figured out. I just had to have you show me how to use the modify directives on the zmprov utility.
So, I did the following and it worked like a champ

zmprov gs zimbra.compunique.com | grep -i id

that returns the ID of the only server I need in the COS pool

zmprov mc default zimbraMailHostPool id

that modified the zimbraMailHostPool to what it needed to be

zmprov gac | grep -i mailhostpool

showed that the list of servers in the default COS is correct now, where as before it had to ID's listed.
Awesome, thanks for the help again Marc! :) :)

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests