Sorry, another 'can't login to admin' -ism

Ask questions about your setup or get help installing ZCS server (ZD section below).
cpm001
Posts: 12
Joined: Fri Sep 12, 2014 10:02 pm

Sorry, another 'can't login to admin' -ism

Postby cpm001 » Wed Jan 04, 2006 6:41 am

Just installed zcs-3.0.0_M3_270.RHEL4 on a fully patched/updated centos 4.2 box.
The install went beautifully, only configuration required was admin password.
Applied password, started zimbra, all is well.
Can't log into admin console at https://blahblah:7071 get "Authentication Failed"

when logging in as admin@host.domain.tld.
However, using the same user/password pair for the "regular" account

at admin@host.domain.tld it works just fine. I thought at admin@host.domain.tld

was the same ldap info user and administrator. So, why does one work and

not the other? Perhaps that's the wrong question.
At any rate, before I reformat this whole machine and start the entire installation

process over from scratch, can someone point out what I have done wrong?
Thanks kindly in advance.


retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Sorry, another 'can't login to admin' -ism

Postby retireoncsco » Wed Jan 04, 2006 9:24 am

[quote user="cpm001"]Just installed zcs-3.0.0_M3_270.RHEL4 on a fully patched/updated centos 4.2 box.
The install went beautifully, only configuration required was admin password.
Applied password, started zimbra, all is well.
Can't log into admin console at https://blahblah:7071 get "Authentication Failed"

when logging in as admin@host.domain.tld.
However, using the same user/password pair for the "regular" account

at admin@host.domain.tld it works just fine. I thought at admin@host.domain.tld

was the same ldap info user and administrator. So, why does one work and

not the other? Perhaps that's the wrong question.
At any rate, before I reformat this whole machine and start the entire installation

process over from scratch, can someone point out what I have done wrong?
Thanks kindly in advance.[/QUOTE]
What does zimbra.log say? /opt/zimbra/log/zimbra.log
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Sorry, another 'can't login to admin' -ism

Postby marcmac » Wed Jan 04, 2006 9:48 am

When logging into the admin console, you have to use the full user name user@domain.com - are you doing that?
From the command line, zmprov ga admin@domain.com - is zimbraIsAdminAccount set to TRUE?
Try resetting the password (zmprov sp) and logging in again.
cpm001
Posts: 12
Joined: Fri Sep 12, 2014 10:02 pm

Sorry, another 'can't login to admin' -ism

Postby cpm001 » Wed Jan 04, 2006 9:55 am

[quote user="retireoncsco"]What does zimbra.log say? /opt/zimbra/log/zimbra.log[/QUOTE]
It sayeth: (in short)
2006-01-04 08:39:50,911 WARN [http-7071-Processor49] [ip=192.168.0.9;] misc - LC.get(trial_expiration_date) was null, returning empty string
cpm001
Posts: 12
Joined: Fri Sep 12, 2014 10:02 pm

Sorry, another 'can't login to admin' -ism

Postby cpm001 » Wed Jan 04, 2006 10:00 am

[quote user="marcmac"]When logging into the admin console, you have to use the full user name user@domain.com - are you doing that?
[/quote]
Yes
[quote user="marcmac"]

From the command line, zmprov ga admin@domain.com - is zimbraIsAdminAccount set to TRUE?
[/quote]
Yes
[quote user="marcmac"]

Try resetting the password (zmprov sp) and logging in again.[/QUOTE]
I have no earthly concept how one would do this.

Belive it or not, what spews forth from zmprov sp isn't the most intuitive thing

some of us have ever seen. I know that's subjective, but seriously.
Please know that as a regular user, admin@domain.com works just fine.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Sorry, another 'can't login to admin' -ism

Postby marcmac » Wed Jan 04, 2006 10:03 am

zmprov sp user password
cpm001
Posts: 12
Joined: Fri Sep 12, 2014 10:02 pm

Sorry, another 'can't login to admin' -ism

Postby cpm001 » Wed Jan 04, 2006 10:06 am

[quote user="marcmac"]zmprov sp user password[/QUOTE]
Did That Thing.
Authentication Failed
2006-01-04 08:51:27,341 WARN [http-7071-Processor44] [ip=192.168.0.9;] misc - LC.get(trial_expiration_date) was null, returning empty string
And again, logging in as a regular user, with the new pasword, worked fine.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Sorry, another 'can't login to admin' -ism

Postby marcmac » Wed Jan 04, 2006 10:12 am

try setting the trial exp date, see if that does it

zmlocalconfig -e trial_expiration_date=20060606

tomcat stop

tomcat start
That shouldn't be the problem, but we may have a bug.
cpm001
Posts: 12
Joined: Fri Sep 12, 2014 10:02 pm

Sorry, another 'can't login to admin' -ism

Postby cpm001 » Wed Jan 04, 2006 10:18 am

[quote user="marcmac"]try setting the trial exp date, see if that does it

zmlocalconfig -e trial_expiration_date=20060606

tomcat stop

tomcat start
That shouldn't be the problem, but we may have a bug.[/QUOTE]
Well, got better errors now.
Still failed, but logs are a bit more verbose about it.
2006-01-04 09:01:09,106 INFO [http-7071-Processor48] [ip=192.168.0.9;] SoapEngine - handler exception

com.zimbra.cs.account.AccountServiceException: authentication failed for admin

at com.zimbra.cs.account.AccountServiceException.AUTH_FAILED(AccountServiceException.java:76)

at com.zimbra.cs.service.admin.Auth.handle(Auth.java:80)

at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:252)

at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:163)

at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:84)

at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:230)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)

at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:152)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)

at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)

at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)

at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)

at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)

at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:526)

at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:825)

at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:738)

at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:526)

at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)

at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)

at java.lang.Thread.run(Thread.java:595)
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Sorry, another 'can't login to admin' -ism

Postby marcmac » Wed Jan 04, 2006 10:28 am

I think the error you just posted is orthogonal to the trial_exp error.
Try this (with your domain for domain.com):
zmprov ca testadmin@domain.com test123 zimbraIsAdminAccount TRUE
Then try logging in as testadmin@domain.com/test123

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests