The mailbox and mta dies in FC4 GA version

Ask questions about your setup or get help installing ZCS server (ZD section below).
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

The mailbox and mta dies in FC4 GA version

Postby marcmac » Fri Feb 10, 2006 9:52 am

[quote user="drewage"]Yes, I encountered that bug after upgrading and changed it to http
zmprov gs | grep zimbraMtaAuth

zmprov gs | grep zimbraMailMode

zmprov gs | grep zimbraMailPort

zmprov gs | grep zimbraMailSSLPort

Does that pipe to a file or something ? It provides no screen output when I run those commands..[/QUOTE]
Sorry, the html parser broke my post. That should read

zmprov gs servername | grep .... in all cases


drewage
Posts: 37
Joined: Fri Sep 12, 2014 10:04 pm

The mailbox and mta dies in FC4 GA version

Postby drewage » Fri Feb 10, 2006 10:51 am

zmprov gs myhost.com | grep zimbraMtaAuth

zimbraMtaAuthEnabled: TRUE

zimbraMtaAuthHost: myhost.com

zimbraMtaAuthURL: https://myhost.com:443/service/soap/
>

zmprov gs myhost.com | grep zimbraMailMode

zimbraMailMode: http


zmprov gs myhost.com | grep zimbraMailPort

zimbraMailPort: 80


zmprov gs myhost.com | grep zimbraMailSSLPort

zimbraMailSSLPort: 443

I did zmcontrol stop/start earlier to see if it would crank back up...would these commands give useful output when the mailbox and mta have failed ? If so I will run them if/when it happens again.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

The mailbox and mta dies in FC4 GA version

Postby marcmac » Fri Feb 10, 2006 11:00 am

[quote user="drewage"]
zmprov gs myhost.com | grep zimbraMtaAuth

zimbraMtaAuthEnabled: TRUE

zimbraMtaAuthHost: myhost.com

zimbraMtaAuthURL: https://myhost.com:443/service/soap/
>

zmprov gs myhost.com | grep zimbraMailMode

zimbraMailMode: http


zmprov gs myhost.com | grep zimbraMailPort

zimbraMailPort: 80


zmprov gs myhost.com | grep zimbraMailSSLPort

zimbraMailSSLPort: 443

I did zmcontrol stop/start earlier to see if it would crank back up...would these commands give useful output when the mailbox and mta have failed ? If so I will run them if/when it happens again.[/QUOTE]


You've hit the bug - notice that your auth URL is https://..., but your mail mode is http - the workaround is to either reset your mtaAuthHost (to the value it's currently set to) or to change your mail mode (depending on whether the mail mode is correct for your purposes).
either:

zmprov ms myhost.com zimbraMtaAuthHost myhost.com

OR

zmtlsctl https (or mixed)
drewage
Posts: 37
Joined: Fri Sep 12, 2014 10:04 pm

The mailbox and mta dies in FC4 GA version

Postby drewage » Fri Feb 10, 2006 11:27 am

and this bug causes the mailbox and mta service to fail without warning ?
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

The mailbox and mta dies in FC4 GA version

Postby marcmac » Fri Feb 10, 2006 11:30 am

[quote user="drewage"]and this bug causes the mailbox and mta service to fail without warning ?[/QUOTE]
It shouldn't kill the mailbox, but it might kill saslauthd. The reason I'm pursuing this is to limit the number of variables - whether or not it's not the cause of the mailbox failure, we should eliminate it as a suspect.
vogon1
Posts: 37
Joined: Fri Sep 12, 2014 9:58 pm

The mailbox and mta dies in FC4 GA version

Postby vogon1 » Fri Feb 10, 2006 11:46 am

I have this problem off and on as well, it started in M4_62 (still running here in vmware).

Sometimes it is running for days, then mta and mailbox stop a few times a day.
I thought it was just me.
There are tomcat stack traces when it happens, I have attached two of them.
Sietse

stacktrace.tgz

14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

The mailbox and mta dies in FC4 GA version

Postby 14319KevinH » Fri Feb 10, 2006 11:58 am

[quote user="vogon1"]I have this problem off and on as well, it started in M4_62 (still running here in vmware).

Sometimes it is running for days, then mta and mailbox stop a few times a day.
I thought it was just me.
There are tomcat stack traces when it happens, I have attached two of them.
Sietse[/QUOTE]
Not too much going on in these stack traces. One shows a single LMTP transaction but that's it. Is this *after* you've restarted from a crash or when the server is still running?
vogon1
Posts: 37
Joined: Fri Sep 12, 2014 9:58 pm

The mailbox and mta dies in FC4 GA version

Postby vogon1 » Fri Feb 10, 2006 3:11 pm

The dumps are created by the system at or just after or just before mailbox/mta go down. zmmtactl start and zmmailboxctl start get them running again.
Sietse
drewage
Posts: 37
Joined: Fri Sep 12, 2014 10:04 pm

The mailbox and mta dies in FC4 GA version

Postby drewage » Mon Feb 13, 2006 9:26 pm

Ok, I just checked and after a day of no use it appears zimbra is down...
zmcontrol status

Host myhost.com

antivirus Running

ldap Running

logger Running

mailbox Stopped

mta Stopped

snmp Running

spell Running

Let me know what you want me to check..
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

The mailbox and mta dies in FC4 GA version

Postby marcmac » Mon Feb 13, 2006 9:29 pm

su - zimbra

sh -x bin/zmmtactl status

sh -x bin/zmmailboxctl status

ps auxww | grep tomcat
If tomcat is running, kill -QUIT

send contents of /opt/zimbra/tomcat/logs/stacktrace.xxxx (most recent file)
What kind of server? OS, hardware, ram, etc. Virtual server or standard install. Zimbra version? Last 100 lines from /opt/zimbra/log/zimbra.log, /var/log/zimbra.log, /var/log/messages.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests