Web client logon fails (INVALID_PDU)

Ask questions about your setup or get help installing ZCS server (ZD section below).
jermxx
Posts: 3
Joined: Fri Sep 12, 2014 10:10 pm

Web client logon fails (INVALID_PDU)

Postby jermxx » Sun May 07, 2006 11:11 pm

I have installed Zimbra Open Source Edition on Suse10 (Release 3.1.0_GA_332.SuSE10_20060414122323 SuSE10 FOSS edition)
Initially all was working fine, I was able to log into the web client using admin etc. However, after a day or two, with no changes in configuration by me, it suddenly started throwing the following error when trying to log in:
An unknown application error has occurred. Please correct any errors and retry. If the problem persists, please contact your System Aministrator. (INVALID_PDU)
I am still able to log into zimbraAdmin, and Server Status page, plus `zmcontrol status` are all showing everything running. I can also send and receive email via Evolution IMAP. No logfiles throw errors while trying to logon. Below is my zimbra.log - I'm not sure how useful it will be. (X.X.X.X is the server, X.X.X.Y is the client).
Regards,
Jeremy
2006-05-08 13:06:34,865 INFO  [main] [] soap - Servlet SoapServlet starting up

2006-05-08 13:06:34,937 INFO [main] [] soap - Adding service AccountService to SoapServlet

2006-05-08 13:06:35,112 INFO [main] [] soap - Adding service MailService to SoapServlet

2006-05-08 13:06:35,350 INFO [main] [] soap - Adding service IMService to SoapServlet

2006-05-08 13:06:35,365 INFO [main] [] misc - version=3.1.0_GA_332.SuSE10 release=20060414122323 builddate=20060414-1223 buildhost=build-suse10

2006-05-08 13:06:35,367 INFO [main] [] misc - LANG environment is set to: C

2006-05-08 13:06:35,638 INFO [main] [] DbPool - Setting mysql connector property: maxActive=10

2006-05-08 13:06:38,278 INFO [main] [] extensions - Loading extensions from /opt/zimbra/lib/ext

2006-05-08 13:06:38,295 INFO [main] [] extensions - extension com.zimbra.clam.ClamScanner found in /opt/zimbra/lib/ext/clamscanner/clamscanner.jar

2006-05-08 13:06:38,296 INFO [main] [] extensions - Initializing extensions

2006-05-08 13:06:38,312 INFO [main] [] ClamScanner - attachment scan is disabled

2006-05-08 13:06:38,526 INFO [main] [] extensions - Initialized extension clamscanner: com.zimbra.clam.ClamScanner@com.zimbra.cs.extension.ZimbraExtensionClassLoader@89e2f1

2006-05-08 13:06:38,627 INFO [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread starting

2006-05-08 13:06:38,677 INFO [main] [] RedoLogManager - Starting pre-startup crash recovery

2006-05-08 13:06:38,826 INFO [main] [] RedoPlayer - No uncommitted transactions to redo

2006-05-08 13:06:38,996 INFO [main] [] RedoLogManager - Finished pre-startup crash recovery

2006-05-08 13:06:40,307 INFO [LmtpServer] [] TcpServer/7025 - starting accept loop

2006-05-08 13:06:40,669 INFO [Pop3Server] [] TcpServer/995 - starting accept loop

2006-05-08 13:06:40,701 INFO [ImapServer] [] TcpServer/143 - starting accept loop

2006-05-08 13:06:40,721 INFO [ImapSSLServer] [] TcpServer/993 - starting accept loop

2006-05-08 13:06:40,723 INFO [main] [] soap - Servlet AdminServlet starting up

2006-05-08 13:06:40,741 INFO [Pop3Server] [] TcpServer/110 - starting accept loop

2006-05-08 13:06:40,920 INFO [main] [] soap - Adding service AdminService to AdminServlet

2006-05-08 13:06:40,944 INFO [main] [] soap - Adding service AccountService to AdminServlet

2006-05-08 13:06:40,944 INFO [main] [] soap - Adding service MailService to AdminServlet

2006-05-08 13:06:40,944 INFO [main] [] soap - Adding service IMService to AdminServlet

2006-05-08 13:06:40,954 INFO [main] [] ContentServlet - Servlet ContentServlet starting up

2006-05-08 13:06:40,959 INFO [main] [] PublicICalServlet - Servlet PublicICalServlet starting up

2006-05-08 13:06:40,967 INFO [main] [] account - Servlet PreAuthServlet starting up

2006-05-08 13:06:41,023 INFO [main] [] mailbox - Servlet UserServlet starting up

2006-05-08 13:06:41,039 INFO [main] [] FileUploadServlet - Servlet FileUploadServlet starting up

2006-05-08 13:06:41,047 INFO [main] [] StatsImageServlet - Servlet StatsImageServlet starting up

2006-05-08 13:07:40,836 INFO [Timer-0] [] stats - 05/08/2006 13:07:40,,,,,,1,2018.00,3,15.33,,,,,,,,,,,,26.975,0,12,1,1,67,1,,0,0,0,0

2006-05-08 13:08:40,772 INFO [Timer-0] [] stats - 05/08/2006 13:08:40,,,,,,8,0.88,,,,,,,,,,,,,,28.615,0,12,1,1,67,1,,0,0,0,0

2006-05-08 13:09:16,755 WARN [http-7071-Processor49] [ip=X.X.X.Y;] misc - LC.get(trial_expiration_date) was null, returning empty string

2006-05-08 13:09:35,932 INFO [http-7071-Processor48] [mid=1;ip=X.X.X.Y;name=admin@X.X;] cache - Initializing folder and tag caches for mailbox 1

2006-05-08 13:09:36,060 INFO [IncomingDirectorySweeper] [] FileBlobStore - IncomingDirectorySweeper thread starting

2006-05-08 13:09:40,771 INFO [Timer-0] [] stats - 05/08/2006 13:09:40,,,,,,11,1.00,20,2.05,,,,,15,91.47,,,,,,55.095,0,14,4,1,85,1,,0,0,0,0

2006-05-08 13:10:08,318 ERROR [{RemoteManager: zim.X.X->zimbra@zim.X.X:22}-zmqstat corrupt] [] rmgmt - error scanning com.zimbra.cs.rmgmt.RemoteMailQueue$QueueHandler@114a306: ERROR: Unknown command: zmqstat
2006-05-08 13:10:40,770 INFO [Timer-0] [] stats - 05/08/2006 13:10:40,,,,,,9,1.11,,,,,,,11,1782.45,,,,,,80.890,0,16,6,1,96,1,,0,0,0,0

2006-05-08 13:11:40,779 INFO [Timer-0] [] stats - 05/08/2006 13:11:40,,,,,,9,1.00,1,1.00,,,,,2,222.00,,,,,,13.861,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:12:40,771 INFO [Timer-0] [] stats - 05/08/2006 13:12:40,,,,,,8,0.75,,,,,,,,,,,,,,16.042,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:13:40,773 INFO [Timer-0] [] stats - 05/08/2006 13:13:40,,,,,,8,1.00,,,,,,,,,,,,,,16.042,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:14:40,781 INFO [Timer-0] [] stats - 05/08/2006 13:14:40,,,,,,8,0.63,,,,,,,,,,,,,,16.880,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:15:40,769 INFO [Timer-0] [] stats - 05/08/2006 13:15:40,,,,,,8,0.88,,,,,,,,,,,,,,16.880,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:16:40,782 INFO [Timer-0] [] stats - 05/08/2006 13:16:40,,,,,,8,1.00,,,,,,,,,,,,,,16.880,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:17:40,779 INFO [Timer-0] [] stats - 05/08/2006 13:17:40,,,,,,8,1.00,,,,,,,,,,,,,,16.880,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:18:40,770 INFO [Timer-0] [] stats - 05/08/2006 13:18:40,,,,,,8,1.00,,,,,,,,,,,,,,17.717,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:19:40,774 INFO [Timer-0] [] stats - 05/08/2006 13:19:40,,,,,,8,0.75,,,,,,,,,,,,,,17.717,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:19:46,890 INFO [Timer-0] [] SessionCache - Removed 3 idle sessions (AdminSession: 1, SoapSession: 2). 1 active sessions remain.

2006-05-08 13:20:40,769 INFO [Timer-0] [] stats - 05/08/2006 13:20:40,,,,,,8,0.75,,,,,,,,,,,,,,18.136,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:21:40,769 INFO [Timer-0] [] stats - 05/08/2006 13:21:40,,,,,,8,0.88,,,,,,,,,,,,,,18.136,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:21:46,910 INFO [Timer-0] [] SessionCache - Removed 1 idle sessions (AdminSession: 1). 0 active sessions remain.

2006-05-08 13:22:40,771 INFO [Timer-0] [] stats - 05/08/2006 13:22:40,,,,,,8,1.00,,,,,,,,,,,,,,18.974,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:23:40,766 INFO [Timer-0] [] stats - 05/08/2006 13:23:40,,,,,,8,0.63,,,,,,,,,,,,,,18.974,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:24:40,767 INFO [Timer-0] [] stats - 05/08/2006 13:24:40,,,,,,8,1.38,,,,,,,,,,,,,,18.974,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:25:40,767 INFO [Timer-0] [] stats - 05/08/2006 13:25:40,,,,,,8,0.88,,,,,,,,,,,,,,19.811,0,16,7,1,96,1,,0,0,0,0

2006-05-08 13:26:06,257 INFO [ImapSSLServer-1] [] imap – [X.X.X.Y] connected

2006-05-08 13:26:18,764 INFO [ImapSSLServer-1] [ip=X.X.X.Y;] mailbox - Creating database mailbox4

2006-05-08 13:26:19,537 INFO [ImapSSLServer-1] [ip=X.X.X.Y;] cache - Initializing folder and tag caches for mailbox 4

2006-05-08 13:26:40,770 INFO [Timer-0] [] stats - 05/08/2006 13:26:40,,,,,,14,2.71,6,0.50,,,,,,,17,70.00,,,,23.330,0,22,11,2,96,51,,0,0,0,1

2006-05-08 13:27:40,766 INFO [Timer-0] [] stats - 05/08/2006 13:27:40,,,,,,8,0.75,,,,,,,,,,,,,,23.749,0,22,11,2,96,51,,0,0,0,1

2006-05-08 13:28:40,769 INFO [Timer-0] [] stats - 05/08/2006 13:28:40,,,,,,8,0.75,,,,,,,,,,,,,,23.749,0,22,11,2,96,51,,0,0,0,1

2006-05-08 13:28:53,047 INFO [LmtpServer-1] [] LmtpHandler – [X.X.X.X] connected

2006-05-08 13:28:53,225 INFO [LmtpServer-1] [] JMSession - SMTP Server: zim.X.X

2006-05-08 13:28:53,803 WARN [LmtpServer-1] [] misc - LC.get(debug_validate_outgoing_icalendar) was null, returning empty string

2006-05-08 13:28:53,804 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_conversation) was null, returning empty string

2006-05-08 13:28:53,805 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_filter) was null, returning empty string

2006-05-08 13:28:53,805 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_message_analysis) was null, returning empty string

2006-05-08 13:28:53,806 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_mime_part_extraction) was null, returning empty string

2006-05-08 13:28:53,806 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_indexing) was null, returning empty string

2006-05-08 13:28:53,806 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_objects) was null, returning empty string

2006-05-08 13:28:53,806 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_indexing_attachments_separately) was null, returning empty string

2006-05-08 13:28:53,806 WARN [LmtpServer-1] [] misc - LC.get(debug_disable_indexing_attachments_together) was null, returning empty string

2006-05-08 13:28:53,872 INFO [LmtpServer-1] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.NANPHandler

2006-05-08 13:28:53,876 INFO [LmtpServer-1] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.TrackingHandler

2006-05-08 13:28:53,881 INFO [LmtpServer-1] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.URLHandler

2006-05-08 13:28:54,093 INFO [LmtpServer-1] [name=test@X.X;] FileBlobStore - Stored size=1344 wrote=1344 path=/opt/zimbra/store/incoming/1147057776038-0.msg vol=1 digest=Kah6KgB6giisXMN,6yCap5x8aHo=

2006-05-08 13:28:54,095 INFO [LmtpServer-1] [name=test@X.X;] FileBlobStore - Renamed id=257 mbox=4 oldpath=/opt/zimbra/store/incoming/1147057776038-0.msg newpath=/opt/zimbra/store/0/4/msg/0/257-3.msg

2006-05-08 13:28:54,270 INFO [LmtpServer-1] [name=test@X.X;] mailbox - Added message id=257 digest=Kah6KgB6giisXMN,6yCap5x8aHo= mailbox=4 rcpt=test@X.X

2006-05-08 13:29:38,850 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (1ms)

2006-05-08 13:29:40,766 INFO [Timer-0] [] stats - 05/08/2006 13:29:40,1,1344,1,1,1344,11,0.91,3,1.00,1,340.00,0.50,1.00,1,10.00,4,7.00,,,0.00,31.492,0,23,11,2,96,66,,0,0,0,1

2006-05-08 13:30:34,280 INFO [LmtpServer-1] [] LmtpHandler – [X.X.X.X] quit from client

2006-05-08 13:30:34,281 INFO [LmtpServer-1] [] ProtocolHandler - Handler exiting normally

2006-05-08 13:30:38,860 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)

2006-05-08 13:30:40,766 INFO [Timer-0] [] stats - 05/08/2006 13:30:40,,,,,,8,0.88,,,,,,,,,,,,,,31.492,0,23,11,2,96,66,,0,0,0,1

2006-05-08 13:32:38,880 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)

2006-05-08 13:32:40,770 INFO [Timer-0] [] stats - 05/08/2006 13:32:40,,,,,,8,0.75,,,,,,,,,,,,,,31.492,0,23,11,2,96,66,,0,0,0,1

2006-05-08 13:33:38,890 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)

2006-05-08 13:33:40,756 INFO [Timer-0] [] stats - 05/08/2006 13:33:40,,,,,,8,0.75,,,,,,,,,,,,,,32.329,0,23,11,2,96,66,,0,0,0,1

2006-05-08 13:34:38,900 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)

2006-05-08 13:34:40,767 INFO [Timer-0] [] stats - 05/08/2006 13:34:40,,,,,,8,0.75,,,,,,,,,1,0.00,,,,32.329,0,23,11,2,96,66,,0,0,0,1

2006-05-08 13:35:38,910 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)

2006-05-08 13:35:40,767 INFO [Timer-0] [] stats - 05/08/2006 13:35:40,,,,,,8,0.63,,,,,,,,,,,,,,32.329,0,23,11,2,96,66,,0,0,0,1

2006-05-08 13:36:38,920 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)

2006-05-08 13:36:40,770 INFO [Timer-0] [] stats - 05/08/2006 13:36:40,,,,,,9,0.78,,,,,,1.00,,,2,4.00,,,,33.387,0,23,11,2,96,66,,0,0,0,1


phoenix
Ambassador
Ambassador
Posts: 26727
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Web client logon fails (INVALID_PDU)

Postby phoenix » Mon May 08, 2006 1:22 am

Hi
Welcome to the forums. :)
Have you made any changes to the Zimbra configuration? Is this a new install or an upgrade? Is it running in a virtual machine or on real hardware? How much memory is on this system?
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
jermxx
Posts: 3
Joined: Fri Sep 12, 2014 10:10 pm

Web client logon fails (INVALID_PDU)

Postby jermxx » Mon May 08, 2006 1:51 am

Thanks for the welcome.
New install, no changes, standard install everything to check it out.
It is running in a Xen VM, with 1GB RAM.
phoenix
Ambassador
Ambassador
Posts: 26727
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Web client logon fails (INVALID_PDU)

Postby phoenix » Mon May 08, 2006 2:02 am

Just to confirm, is that 1Gb of memory allocated to the VM or 1Gb in total on the machine? When you say this problem ocured after a couple of day, did you mean that Zimbra had been running for a couple of days? What happens if you stop/restart Zimbra? It's just logging into the Zimbra GUI that's causing you problems?
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
jermxx
Posts: 3
Joined: Fri Sep 12, 2014 10:10 pm

Web client logon fails (INVALID_PDU)

Postby jermxx » Mon May 08, 2006 2:12 am

Sure, the 1GB of memory is the VM allocation. free reports about 512MB used, 512MB free. Zimbra had been running for a day or so before it exhibited this behaviour. I had been able to log in as admin immediately after completing the setup and had a look around, and then logged out. Then, the following day, I tried to do the same thing, and had this error. I had not touched anything in the interim.
Starting and stopping zimbra, and restarting the VM all looks normal - there are no errors thrown.
I can log into the zimbraAdmin GUI, and send and receive mail, but I can't log into the client (web) GUI.
Regards,

Jeremy
matthijsberg
Posts: 13
Joined: Fri Sep 12, 2014 10:09 pm

Web client logon fails (INVALID_PDU)

Postby matthijsberg » Mon May 15, 2006 1:25 am

[quote user="jermxx"]Sure, the 1GB of memory is the VM allocation. free reports about 512MB used, 512MB free. Zimbra had been running for a day or so before it exhibited this behaviour. I had been able to log in as admin immediately after completing the setup and had a look around, and then logged out. Then, the following day, I tried to do the same thing, and had this error. I had not touched anything in the interim.
Starting and stopping zimbra, and restarting the VM all looks normal - there are no errors thrown.
I can log into the zimbraAdmin GUI, and send and receive mail, but I can't log into the client (web) GUI.
Regards,

Jeremy[/QUOTE]
Hello all,
I have exactly the same problem running Zimbra 3.1 on redHat 4 (no VM or so). It worked verry wel for a couple of weeks but now, sinds a few days, I get the same error... maybe this info can help you solve it somehow.
Regards
Matthijs
UPDATE
I forgot, I changed the IP of the server, so the server was not reachable any more. It appears the error is generated from local cache.... :confused:
bpette
Posts: 9
Joined: Fri Sep 12, 2014 10:24 pm

Web client logon fails (INVALID_PDU)

Postby bpette » Thu Jan 25, 2007 12:43 am

Hi,
I got the same error message when I try to access zimbra via a web server (apache). If I access the zimbra directly (not via the web server), then it works fine. Any idea how to fix this?

Thks,
Ben
hiper
Posts: 12
Joined: Fri Sep 12, 2014 10:12 pm

Web client logon fails (INVALID_PDU)

Postby hiper » Tue Feb 20, 2007 11:29 am

I has the INVALID_PDU error when I'm logining in zimbra throught apache proxy reverse, but it work when I change to basic client in web login, What happen? some idea?

Im using apache proxy reverse for mapping zimbra as local service in front end -> some example: http://midominio.com/zimbra/, it fork fine for me, but the INVALID_PDU for login is a litle big problem for me.
bpette
Posts: 9
Joined: Fri Sep 12, 2014 10:24 pm

Web client logon fails (INVALID_PDU)

Postby bpette » Tue Feb 20, 2007 3:20 pm

I haven't managed to fix the problem using mod_proxy, but followed the instructions to use mod_jk

http://wiki.zimba.com/index.php?title=Zimbra_with_Apache_using_mod_jk

Using mod_jk works fine!!

Let me know if it works for you,
Ben

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests